summaryrefslogtreecommitdiff
path: root/sci-libs/h5part/h5part-1.6.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/h5part/h5part-1.6.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/h5part/h5part-1.6.6.ebuild')
-rw-r--r--sci-libs/h5part/h5part-1.6.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/h5part/h5part-1.6.6.ebuild b/sci-libs/h5part/h5part-1.6.6.ebuild
new file mode 100644
index 000000000000..3e15653d504a
--- /dev/null
+++ b/sci-libs/h5part/h5part-1.6.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P^^[hp]}"
+DESCRIPTION="Portable High Performance Parallel Data Interface to HDF5"
+HOMEPAGE="http://vis.lbl.gov/Research/H5Part/"
+SRC_URI="https://codeforge.lbl.gov/frs/download.php/latestfile/18/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ virtual/mpi
+ sci-libs/hdf5[mpi]
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-mpio.patch" )
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf --enable-parallel --enable-shared --disable-static CC=mpicc CXX=mpicxx
+}