summaryrefslogtreecommitdiff
path: root/sci-libs/gsl/gsl-2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-09 01:31:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-09 01:31:00 +0100
commitc956c264bdc853972b72016b752683468881af25 (patch)
treed6305ce3422074c4aaf3159ddd7a23bba7682e45 /sci-libs/gsl/gsl-2.7.ebuild
parent541eca7cf7b9950f0adaaf9158f94c76ba0aedc9 (diff)
gentoo auto-resync : 09:10:2022 - 01:31:00
Diffstat (limited to 'sci-libs/gsl/gsl-2.7.ebuild')
-rw-r--r--sci-libs/gsl/gsl-2.7.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sci-libs/gsl/gsl-2.7.ebuild b/sci-libs/gsl/gsl-2.7.ebuild
deleted file mode 100644
index ac5938b4fe8d..000000000000
--- a/sci-libs/gsl/gsl-2.7.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="https://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-2.7-cblas.patch.bz2"
-
-LICENSE="GPL-3"
-SLOT="0/25"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE="cblas-external +deprecated static-libs"
-
-RDEPEND="cblas-external? ( virtual/cblas:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${WORKDIR}"/${PN}-2.7-cblas.patch
-)
-
-src_prepare() {
- filter-flags -ffast-math
-
- default
-
- if use deprecated; then
- sed -i -e "/GSL_DISABLE_DEPRECATED/,+2d" configure.ac || die
- fi
- eautoreconf
-}
-
-src_configure() {
- if use cblas-external; then
- export CBLAS_LIBS="$($(tc-getPKG_CONFIG) --libs cblas)"
- export CBLAS_CFLAGS="$($(tc-getPKG_CONFIG) --cflags cblas)"
- fi
-
- econf \
- --enable-shared \
- $(use_with cblas-external) \
- $(use_enable static-libs static)
-}
-
-src_test() {
- local MAKEOPTS="${MAKEOPTS} -j1"
- default
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-}