summaryrefslogtreecommitdiff
path: root/sci-libs/gloo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
commitf5ef7f2371babf22c2c3fad17108692b09e4c98e (patch)
tree7f195ab30a74fa23e6dd24307d67d0890714d093 /sci-libs/gloo
parent3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (diff)
gentoo auto-resync : 02:05:2024 - 00:00:17
Diffstat (limited to 'sci-libs/gloo')
-rw-r--r--sci-libs/gloo/Manifest2
-rw-r--r--sci-libs/gloo/gloo-2023.12.03.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-libs/gloo/Manifest b/sci-libs/gloo/Manifest
index 110472e29860..4e73dd04f2dc 100644
--- a/sci-libs/gloo/Manifest
+++ b/sci-libs/gloo/Manifest
@@ -2,5 +2,7 @@ AUX gloo-2022.05.18-gentoo.patch 3073 BLAKE2B 0d6b4b4f87d8b8507b8ed06b3ea1548f75
AUX gloo-2023.01.17-cuda.patch 460 BLAKE2B 646004184eed2acbfb0cb54bdfadaa6cb4b3ac51b4323a6e16e825a3eabf0274061dcd8c1cfc996c72d75645176f3f798667caae33006d387bbd6ac1d00d4aa1 SHA512 649969154c42ef381c8220ea891ff3175292b2941efef0ce166bef137b1fb08d2f262de0961e3ce11661307a56c2338e7a7f81944e71b93aa5210bc2a7603caf
AUX gloo-2023.01.17-ssl3.patch 764 BLAKE2B e4abed8dc9f891da2a97c80e4aa3c7f68beed1143a039f22ed6add80cdb16b0543086b0d3c54628904743dd7901caa11a3281d9e574a256132ee3a1f4d52bb28 SHA512 259048a70a9ae9090b6e6631aba5787ce68b12facbf0d0c0200121ace780ffe30990b9240ba817f361e46025ec2cf22f3b6f06d8df8797848a16f8e4167253d2
DIST gloo-2023.07.19.tar.gz 260264 BLAKE2B b787794a6b5e791da5f8693ad9a522c8caa5410316d64ad3a2c23ae744ca9f0b45ac6a6f60572049d3e5825a2e29833ff887fc39f6fe6a6efef61d848c225318 SHA512 e84e8a69a8548a8bfcb6044b960fca3204eb358c50fa79f3053779f2a61703d5219ef428f4ba057ed08e6ec437aadb7f8e67565f03f3510e0bf94c6f793af8d9
+DIST gloo-2023.12.03.tar.gz 259857 BLAKE2B b56cbbb0986b70ed327a8d019f140099c5d1d725576120089cd5e640dc42daa6c6bb67de877d540fd2160f5b8d89cf54af7c11a1b81039e62e4de97daa4f63d6 SHA512 597679dd96394e7d0009be34ef9bd6f8446d22e2faa006c0853e055caf0d6d821c7532ff867b4d924197e92ab53c4c7ee9b74f897d6c5a469ee797c11ce0d28d
EBUILD gloo-2023.07.19.ebuild 1490 BLAKE2B 23670dfd2a9ab851845d019d0e24b44d21b392b75a6666d929cdca1a8fd7ca9f46f200e535e28cae022d7fa9c85aafe34c3b09611e42fe44cfca9eb4cee56489 SHA512 1dd5273720563e8af4eedd026593d21569c468862f1470d764435334aee669c9b0ed54523505ac924078318b8f1d701397442ea09810bf1b5de1d919264570d6
+EBUILD gloo-2023.12.03.ebuild 1490 BLAKE2B 6e3f632b88c9e5659a21a7a119747f9d9687adfbd18ebc6b3384f7bb3021f332aba93ea18e3bc04b6961b5e202c70dc361af1ee0e8f5df6e7fd76a8885ede0a3 SHA512 f1ae483ae15cc8ebcd24326ca1218bc0414ec5dea8aeb3a9c93e641d59d0537abd14bc8bcd4a8c87bf0ffefb6e27b04312e2d9a29a37c51219ae99f3ef61d720
MISC metadata.xml 492 BLAKE2B be64dabc0bd193d99c4458e6bad8c78042ef1d65800ebd3a3818ffdac3b361f18011ae044036e3c73deba03886e8aa6ffdcb5c2a66b635ecc2f29d636c660227 SHA512 e342a7d570f7ff12718f51e91fd6d359d038670dfb3b679a4cd8d7de61bef8d4b048e2362303bb925eddfd7c40e67f4179e89c24dc2f9b5c21e5a220bf9d4aa2
diff --git a/sci-libs/gloo/gloo-2023.12.03.ebuild b/sci-libs/gloo/gloo-2023.12.03.ebuild
new file mode 100644
index 000000000000..16201cde8c0d
--- /dev/null
+++ b/sci-libs/gloo/gloo-2023.12.03.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake cuda
+
+CommitId=5354032ea08eadd7fc4456477f7f7c6308818509
+
+DESCRIPTION="library of floating-point neural network inference operators"
+HOMEPAGE="https://github.com/facebookincubator/gloo/"
+SRC_URI="https://github.com/facebookincubator/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cuda libuv mpi redis ssl test"
+
+RDEPEND="
+ cuda? ( dev-util/nvidia-cuda-toolkit:= )
+ libuv? ( dev-libs/libuv )
+ mpi? ( virtual/mpi )
+ redis? (
+ dev-db/redis
+ dev-libs/hiredis
+ )
+ ssl? ( dev-libs/openssl:= )
+"
+DEPEND="${RDEPEND}
+"
+
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="test" # For some test the network is needed
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2022.05.18-gentoo.patch
+ "${FILESDIR}"/${PN}-2023.01.17-cuda.patch
+ "${FILESDIR}"/${PN}-2023.01.17-ssl3.patch
+)
+
+src_prepare() {
+ eapply_user
+ cmake_src_prepare
+ use cuda && cuda_add_sandbox
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test ON OFF)
+ -DUSE_CUDA=$(usex cuda ON OFF)
+ -DGLOO_USE_CUDA_TOOLKIT=$(usex cuda ON OFF)
+ -DUSE_LIBUV=$(usex libuv ON OFF)
+ -DUSE_MPI=$(usex mpi ON OFF)
+ -DUSE_REDIS=$(usex redis ON OFF)
+ -DUSE_TCP_OPENSSL_LINK=$(usex ssl ON OFF)
+ )
+ if use cuda; then
+ addpredict "/proc/self/task"
+
+ mycmakeargs+=(
+ -DCMAKE_CUDA_FLAGS="$(cuda_gccdir -f | tr -d \")"
+ )
+ fi
+ cmake_src_configure
+}