summaryrefslogtreecommitdiff
path: root/sci-libs/gloo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
commit2c359e29620429f94a60fc1e832048e54ee41eb5 (patch)
tree3a24152899725be0796179577e84caf957a80ce3 /sci-libs/gloo/files
parentd6a3ca89e16356791af128f18ca5d5aeaf1323e0 (diff)
gentoo auto-resync : 08:05:2023 - 23:39:55
Diffstat (limited to 'sci-libs/gloo/files')
-rw-r--r--sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch14
-rw-r--r--sci-libs/gloo/files/gloo-2023.01.17-cuda.patch13
2 files changed, 15 insertions, 12 deletions
diff --git a/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch b/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
index 09f7588a1858..1344d42a0c3f 100644
--- a/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
+++ b/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
@@ -12,7 +12,7 @@
set(GLOO_VERSION_PATCH 0)
--- a/gloo/CMakeLists.txt 2022-06-09 08:41:09.883773600 +0200
+++ b/gloo/CMakeLists.txt 2022-06-09 08:42:39.045637103 +0200
-@@ -176,7 +176,7 @@
+@@ -181,7 +181,7 @@
# want to statically link with Gloo and not install any artifacts.
if(GLOO_INSTALL)
install(TARGETS gloo EXPORT GlooTargets
@@ -23,7 +23,7 @@
DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
--- a/gloo/test/CMakeLists.txt 2022-06-10 22:17:03.682856314 +0200
+++ b/gloo/test/CMakeLists.txt 2022-06-10 22:17:49.671242697 +0200
-@@ -68,3 +68,4 @@
+@@ -73,3 +73,4 @@
gloo_hip_add_executable(gloo_test_hip ${GLOO_TEST_HIP_SRCS})
target_link_libraries(gloo_test_hip gloo_hip gtest OpenSSL::SSL OpenSSL::Crypto)
endif()
@@ -62,16 +62,6 @@
endif()
endif()
---- a/gloo/transport/tcp/device.cc 2022-08-02 11:25:32.404166606 +0200
-+++ b/gloo/transport/tcp/device.cc 2022-08-02 11:25:48.706963018 +0200
-@@ -12,6 +12,7 @@
- #include <netdb.h>
- #include <netinet/in.h>
- #include <string.h>
-+#include <array>
-
- #include "gloo/common/linux.h"
- #include "gloo/common/logging.h"
--- a/gloo/transport/tcp/tls/pair.cc 2022-10-04 21:14:04.099150060 +0200
+++ b/gloo/transport/tcp/tls/pair.cc 2022-10-04 21:14:22.330886610 +0200
@@ -17,6 +17,7 @@
diff --git a/sci-libs/gloo/files/gloo-2023.01.17-cuda.patch b/sci-libs/gloo/files/gloo-2023.01.17-cuda.patch
new file mode 100644
index 000000000000..1a894d3e4251
--- /dev/null
+++ b/sci-libs/gloo/files/gloo-2023.01.17-cuda.patch
@@ -0,0 +1,13 @@
+diff --git a/gloo/CMakeLists.txt b/gloo/CMakeLists.txt
+index 9ee82df..3b3affb 100644
+--- a/gloo/CMakeLists.txt
++++ b/gloo/CMakeLists.txt
+@@ -184,7 +184,7 @@ if(GLOO_INSTALL)
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ if(USE_CUDA)
+ install(TARGETS gloo_cuda EXPORT GlooTargets
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
++ DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
+ if(USE_ROCM)
+ install(TARGETS gloo_hip EXPORT GlooTargets