summaryrefslogtreecommitdiff
path: root/sci-libs/geos
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /sci-libs/geos
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/Manifest2
-rw-r--r--sci-libs/geos/geos-3.7.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 25c95a181deb..e20aeee6e652 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,4 +1,6 @@
AUX 3.4.2-solaris-isnan.patch 575 BLAKE2B 34e2fddd46e4e503630d0c44c03ee72ceb8bb19af31075ae209d0198b5db0839a633cbb7c855035bf8964d860174c56288579a4bd50e322d728ea4704d312108 SHA512 efa2730f178814e8d98318347e7a8313327679a5c861ef2a844ce821c5854f4dd56e0cc2c52fa5866fb4214b0d9aa8614b1f1ebaa62f0427e69221a93106aa45
DIST geos-3.6.2.tar.bz2 2030705 BLAKE2B f23cf1fc080fb7b353fb6292900d84811ace04a5364200bfea19f79d7b09a795d36e30cd6e4dbb7acd8417245bc2ce644298dc1b4140ef70495e4f7d71fc522b SHA512 515d8700b8a28282678e481faee355e3a43d7b70160472a63335b8d7225d9ba10437be782378f18f31a15288118126d411a2d862f01ce35d27c96f6bc0a73016
+DIST geos-3.7.0.tar.bz2 2028814 BLAKE2B 17385d9be831d4812391a30627e13989d3ca099ca9b0a719a92cdb2503dadff3693d4b3d320652764185db05782b33760ca14d155365d87167bb4ef6d6c2463c SHA512 fcca5e503efa32bb388376b2a06b9ca5c74fbcddba750cce6b3b4109eb2eb122058aead12b9462cdd881f425cd75d7241645ab344f25ce022bc0659954560742
EBUILD geos-3.6.2.ebuild 1342 BLAKE2B 2cdc55473a3c7e2f4cf45b77de88e3e359598e1b9a7f6ee33d221474853ad191c61692ed84b1648204fe71b4e8c3fec70710725a1f30f4c81c89c3607db6e51a SHA512 91f4a1f15927b151e2d7811410dfa3cf4ccee0a667751eb05f6ebdcaa12b2a8c38e0c6ce08018f22da7bb7220ac77846a5975d4dd439c230eb326718a03ea6ba
+EBUILD geos-3.7.0.ebuild 1348 BLAKE2B b1d14ccab7424bd6f3789fed0f482a3ba7729b87db3645e68c15aa17eee3e44eac3be356e7113db6052b916506113a08e37a7f3d92e0f5ddc8c615a98e7b4f68 SHA512 8bc9a1d54600f1092eace39c7d5ee120baa820d4338580bc7bb2ef4613e597986185e72d883983afd59bf07c6b195a3eff6a79ed8b115a09e4d5c508f62b8f3a
MISC metadata.xml 941 BLAKE2B 037cfbe59d6e841cfd50acce4eb41b58d1caf2459205cbb9432a1c2187a26196c09785665df2e8fd17498e672a1a66fb3d50f8bb8ced62e54bf963b821b93181 SHA512 cf93ad12e2e2d23ce6b454ae1032e8362beccd952a0f431780467c2985c07fa284edcb10a5d7b61d098a70c097f091a7f771be5a1650c1ed431ba249f73e5b1c
diff --git a/sci-libs/geos/geos-3.7.0.ebuild b/sci-libs/geos/geos-3.7.0.ebuild
new file mode 100644
index 000000000000..230e09c56c97
--- /dev/null
+++ b/sci-libs/geos/geos-3.7.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig:0 )
+ ruby? ( dev-lang/swig:0 )
+"
+
+PATCHES=( "${FILESDIR}"/3.4.2-solaris-isnan.patch )
+
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${D}" -name '*.la' -delete || die
+}