summaryrefslogtreecommitdiff
path: root/sci-libs/geos/geos-3.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /sci-libs/geos/geos-3.10.0.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'sci-libs/geos/geos-3.10.0.ebuild')
-rw-r--r--sci-libs/geos/geos-3.10.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-3.10.0.ebuild b/sci-libs/geos/geos-3.10.0.ebuild
new file mode 100644
index 000000000000..28033433e149
--- /dev/null
+++ b/sci-libs/geos/geos-3.10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="https://trac.osgeo.org/geos/"
+SRC_URI="https://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+
+ # bug #709368
+ $(usex arm '-DDISABLE_GEOS_INLINE=ON' '')
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc ; then
+ HTML_DOCS=( "${BUILD_DIR}"/doc/doxygen_docs/html/. )
+ einstalldocs
+ fi
+}