summaryrefslogtreecommitdiff
path: root/sci-libs/gdal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 15:09:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 15:09:32 +0100
commitf3a881e4cb31d574a107320b2f04e2d1f0ddf551 (patch)
tree0fb407d14cee6b3da0742b5060c92e9accb07fe0 /sci-libs/gdal
parent720452fca3cdf447b4c65bc3bb363032a983309e (diff)
gentoo auto-resync : 26:05:2023 - 15:09:32
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/Manifest2
-rw-r--r--sci-libs/gdal/gdal-3.7.0.ebuild18
2 files changed, 19 insertions, 1 deletions
diff --git a/sci-libs/gdal/Manifest b/sci-libs/gdal/Manifest
index 4a804cafa297..33b7f4edceb2 100644
--- a/sci-libs/gdal/Manifest
+++ b/sci-libs/gdal/Manifest
@@ -11,5 +11,5 @@ DIST gdalautotest-3.7.0.tar.gz 13785892 BLAKE2B cac18436ad2acb558e27e8ba3f1f2c22
EBUILD gdal-3.5.3-r1.ebuild 6692 BLAKE2B 2648c9ba25041e36dbb482964b2b5cdabddee82170232f1372b1f3436c16041e6675234407d5fb38d85a17753216fb29e6f41bdee417312ba78d0ef7b3173cae SHA512 9af7d1da2dbbb461e400ffad40e94546e08e40aeb2ef89db367e6b4981798ec0321e9a17e655c2fa46aedc89ae0739f1ee04c15a77d382fec4b30802156d2491
EBUILD gdal-3.6.2.ebuild 6761 BLAKE2B f792b599ddaeea5d8601b6669c5a13a076cd171469fc647b532286b4ae9011c4eee1131b13c8bd1c14d602deaf9431c7fa8d91e78f68a7198b38d5fad12ec103 SHA512 6096e471435679fdd5a4d307e3225a7965164806fd1080ab26ae6161088f9e85cc017ca42b41ab0b2570b32f4710aa3da4998d4c703a274b9e69bee13eb53865
EBUILD gdal-3.6.4.ebuild 6773 BLAKE2B 4ad17e071164a490ad2ed1f83209f58f7dd721381bd412a559f1cf13eafb1d6d25bc8d995e3daabd8b2db2f11cc04091d7117bbf509d66f43cd7dfd62298d128 SHA512 08c39be33e0b330ae81daf2b1e227fa5fa36192a6611e88fe1fd4b2e2105238a6d462e451cc377cb880f8eeb6650dc3405973f0e2c172caf7a224f0f4f991a6d
-EBUILD gdal-3.7.0.ebuild 7027 BLAKE2B 8995c2630f2d2d9749559ce2d13eb0ba2935c02e24cb707044ddfc775279ebe682e51c1a54ab49e9cc94d67720f495529b9b5679a8ba88298369dd93c5718aab SHA512 963575b670488d625e7701793d8e2e914a48bb9058a62c52501a51c4c06b4d8aae8cb809c8494edeefa2ca63b3ded3dcbc6ee94ac0564fff85bf8fc40f6255d2
+EBUILD gdal-3.7.0.ebuild 7740 BLAKE2B 871cc02626618847a4cd720459950ad103ec5124fab169b9c3359b5c3b4525aeba0618cbd04047022353495ab7de3e2d3253b42cb7caa4527d928b3ed89aeae9 SHA512 629569da1a7d6b474ac12d935787b1f68e4948434900c1fc3bdf8a8f0872c3660fa68260ebff827cb904dcc6a1da700c9a0c1c209c768ffde94b21fb70acfe48
MISC metadata.xml 1348 BLAKE2B 6666f26bc5f48bbfe1971736c6737420fefa7949cd6e1b74c649ae53cb51b756ebba42bb934930af83de254bebc4e4268f60a04ed2fb1aa8835b9abbdb3968b2 SHA512 b5b90368a48679c780dbe89b73ddee9e2c74639bf1a2c9f39dd4a3cdbb005878cd2197271f2ddc23d9611feaf79c0239b32d655d8a29592ad6d87a402970b726
diff --git a/sci-libs/gdal/gdal-3.7.0.ebuild b/sci-libs/gdal/gdal-3.7.0.ebuild
index 7015e10d415d..8e85dac1b17e 100644
--- a/sci-libs/gdal/gdal-3.7.0.ebuild
+++ b/sci-libs/gdal/gdal-3.7.0.ebuild
@@ -212,6 +212,9 @@ src_configure() {
# Bindings
-DBUILD_PYTHON_BINDINGS=$(usex python)
-DBUILD_JAVA_BINDINGS=$(usex java)
+ $(usev java -DJAVA_AWT_LIBRARY=/etc/java-config-2/current-system-vm/lib)
+ $(usev java -DJAVA_JVM_LIBRARY=/etc/java-config-2/current-system-vm/lib)
+ $(usev java -DJAVA_INCLUDE_PATH=/etc/java-config-2/current-system-vm/include)
# bug #845369
-DBUILD_CSHARP_BINDINGS=OFF
@@ -260,10 +263,25 @@ src_test() {
src_install() {
cmake_src_install
use python && python_optimize
+
+ if use java; then
+ # Move the native library into the proper place for Gentoo. The
+ # library in ${D} has already had its RPATH fixed, so we use it
+ # rather than ${BUILD_DIR}/swig/java/libgdalalljni.so.
+ java-pkg_doso "${D}/usr/share/java/libgdalalljni.so"
+ rm "${D}/usr/share/java/libgdalalljni.so" || die
+ fi
+
# TODO: install docs?
}
pkg_postinst() {
elog "Check available image and data formats after building with"
elog "gdalinfo and ogrinfo (using the --formats switch)."
+
+ if use java; then
+ elog
+ elog "To use the Java bindings, you need to pass the following to java:"
+ elog " -Djava.library.path=$(java-config -i gdal)"
+ fi
}