summaryrefslogtreecommitdiff
path: root/sci-libs/fplll
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-12 16:26:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-12 16:26:05 +0000
commit84685f125134bc8f4d6a523a861e8aeb26e301f9 (patch)
tree5146ec209fb7ddec33709f281ee437059fb4a24f /sci-libs/fplll
parentf1535b44d6fda761018ea432a180dcb482e97652 (diff)
gentoo auto-resync : 12:11:2023 - 16:26:05
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/Manifest2
-rw-r--r--sci-libs/fplll/fplll-5.4.5.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index 016b3b2c76af..d212c00f3179 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1,3 +1,5 @@
DIST fplll-5.4.4.tar.gz 2630101 BLAKE2B b990c9346acd2c506b4697f27ff21d8453bb97473b2e988beb2ab9da34b3edd8a64d7558bca5f66a888fb4397c1e5340cf50f543ec580f0ec6980bc8c73a9390 SHA512 32a6515a3ab2677739a60a4ef0938e4284b5d3119a396104a7af22a6291ef669b42a4fb6e59f5c6daf97ff2402e7d035ea84fd1c76bfe7c0e17402bd03ae7166
+DIST fplll-5.4.5.tar.gz 2630275 BLAKE2B 43d1601f401c3a4eba60939028b26f99d32f92b9d53b763768427d05b2d709645532c4fbb14556c8d8d92cc14efe86468469ed69a77bdb03af75ec08499cc17e SHA512 3e1281f1b993ebe4a767b7fc526f49a27d58f24b1b4c6074310cc971f6f569388d6ba27102087a2eb11671d2d5b87bd60306e2597567f4ae8dd2a9efd13beb77
EBUILD fplll-5.4.4.ebuild 608 BLAKE2B 0edc23808a661bd009ae7b4e737e2e6ff3331b66f90effd4e6e8ed58f7e49e81590280a84334163f07ca6544d66b00e4cd30598ef1c42e2178cd2502a3314bb6 SHA512 cf4cc0a7d6bdd3b7c04f5f575212f5b9c2c775ffabe30db35e50f71c39780ffb8ca163bfb90f950023254eaebe1442a242b608628117cec9f7c567b56019f672
+EBUILD fplll-5.4.5.ebuild 609 BLAKE2B 026d1aca2546eb033bcbd934d25eee8b7ae42798febd3c8fdd46243675bca07310d1b4f5840322fefb921f1e1f699b8d9b939da6c61606e3a07a09c24b8ece02 SHA512 2f83e6daf53eb8ec3e9a34d203fc0ea86c4fe9154ba381a6087a9cc0e1ff4602f851f1c3ed0bf00509adc0d3a56556009a88e1f464721757eee189402a8efc6e
MISC metadata.xml 858 BLAKE2B e27b47f6a8d0bb3c17eb023c24f95472c5f791e8a9bf86c1805d1c832b0973a665fe2231f82a289c37afd5318deb89717029ae6694005ade8e112a2769a56170 SHA512 49b6fd4968670fb0da92a883b81420e4739a893a6866ae500106181df5182324e616ccee8e0f290a7cda20f3f4d850fbf9a9462d03f0057da9ced4ba1d835ba7
diff --git a/sci-libs/fplll/fplll-5.4.5.ebuild b/sci-libs/fplll/fplll-5.4.5.ebuild
new file mode 100644
index 000000000000..d8ad2144d60b
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.4.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8"
+KEYWORDS="~amd64 ~x86"
+IUSE="qd"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}