summaryrefslogtreecommitdiff
path: root/sci-libs/fplll/fplll-4.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/fplll/fplll-4.0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/fplll/fplll-4.0.4.ebuild')
-rw-r--r--sci-libs/fplll/fplll-4.0.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/fplll/fplll-4.0.4.ebuild b/sci-libs/fplll/fplll-4.0.4.ebuild
new file mode 100644
index 000000000000..bb87e6a41656
--- /dev/null
+++ b/sci-libs/fplll/fplll-4.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Different implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="http://perso.ens-lyon.fr/damien.stehle/index.html#software"
+SRC_URI="http://perso.ens-lyon.fr/damien.stehle/fplll/lib${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/gmp-4.2.0:0
+ >=dev-libs/mpfr-2.3.0:0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/lib${P}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README" default
+ dohtml README.html
+ prune_libtool_files
+}