summaryrefslogtreecommitdiff
path: root/sci-libs/fcl/fcl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/fcl/fcl-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/fcl/fcl-9999.ebuild')
-rw-r--r--sci-libs/fcl/fcl-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/fcl/fcl-9999.ebuild b/sci-libs/fcl/fcl-9999.ebuild
new file mode 100644
index 000000000000..6d823b172040
--- /dev/null
+++ b/sci-libs/fcl/fcl-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cpu_flags_x86_sse"
+
+RDEPEND="
+ sci-libs/octomap
+ sci-libs/flann
+ dev-libs/boost:=[threads]
+ sci-libs/libccd"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}