summaryrefslogtreecommitdiff
path: root/sci-libs/dmlc-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-libs/dmlc-core
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-libs/dmlc-core')
-rw-r--r--sci-libs/dmlc-core/Manifest2
-rw-r--r--sci-libs/dmlc-core/dmlc-core-0_p20170719-r1.ebuild (renamed from sci-libs/dmlc-core/dmlc-core-0_p20170719.ebuild)50
2 files changed, 30 insertions, 22 deletions
diff --git a/sci-libs/dmlc-core/Manifest b/sci-libs/dmlc-core/Manifest
index e325528e3b10..11a4da14c74b 100644
--- a/sci-libs/dmlc-core/Manifest
+++ b/sci-libs/dmlc-core/Manifest
@@ -1,4 +1,4 @@
AUX dmlc-core-install-dirs.patch 1206 BLAKE2B df1f1520f3e6b21ef7dc30d6f2d73f888c639bdbbfe824ed89a5a7a9fa7b9dabb94704d6ba1ee9a95274b66b5160c560538cdb252804cfdeb304f7b8727cddb5 SHA512 ceee3e6f6f02e4a96167f12ffb50cbbc3bfbf07d025acb002139072ac73cf02adcd9c8f7a7b371055a68a61a104bf16ad95d7a3769edc3ad2dc63be36ff45ff5
DIST dmlc-core-0_p20170719.tar.gz 160242 BLAKE2B 2752968c831b5468cb926fbd2783098d1d66f5dd7f06b1abf138e165c637a3c16d477b04b709a05826528ee8e35ed61b563bdaae958fb91c78591dd57761a5f4 SHA512 2e2d79800839652772f07deb5ea3aa470cc5a18d2d0e480b8f4a1598aca72443546a438f3309708268cc49cf2d65684c3366cfc6c33c085baf1b804b4c04f02e
-EBUILD dmlc-core-0_p20170719.ebuild 2282 BLAKE2B d0fe3e790ce2a513321724c6f3a5f1049abb2e8196f3828ac803496ddc708ae6545cbfdc1f92ac46c9fa7e7c16c3c8abfdc9275a54cae4b83e2553f13b58153d SHA512 41d6bc00e62ba174617a6c46103ae9397757a34c767b1d4087381c551db145473aae7914699e243597bf9cb8e82b93d5f3bf1140f91d0e666ce777c8d3a78c42
+EBUILD dmlc-core-0_p20170719-r1.ebuild 2260 BLAKE2B 9d594bd7f58f7070d32480a5512859f65afbbdd355d558e9f13e05c622f2871ad75a5159b04c5f34ad6d2f352bb0326395e859e095b719511cd4def2129ed01a SHA512 cfd9d3b3a14be0a225db85ed00b19c7b0ac846af424a6de43807385095745fd5146719142b4a8eec58256c5bba9c0aa8feae09d9e22a4d4411d40510f1d93254
MISC metadata.xml 703 BLAKE2B 62473feed3c698cf3f2155aaad65ca27c504f6009932d0b402848f4c0192448ef74f1a8a789fbb97f7970f49eb4b8279535e539d2fe5a68dd97714f45ba500a7 SHA512 4328a90286999ba528b6d4c46d69d46ebb973ff41528b97560ec6759281cefbd271ef89f9344c22779321ca7e89e8f4a462ac344fd5e1624b971bcc1d4c215a6
diff --git a/sci-libs/dmlc-core/dmlc-core-0_p20170719.ebuild b/sci-libs/dmlc-core/dmlc-core-0_p20170719-r1.ebuild
index 06b9ed11eaae..991dc719c890 100644
--- a/sci-libs/dmlc-core/dmlc-core-0_p20170719.ebuild
+++ b/sci-libs/dmlc-core/dmlc-core-0_p20170719-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit toolchain-funcs cmake-utils
+inherit cmake toolchain-funcs
DESCRIPTION="Common bricks library for building distributed machine learning"
HOMEPAGE="https://github.com/dmlc/dmlc-core"
@@ -12,10 +12,11 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/dmlc/${PN}.git"
inherit git-r3
else
- EGIT_COMMIT="54db57d5d1b2a7b93319053011802888b827a539"
+ MY_COMMIT="54db57d5d1b2a7b93319053011802888b827a539"
inherit vcs-snapshot
+ SRC_URI="https://github.com/dmlc/dmlc-core/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://github.com/dmlc/dmlc-core/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="Apache-2.0"
@@ -28,9 +29,11 @@ RESTRICT="!test? ( test )"
RDEPEND="net-misc/curl[ssl]"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- test? ( dev-cpp/gtest )
-"
+ test? ( dev-cpp/gtest )"
+BDEPEND="doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-fontutils
+ )"
PATCHES=( "${FILESDIR}"/${PN}-install-dirs.patch )
@@ -43,13 +46,15 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
- # respect user flags (SSE2 does nothing more than adding -msse2)
- # also doc install everything so remove
+ cmake_src_prepare
+
+ # Respect user flags (SSE2 does nothing more than adding -msse2)
+ # Also doc installs everything, so remove
sed -e '/-O3/d' \
-e '/check_cxx.*SSE2/d' \
-i CMakeLists.txt || die
- # all these hacks below to allow testing
+
+ # All these hacks below to allow testing
sed -e 's|-O3||' -e 's|-lm|-lm -L$(LD_LIBRARY_PATH) -ldmlc|g' -i Makefile || die
sed -e "s|libdmlc.a||g" \
-i test/dmlc_test.mk test/unittest/dmlc_unittest.mk || die
@@ -66,15 +71,16 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DUSE_S3="$(usex s3)"
- -DUSE_OPENMP="$(usex openmp)"
+ -DUSE_S3=$(usex s3)
+ -DUSE_OPENMP=$(usex openmp)
)
- cmake-utils_src_configure
+
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
+
if use doc; then
doxygen doc/Doxyfile || die
fi
@@ -82,16 +88,18 @@ src_compile() {
src_test() {
tc-export CXX
- export LD_LIBRARY_PATH="${BUILD_DIR}"
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${BUILD_DIR}"
+
emake test
+
test/unittest/dmlc_unittest || die
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
+
if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r doc/doxygen/html
+ dodoc -r doc/doxygen/html
docompress -x /usr/share/doc/${PF}/html
fi
}