summaryrefslogtreecommitdiff
path: root/sci-libs/dmlc-core/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/dmlc-core/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/dmlc-core/files')
-rw-r--r--sci-libs/dmlc-core/files/dmlc-core-install-dirs.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/dmlc-core/files/dmlc-core-install-dirs.patch b/sci-libs/dmlc-core/files/dmlc-core-install-dirs.patch
new file mode 100644
index 000000000000..06f87f701754
--- /dev/null
+++ b/sci-libs/dmlc-core/files/dmlc-core-install-dirs.patch
@@ -0,0 +1,38 @@
+From 536ba11dfdaa7feacc7fe5726a3a50e4d663da13 Mon Sep 17 00:00:00 2001
+From: Maarten de Vries <maarten@de-vri.es>
+Date: Fri, 26 May 2017 15:29:29 +0200
+Subject: [PATCH] Use GNUInstallDirs for standard conforming install target.
+
+---
+ CMakeLists.txt | 18 +++++++-----------
+ 1 file changed, 7 insertions(+), 11 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0b3b3ec..316e2f5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -121,18 +121,13 @@ endif()
+ add_library(dmlc ${SOURCE})
+ target_link_libraries(dmlc ${dmlccore_LINKER_LIBS})
+
+-# ---[ Install Includes
+-if(INSTALL_INCLUDE_DIR)
+- add_custom_command(TARGET dmlc POST_BUILD
+- COMMAND ${CMAKE_COMMAND} -E copy_directory
+- ${PROJECT_SOURCE_DIR}/include ${INSTALL_INCLUDE_DIR}/
+- )
+-endif()
+-
+ # ---[ Install the archive static lib and header files
+-install(TARGETS dmlc ARCHIVE DESTINATION lib)
+-install(DIRECTORY include DESTINATION .)
+-install(DIRECTORY doc DESTINATION .)
++include(GNUInstallDirs)
++install(TARGETS dmlc
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++)
++install(DIRECTORY include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ # ---[ Linter target
+ if(MSVC)