summaryrefslogtreecommitdiff
path: root/sci-libs/dealii/dealii-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sci-libs/dealii/dealii-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sci-libs/dealii/dealii-9999.ebuild')
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index 35dcbc94b523..14d898de7089 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,24 +19,20 @@ if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
else
- MY_PV="${PV//0_rc/rc}"
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz -> ${P}.tar.gz
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz
doc? (
- https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}-offline_documentation.tar.gz
- -> ${P}-offline_documentation.tar.gz
+ https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}-offline_documentation.tar.gz
)"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}-${MY_PV}"
fi
LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="
adolc assimp arpack cpu_flags_x86_avx cpu_flags_x86_avx512f
- cpu_flags_x86_sse2 cuda +debug doc +examples gmsh +gsl hdf5 +lapack
- metis mpi muparser nanoflann opencascade netcdf p4est petsc scalapack
- slepc +sparse static-libs sundials symengine +tbb trilinos
+ cpu_flags_x86_sse2 cuda +debug doc +examples ginkgo gmsh +gsl hdf5
+ +lapack metis mpi muparser nanoflann opencascade netcdf p4est petsc
+ scalapack slepc +sparse static-libs sundials symengine +tbb trilinos
"
# TODO: add slepc use flag once slepc is packaged for gentoo-science
@@ -52,6 +48,7 @@ RDEPEND="dev-libs/boost
arpack? ( sci-libs/arpack[mpi=] )
assimp? ( media-libs/assimp )
cuda? ( dev-util/nvidia-cuda-sdk )
+ ginkgo? ( sci-libs/ginkgo )
gmsh? ( sci-libs/gmsh )
gsl? ( sci-libs/gsl )
hdf5? ( sci-libs/hdf5[mpi=] )
@@ -102,6 +99,7 @@ src_configure() {
-DDEAL_II_WITH_ASSIMP="$(usex assimp)"
-DDEAL_II_WITH_ARPACK="$(usex arpack)"
-DDEAL_II_WITH_CUDA="$(usex cuda)"
+ -DDEAL_II_WITH_GINKGO="$(usex ginkgo)"
-DDEAL_II_COMPONENT_DOCUMENTATION="$(usex doc)"
-DDEAL_II_COMPONENT_EXAMPLES="$(usex examples)"
-DDEAL_II_WITH_GMSH="$(usex gmsh)"