summaryrefslogtreecommitdiff
path: root/sci-libs/datasets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-16 04:05:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-16 04:05:53 +0100
commitd7665b9dae37c3b9a1c72157fdf49c101bd6495e (patch)
tree6346f889dbe3164a49e89d92ec5914494af4b865 /sci-libs/datasets
parentaffa75f527bf2512b296482bd14bade15f820d6a (diff)
gentoo auto-resync : 16:05:2023 - 04:05:52
Diffstat (limited to 'sci-libs/datasets')
-rw-r--r--sci-libs/datasets/Manifest2
-rw-r--r--sci-libs/datasets/files/datasets-2.11.0-tests.patch82
2 files changed, 83 insertions, 1 deletions
diff --git a/sci-libs/datasets/Manifest b/sci-libs/datasets/Manifest
index 7f194fcc9e7a..0848e70af632 100644
--- a/sci-libs/datasets/Manifest
+++ b/sci-libs/datasets/Manifest
@@ -1,4 +1,4 @@
-AUX datasets-2.11.0-tests.patch 6391 BLAKE2B ce947a4c52b224d860b58ee7cbe2cbeb006d0f532b29b6d67e2d3a60fcad50e6a9e63534bc6dccb8a6d83ddaca6b8bce81fafafa22265f5ac44964347e18244c SHA512 a89d57195acbc5e99d7dc4adbd1dde0f04461421fbfef8735964ff41e90b071f03526acbfe4a266ae8a4e3a1796c39ffebe299a8638c2a476d23d1c75f8495ee
+AUX datasets-2.11.0-tests.patch 8857 BLAKE2B 669d4053c2feabbdba7405782ad32d09a63cac3b0423b48b6e79c92df1e696b902ef10fed03b01e3348e57f9321d4dcf28420c3458115043412c1990e8a9849c SHA512 8c5c99f9babf608489209b345ad0759e1582a81b39605e535fd046bd6b639d4ccc40e43cc51098be0f27c8afe7e75d6539f20a065d38dabc0b88f0e42cd857a4
DIST datasets-2.11.0.gh.tar.gz 2141289 BLAKE2B 0fb471dd6ee5de3831eb6586c4a15e67381262470b72d5ab02ee87dfc7977cb4d40e04da6507049d1e47cb8948cad11988bb7627293b48231e1cd413d2cfb885 SHA512 9ec2274d7978e3dde1b2f8ce78dd65bdf66742bbfee7b8672af46216aeaae3ef5c4604a8a5ea0bdee808f1c362cca9a122c16d2e9a161678148e581e4cd5c863
EBUILD datasets-2.11.0-r1.ebuild 1330 BLAKE2B 9a2ce5b9420d51ec0cd4e925a3619f4382534c607e9100b6f90a947a8814040dda202485b470bb491af391d877d370a92841c95f64181f2646505a97a75fc171 SHA512 18fb6c7cd4109510274112284d740b2c052ce54d6c6f31ece8d55bbb2f959435125b71a7fb7f580d885295ec6744852ffa938ad8fd79302b34b13039c6fb15c3
MISC metadata.xml 379 BLAKE2B 48ebb9e7bfa8b58b0d15b82c4146def465e08cf3212ab4af04129d09c153b67b00d0fa05b94d6af54f643ec3a202f2335d3254b966f49d1394d3c7b9e5da56a5 SHA512 99560decfaa0e438980f372d99257695e9ca9585167d9aba091e0b775c2f8384657ddc017841c8f06f8b568017a54fb9e31da736f3c875da717e154cdce876d1
diff --git a/sci-libs/datasets/files/datasets-2.11.0-tests.patch b/sci-libs/datasets/files/datasets-2.11.0-tests.patch
index 0bbf200acbd0..0babe8b23d58 100644
--- a/sci-libs/datasets/files/datasets-2.11.0-tests.patch
+++ b/sci-libs/datasets/files/datasets-2.11.0-tests.patch
@@ -168,3 +168,85 @@
def test_task_automatic_speech_recognition(self):
# Include a dummy extra column `dummy` to test we drop it correctly
features_before_cast = Features(
+--- a/tests/test_streaming_download_manager.py 2023-05-15 23:06:59.146379973 +0200
++++ b/tests/test_streaming_download_manager.py 2023-05-15 23:11:32.441363757 +0200
+@@ -217,6 +217,7 @@
+ assert output_path == _readd_double_slash_removed_by_path(Path(expected_path).as_posix())
+
+
++@pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, exists",
+ [
+@@ -299,6 +300,7 @@
+ assert list(f) == TEST_URL_CONTENT.splitlines(keepends=True)
+
+
++@pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, expected_paths",
+ [
+@@ -328,6 +330,7 @@
+ xlistdir(root_url, use_auth_token=hf_token)
+
+
++@pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, isdir",
+ [
+@@ -355,6 +358,7 @@
+ xisdir(root_url, use_auth_token=hf_token)
+
+
++@pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, isfile",
+ [
+@@ -378,6 +382,7 @@
+ assert xisfile(root_url + "qwertyuiop", use_auth_token=hf_token) is False
+
+
++@pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, size",
+ [
+@@ -402,6 +407,7 @@
+ xgetsize(root_url + "qwertyuiop", use_auth_token=hf_token)
+
+
++@pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, expected_paths",
+ [
+@@ -444,6 +450,7 @@
+ assert len(xglob("zip://qwertyuiop/*::" + root_url, use_auth_token=hf_token)) == 0
+
+
++@pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, expected_outputs",
+ [
+@@ -533,6 +540,7 @@
+ def test_xpath_as_posix(self, input_path, expected_path):
+ assert xPath(input_path).as_posix() == expected_path
+
++ @pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, exists",
+ [
+@@ -548,6 +556,7 @@
+ (tmp_path / "file.txt").touch()
+ assert xexists(input_path) is exists
+
++ @pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, pattern, expected_paths",
+ [
+@@ -586,6 +595,7 @@
+ output_paths = sorted(xPath(input_path).glob(pattern))
+ assert output_paths == expected_paths
+
++ @pytest.mark.skip(reason="not working in sandbox")
+ @pytest.mark.parametrize(
+ "input_path, pattern, expected_paths",
+ [