summaryrefslogtreecommitdiff
path: root/sci-libs/datasets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
commit2c359e29620429f94a60fc1e832048e54ee41eb5 (patch)
tree3a24152899725be0796179577e84caf957a80ce3 /sci-libs/datasets
parentd6a3ca89e16356791af128f18ca5d5aeaf1323e0 (diff)
gentoo auto-resync : 08:05:2023 - 23:39:55
Diffstat (limited to 'sci-libs/datasets')
-rw-r--r--sci-libs/datasets/Manifest2
-rw-r--r--sci-libs/datasets/files/datasets-2.11.0-tests.patch28
2 files changed, 16 insertions, 14 deletions
diff --git a/sci-libs/datasets/Manifest b/sci-libs/datasets/Manifest
index 3274fb3f5b10..60c41a959a09 100644
--- a/sci-libs/datasets/Manifest
+++ b/sci-libs/datasets/Manifest
@@ -1,4 +1,4 @@
-AUX datasets-2.11.0-tests.patch 6408 BLAKE2B aed33ac39b4bd1b3a75776a6efc93b03817b09cf63ee582f72a4acf48149ce7865bc3f4501f67dbc73d02c478732d8c953c54cf66918b70e22fdea6393c639da SHA512 88e9f86af80c2197282a9d8878a9319d7d7e63937a7bdc17ad8ae51e53ed49c1b98a9e8476c161d1eb6dc3a603ebd95c5f822c5078c5eea59cc2d86cda591fbd
+AUX datasets-2.11.0-tests.patch 6391 BLAKE2B ce947a4c52b224d860b58ee7cbe2cbeb006d0f532b29b6d67e2d3a60fcad50e6a9e63534bc6dccb8a6d83ddaca6b8bce81fafafa22265f5ac44964347e18244c SHA512 a89d57195acbc5e99d7dc4adbd1dde0f04461421fbfef8735964ff41e90b071f03526acbfe4a266ae8a4e3a1796c39ffebe299a8638c2a476d23d1c75f8495ee
DIST datasets-2.11.0.gh.tar.gz 2141289 BLAKE2B 0fb471dd6ee5de3831eb6586c4a15e67381262470b72d5ab02ee87dfc7977cb4d40e04da6507049d1e47cb8948cad11988bb7627293b48231e1cd413d2cfb885 SHA512 9ec2274d7978e3dde1b2f8ce78dd65bdf66742bbfee7b8672af46216aeaae3ef5c4604a8a5ea0bdee808f1c362cca9a122c16d2e9a161678148e581e4cd5c863
EBUILD datasets-2.11.0.ebuild 1393 BLAKE2B 9a4e44ff67d4dfceffa95b8710a6f7dd5b97d071cfcd1dbeb86d9c9a52168f211cc65f02268a94a5f6e41871e8caededab126ec9e109862d1d4b3b66b88938ae SHA512 b7aef0e39a2693af36e478c857b1e339ae5ef46b45f9477eacdac08aa737c53bf99e0c7f2d418a7ac5fe5e8dbbdbe4bfb1ab28bc801219f8c3e07bb84632eae3
MISC metadata.xml 379 BLAKE2B 48ebb9e7bfa8b58b0d15b82c4146def465e08cf3212ab4af04129d09c153b67b00d0fa05b94d6af54f643ec3a202f2335d3254b966f49d1394d3c7b9e5da56a5 SHA512 99560decfaa0e438980f372d99257695e9ca9585167d9aba091e0b775c2f8384657ddc017841c8f06f8b568017a54fb9e31da736f3c875da717e154cdce876d1
diff --git a/sci-libs/datasets/files/datasets-2.11.0-tests.patch b/sci-libs/datasets/files/datasets-2.11.0-tests.patch
index 01e5d9c70e7b..0bbf200acbd0 100644
--- a/sci-libs/datasets/files/datasets-2.11.0-tests.patch
+++ b/sci-libs/datasets/files/datasets-2.11.0-tests.patch
@@ -59,7 +59,7 @@
@pytest.mark.parametrize(
"build_example",
[
-@@ -82,6 +82,7 @@
+@@ -81,6 +82,7 @@
assert decoded_example.keys() == {"path", "array", "sampling_rate"}
@@ -75,7 +75,7 @@
@pytest.mark.parametrize("sampling_rate", [16_000, 48_000])
def test_audio_decode_example_pcm(shared_datadir, sampling_rate):
audio_path = str(shared_datadir / "test_audio_16000.pcm")
-@@ -416,6 +417,7 @@
+@@ -414,6 +417,7 @@
assert column[0]["sampling_rate"] == 16000
@@ -83,7 +83,7 @@
@pytest.mark.parametrize(
"build_data",
[
-@@ -440,6 +442,7 @@
+@@ -438,6 +442,7 @@
assert item["audio"].keys() == {"path", "array", "sampling_rate"}
@@ -91,7 +91,7 @@
def test_dataset_concatenate_audio_features(shared_datadir):
# we use a different data structure between 1 and 2 to make sure they are compatible with each other
audio_path = str(shared_datadir / "test_audio_44100.wav")
-@@ -453,6 +456,7 @@
+@@ -451,6 +456,7 @@
assert concatenated_dataset[1]["audio"]["array"].shape == dset2[0]["audio"]["array"].shape
@@ -99,7 +99,7 @@
def test_dataset_concatenate_nested_audio_features(shared_datadir):
# we use a different data structure between 1 and 2 to make sure they are compatible with each other
audio_path = str(shared_datadir / "test_audio_44100.wav")
-@@ -616,6 +616,7 @@
+@@ -610,6 +616,7 @@
assert isinstance(ds, Dataset)
@@ -107,7 +107,7 @@
def test_dataset_with_audio_feature_undecoded(shared_datadir):
audio_path = str(shared_datadir / "test_audio_44100.wav")
data = {"audio": [audio_path]}
-@@ -633,6 +634,7 @@
+@@ -627,6 +634,7 @@
assert column[0] == {"path": audio_path, "bytes": None}
@@ -115,7 +115,7 @@
def test_formatted_dataset_with_audio_feature_undecoded(shared_datadir):
audio_path = str(shared_datadir / "test_audio_44100.wav")
data = {"audio": [audio_path]}
-@@ -664,6 +666,7 @@
+@@ -658,6 +666,7 @@
assert column[0] == {"path": audio_path, "bytes": None}
@@ -135,24 +135,26 @@
wrong_scheme = "ERROR"
--- a/tests/packaged_modules/test_audiofolder.py 2023-05-06 14:00:39.560876163 +0200
+++ b/tests/packaged_modules/test_audiofolder.py 2023-05-06 14:01:26.005212423 +0200
-@@ -4,7 +4,6 @@
- import librosa
+@@ -1,10 +1,8 @@
+ import shutil
+ import textwrap
+
+-import librosa
import numpy as np
import pytest
-import soundfile as sf
from datasets import Audio, ClassLabel, Features, Value
from datasets.data_files import DataFilesDict, get_data_patterns_locally
-@@ -191,9 +190,11 @@
- assert len(data_files_with_two_splits_and_metadata["test"]) == 2
+@@ -192,8 +190,11 @@
return data_files_with_two_splits_and_metadata
--
+
+@pytest.mark.skip(reason="require soundfile")
@pytest.fixture
def data_files_with_zip_archives(tmp_path, audio_file):
+ import soundfile as sf
-+
++ import librosa
data_dir = tmp_path / "audiofolder_data_dir_with_zip_archives"
data_dir.mkdir(parents=True, exist_ok=True)
archive_dir = data_dir / "archive"