summaryrefslogtreecommitdiff
path: root/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
commit4464bf26d93bdcc80e0b1330fe9c9caef26b34fc (patch)
tree62f9e9438bf700cf277191db5d7c3a641bc972dc /sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch
parent8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (diff)
gentoo auto-resync : 09:03:2024 - 01:07:53
Diffstat (limited to 'sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch')
-rw-r--r--sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch b/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch
new file mode 100644
index 000000000000..dd93b8af743a
--- /dev/null
+++ b/sci-libs/composable-kernel/files/composable-kernel-5.7.1-enable-test-examples.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -280,8 +280,14 @@ rocm_package_setup_component(profiler
+ )
+
+ add_subdirectory(library)
+-add_subdirectory(example)
+-add_subdirectory(test)
++option(BUILD_EXAMPLES "Build examples" OFF)
++if(BUILD_EXAMPLES)
++ add_subdirectory(example)
++endif()
++option(BUILD_TESTS "Build binaries for tests" OFF)
++if(BUILD_TESTS)
++ add_subdirectory(test)
++endif()
+ add_subdirectory(profiler)
+
+ #Create an interface target for the include only files and call it "composablekernels"