summaryrefslogtreecommitdiff
path: root/sci-libs/colpack/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/colpack/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/colpack/files')
-rw-r--r--sci-libs/colpack/files/colpack-1.0.6-flags.patch10
-rw-r--r--sci-libs/colpack/files/colpack-1.0.8-no-bin.patch15
-rw-r--r--sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch71
-rw-r--r--sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch26
4 files changed, 122 insertions, 0 deletions
diff --git a/sci-libs/colpack/files/colpack-1.0.6-flags.patch b/sci-libs/colpack/files/colpack-1.0.6-flags.patch
new file mode 100644
index 000000000000..6d4bb6a0d612
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.6-flags.patch
@@ -0,0 +1,10 @@
+diff -Nur ColPack-1.0.6.orig/Makefile.am ColPack-1.0.6/Makefile.am
+--- ColPack-1.0.6.orig/Makefile.am 2012-04-13 03:25:37.000000000 +0100
++++ ColPack-1.0.6/Makefile.am 2012-04-13 03:30:35.000000000 +0100
+@@ -1,5 +1,5 @@
+ ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
+-COLPACK_COMMON_FLAGS = $(EXTRA_FLAGS) -O5
++COLPACK_COMMON_FLAGS = $(EXTRA_FLAGS)
+
+ INCLUDES = $(COLPACK_COMMON_FLAGS) \
+ -I$(top_srcdir)/Main \
diff --git a/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch b/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch
new file mode 100644
index 000000000000..e9230b0ff105
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch
@@ -0,0 +1,15 @@
+From: Sebastien Fabbro <bicatali@gentoo.org>
+Avoid installing the ColPack binary on an absolute path
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -17,8 +17,7 @@
+ LDADD = libColPack.la
+ AM_DEFAULT_SOURCE_EXT = .cpp
+
+-noinst_bin_PROGRAMS = ColPack
+-noinst_bindir = $(abs_top_builddir)/progs
++noinst_PROGRAMS = ColPack
+ lib_LTLIBRARIES = libColPack.la
+ pkginclude_HEADERS = \
+ Utilities/CoutLock.h Utilities/command_line_parameter_processor.h \
diff --git a/sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch b/sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch
new file mode 100644
index 000000000000..7076be5426a3
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch
@@ -0,0 +1,71 @@
+From 44851d9e90d9847fbfeaaea7b0ed1e7c3d093dcb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <me@besser82.io>
+Date: Wed, 24 Feb 2016 23:26:20 +0100
+Subject: [PATCH] fix semantic errors in error-msgs
+
+---
+ Utilities/extra.cpp | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/Utilities/extra.cpp b/Utilities/extra.cpp
+index 21862e6..9f59263 100644
+--- a/Utilities/extra.cpp
++++ b/Utilities/extra.cpp
+@@ -49,7 +49,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+
+ ofstream out_Matrix (s_MatrixName.c_str());
+ if(!out_Matrix) {
+- cout<<"Error creating file: \""<<out_Matrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_MatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -84,7 +84,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_MatrixName = "pattern"+s_postfix+s_BaseName;
+ ofstream out_Matrix (s_MatrixName.c_str());
+ if(!out_Matrix) {
+- cout<<"Error creating file: \""<<out_Matrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_MatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -111,7 +111,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_CompressedMatrixName = "CompressedMatrix"+s_postfix+s_BaseName;
+ ofstream out_CompressedMatrix (s_CompressedMatrixName.c_str());
+ if(!out_CompressedMatrix) {
+- cout<<"Error creating file: \""<<out_CompressedMatrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_CompressedMatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -140,7 +140,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_MatrixName = "pattern_value"+s_postfix+s_BaseName;
+ ofstream out_Matrix (s_MatrixName.c_str());
+ if(!out_Matrix) {
+- cout<<"Error creating file: \""<<out_Matrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_MatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -167,7 +167,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_CompressedMatrixName = "CompressedMatrix"+s_postfix+s_BaseName;
+ ofstream out_CompressedMatrix (s_CompressedMatrixName.c_str());
+ if(!out_CompressedMatrix) {
+- cout<<"Error creating file: \""<<out_CompressedMatrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_CompressedMatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -671,7 +671,6 @@ int buildDotWithColor(ColPack::GraphColoringInterface &g, vector<string> &ListOf
+ }
+ }
+ }
+-
+ }
+ }
+ }
+@@ -1483,4 +1482,3 @@ int DisplayADICFormat_Value(std::list<std::vector<double> > &lvd_Value) {
+ }
+
+ #endif
+-
diff --git a/sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch b/sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch
new file mode 100644
index 000000000000..0510be9f90ef
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch
@@ -0,0 +1,26 @@
+Index: ColPack-1.0.9/BipartiteGraphPartialColoring/BipartiteGraphPartialColoring.cpp
+===================================================================
+--- ColPack-1.0.9.orig/BipartiteGraphPartialColoring/BipartiteGraphPartialColoring.cpp
++++ ColPack-1.0.9/BipartiteGraphPartialColoring/BipartiteGraphPartialColoring.cpp
+@@ -388,8 +388,9 @@ namespace ColPack
+ if ( m_vi_LeftVertexColors [m_vi_Edges [x]] == m_vi_LeftVertexColors[v] && f(v) > f(m_vi_Edges [x]) ) {
+ //Algo 4 - Line 18: add [v] to R ; cont <- false; break
+ #pragma omp critical
++ {
+ vi_verticesNeedNewColor.push_back(v);
+-#pragma omp end critical
++ }
+ cont = false;
+ break;
+ }
+@@ -575,8 +576,9 @@ namespace ColPack
+ if ( m_vi_RightVertexColors [m_vi_Edges [x]] == m_vi_RightVertexColors[v] && f(v) > f(m_vi_Edges [x]) ) {
+ //Algo 4 - Line 18: add [v] to R ; cont <- false; break
+ #pragma omp critical
++ {
+ vi_verticesNeedNewColor.push_back(v);
+-#pragma omp end critical
++ }
+ cont = false;
+ break;
+ }