summaryrefslogtreecommitdiff
path: root/sci-libs/colamd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
commit7d1fc8f13082082c2539f20beadcf37089543b8e (patch)
treefda7c412f8ace82836e911da18f1b0f6eaf8bc55 /sci-libs/colamd
parentbc4457d8e0e53a2e43c4254d08053ba9708663e1 (diff)
gentoo auto-resync : 20:06:2023 - 07:15:40
Diffstat (limited to 'sci-libs/colamd')
-rw-r--r--sci-libs/colamd/Manifest4
-rw-r--r--sci-libs/colamd/colamd-3.0.3.ebuild39
-rw-r--r--sci-libs/colamd/metadata.xml3
3 files changed, 45 insertions, 1 deletions
diff --git a/sci-libs/colamd/Manifest b/sci-libs/colamd/Manifest
index b79934f23971..399dd8b68aeb 100644
--- a/sci-libs/colamd/Manifest
+++ b/sci-libs/colamd/Manifest
@@ -1,3 +1,5 @@
+DIST SuiteSparse-7.0.0.gh.tar.gz 64884962 BLAKE2B 06c6cf54ffae188f5179e0cd45523700448d8999b44d6b1aeb3dfb99ccf34a570f6aff600988a144c68a4a2d8f41e32f7145e09349aed3bd889501ea031c8340 SHA512 50b1cd7bab6e4c063984162ed803fd13b69df7f67efe8ce7af15eace6b0ccd1669b6e57daa59511fd9531a847433cda49c1f52bfff234031af0d79e7fbd6423e
DIST colamd-2.9.6.tar.bz2 298903 BLAKE2B e1e3cfa0153e21b742854d28fb6d3ede287c2ec22cfef4268a8aba8bb239be527433907f6984dad976341cf6e1ca9cb39f5c97029ad9bed032a874add9aa0e02 SHA512 f302d18f9ba004c9d1b0e1ada76e70f20fa1d11896815e5300983513b7ed4a7b969adef33adb1a57d67ce856a5ded410874c23d9bba42b6bf1a6a790430f5137
EBUILD colamd-2.9.6.ebuild 662 BLAKE2B f69645b6178fc5c8c978290671609a246afcb060a43d1051c2d8c7cc0fd8c84410bc547222a7db5e194ba8879863c2fc56d12eef69b45748f88ef120f8e0d13d SHA512 ddfce73ebab4883861d8478031ee0be4d64dce993b56253d245f51deb53b897df4206869089e12d37a33440d36e2240a7170afd140b7eab95d4d84fa694b484c
-MISC metadata.xml 830 BLAKE2B dd4aff550cd72c649f492792e6c1132e01416c7065f6887bb5d3510e120af9465c88818ca41dccf67f672a2542f3951bfb001de8d9f97f39711d6b55cfcfe64e SHA512 8078fc04ebfdeb092c21d90f785f41be5887f2cd6b68a2431a6bfffeec81ff9bdac66a68763217a1780e593957bea458c8b86a02291cf1698cf1eed7b601c3df
+EBUILD colamd-3.0.3.ebuild 1263 BLAKE2B b71b43f26202b318a011bca0b687203076445917ca8eee7f645f2257a0a06c72b3863c1b0f7aaf2af1921b2460739f9ddea743898efb341e4e8cb06a778a0fd8 SHA512 5411a366f893ec935893ae586ea828808cdbffce6ab89a030e7fe34af364e621b15726ebdf96cf5e2d5139d39a8f3f389d639bc4db48435954d79d89f214b641
+MISC metadata.xml 930 BLAKE2B 5d1504e999e351fdc13fb95a02316df866a82a05eca0296e6e80cee34226c470da5de8e065152057f26ee0eb8527f9e00f631d29982e6dc05c1197eb4d6ae5da SHA512 456f5ce12f30b0c52c5dc49cd763194175b18bc4c29d31d90c217e93bfe17847d201a2f3f3f8378497b14430aa412755eaebc11767f66a3ce12f24319c008fa9
diff --git a/sci-libs/colamd/colamd-3.0.3.ebuild b/sci-libs/colamd/colamd-3.0.3.ebuild
new file mode 100644
index 000000000000..b0a4af5bedc1
--- /dev/null
+++ b/sci-libs/colamd/colamd-3.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+Sparse_PV="7.0.0"
+Sparse_P="SuiteSparse-${Sparse_PV}"
+DESCRIPTION="Column approximate minimum degree ordering algorithm"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-libs/suitesparseconfig-${Sparse_PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${Sparse_P}/${PN^^}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNSTATIC=ON
+ -DDEMO=$(usex test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ # Run demo files
+ ./colamd_example > colamd_example.out || die "failed to run test colamd_example"
+ diff "${S}"/Demo/colamd_example.out colamd_example.out || die "failed testing colamd_example"
+ ./colamd_l_example > colamd_l_example.out || die "failed to run test colamd_l_example"
+ diff "${S}"/Demo/colamd_l_example.out colamd_l_example.out || die "failed testing colamd_l_example"
+}
diff --git a/sci-libs/colamd/metadata.xml b/sci-libs/colamd/metadata.xml
index 249c30df3a5c..568cb46d3cfe 100644
--- a/sci-libs/colamd/metadata.xml
+++ b/sci-libs/colamd/metadata.xml
@@ -15,4 +15,7 @@
matrix M such that M\'*M has the same pattern as A, and then uses
COLAMD to compute a column ordering of M.
</longdescription>
+ <upstream>
+ <remote-id type="github">DrTimothyAldenDavis/SuiteSparse</remote-id>
+ </upstream>
</pkgmetadata>