summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-vol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 08:09:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 08:09:34 +0100
commitda3552023d9aae2ee5183df71a80a8169414974e (patch)
treed26518a0f3fb7b5f62d9fa5f546757d405f4d380 /sci-libs/coinor-vol
parent51f0d16e058c162dbce0f93d871ba45683b0ab3a (diff)
gentoo auto-resync : 06:08:2022 - 08:09:34
Diffstat (limited to 'sci-libs/coinor-vol')
-rw-r--r--sci-libs/coinor-vol/Manifest3
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild6
-rw-r--r--sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch24
3 files changed, 31 insertions, 2 deletions
diff --git a/sci-libs/coinor-vol/Manifest b/sci-libs/coinor-vol/Manifest
index deaa475b50f5..43853bfeb25d 100644
--- a/sci-libs/coinor-vol/Manifest
+++ b/sci-libs/coinor-vol/Manifest
@@ -1,3 +1,4 @@
+AUX coinor-vol-1.5.4-musl-1.2.3-null.patch 960 BLAKE2B 23394fe662887a2933e96114ad95cb2f43951598d1eb650cba358864b61491a161e34de38bf3d287e35492245a06a7138281d1c67799efb74a2a1022b6c2522b SHA512 bd97018719ef4fa4dd5222ad5acc4445f63fda3043358b2b7f59f0b812ec62c22f8f8911c1e9b7fd86ed601c481c75b188fe42c02844a5d31dadca56efc2bc96
DIST coinor-vol-1.5.4.tar.gz 983625 BLAKE2B b1c78f94d1232d773aa325227ac01ad469d3ff56571119ae95ddb9a34eb7d55d004111e81dc89bb4bae1b5754da29cd4e93983772e158afa131a4da0b187b03c SHA512 ba489b909dab45a9a48a32804a571fc9ad966b268ce8a81a391a743b523bce393bd649aaf15c51f401267fe05fb2ff7623a1f7208c0b9d6c24af9b659a230780
-EBUILD coinor-vol-1.5.4.ebuild 2102 BLAKE2B 1c37d117d976ccd271cc10dba41cb163ee2913586e8c65b0ecfd3a4dfaf051ca5a7322eddec1e8390b9395d83e563e489162c4f9d3d4fe8be153ca1428ac3a66 SHA512 eb65860ba325fc7f4c65d7281556ef39deb0bd223761781fe05a0ff6a27c2ebed01366d5ff07440a5cc25a073246591b2da60c72c67888ec43ca8513844a2c47
+EBUILD coinor-vol-1.5.4.ebuild 2157 BLAKE2B cf81a7dc3e2d57d86b9690e8aec3b8cfeec1f19f986118fee989f60d394f063016fc29f0f77f3e399b316fd48d1136ff8f08d90b00da6c666a37f9a79b021ecb SHA512 4858ae612fed262c4ebeecb6507eaf5b360cd2642133dcdd501ea7b90246d832eb98ff5cc495ccb62d09c895f7b1e5ec6fc51403d54b0fe5a7c99953c6f0285c
MISC metadata.xml 600 BLAKE2B 3921f277d3c92a1754802eebc64b75066da9c633e96e7dc5ece03a4554def9f1c59a4964440ed38e7cd97bebf68ebfac0adacc0081b10b45add2b3de0d47d0f0 SHA512 c61bdfbcf18560775ef5838a216fe1483e00dcaf9dc811ae8933e3394691e69bc9212ba1fb46cb71551fb8877f6dbaa2bbb1b9307aed6712066577f99559fc70
diff --git a/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
index 53276b0f38c4..5ea2c976d627 100644
--- a/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
+++ b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,6 +34,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-1.2.3-null.patch
+)
+
src_prepare() {
# Needed to make the --with-coin-instdir in src_configure happy.
dodir /usr
diff --git a/sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch b/sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch
new file mode 100644
index 000000000000..96a154740ed4
--- /dev/null
+++ b/sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/841746
+https://github.com/coin-or/Vol/commit/7b65983cfbf66f9a615c1babcc28a7cd87eee3c4
+
+From: Stefan Vigerske <svigerske@gams.com>
+Date: Sat, 1 Feb 2020 17:45:41 +0000
+Subject: [PATCH] there should be no need to cast NULL, closes #1
+
+--- a/src/OsiVol/OsiVolSolverInterfaceIO.cpp
++++ b/src/OsiVol/OsiVolSolverInterfaceIO.cpp
+@@ -423,10 +423,10 @@ OsiVolSolverInterface::writeMps(const char *filename,
+ writer.setMpsData(*getMatrixByCol(), getInfinity(),
+ getColLower(), getColUpper(),
+ getObjCoefficients(),
+- reinterpret_cast<const char *> (NULL) /*integrality*/,
++ NULL /*integrality*/,
+ getRowLower(), getRowUpper(),
+- reinterpret_cast<const char **> (NULL) /*colnam*/,
+- reinterpret_cast<const char **> (NULL) /*rownam*/);
++ NULL /*colnam*/,
++ NULL /*rownam*/);
+ std::string fname = filename;
+ if (extension)
+ { if (extension[0] != '\0' && extension[0] != '.')
+