summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-mp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/coinor-mp
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/coinor-mp')
-rw-r--r--sci-libs/coinor-mp/Manifest5
-rw-r--r--sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild60
-rw-r--r--sci-libs/coinor-mp/metadata.xml14
3 files changed, 79 insertions, 0 deletions
diff --git a/sci-libs/coinor-mp/Manifest b/sci-libs/coinor-mp/Manifest
new file mode 100644
index 000000000000..d69312bce52d
--- /dev/null
+++ b/sci-libs/coinor-mp/Manifest
@@ -0,0 +1,5 @@
+DIST CoinMP-1.7.6.tgz 10343849 SHA256 86c798780b9e1f5921fe4efe651a93cb420623b45aa1fdff57af8c37f116113f SHA512 1612d43d52d0ee29b4e6ca328e1535c59722dfd5c7a7e0811a4180ad6033ef27111ced6497f9d5cea816c047a4e11c2aed6d1936feac8ded797eeec55d9539ce WHIRLPOOL 32f392e7bc2a0ca1e4a3a7f4ae30d1302cac3e65630cfb8d1483dc5cdf26fb46ba758049f7bd590bb93e7b73018affe05118ebb15fe1e41ffaade8f5a938ea5a
+EBUILD coinor-mp-1.7.6.ebuild 1351 SHA256 4da2e2431e5b130a01621e923f2d554de03424442f02c23d490f1bea32cc3c30 SHA512 ea2ef701b4e46d53f25d0d8585c79ebef718fdc77d65ad71fa8b43131dd9d540b87e7afa913a827a1494c40bbbb299c46b6a59cd9bfad8377453c7a35b433b59 WHIRLPOOL 8fb46273d9e21c4165c736a1d2c4816f2d5056aa1baad3f7c94581682690bf3e80564b7d0cb8eb9f40549521f5e86a636ae33fd0e18feeb24d95f2e5f12b1fca
+MISC ChangeLog 2433 SHA256 365b2f2c6f7811db1c5c69dc7f56e0ed3e380932efbabe51ade79fd50b173ef8 SHA512 e6a97704e9738aaff4344bf8ac23a1b2ac689a1c862b0071deae1921b283f848addd57217b7f3a2fd88cef3e1065f9628d4a386c8b3d679a1c9db84f6921b359 WHIRLPOOL e9648eef886f351d56dd328ec078c70af408c8b1f0d9336aa1eb2da53d7c6ddddbfa87e74ab841c59ca2d2ffef8504f57c373aead3b30525a633a56f469f9d12
+MISC ChangeLog-2015 1583 SHA256 17b0882d9dc87adbda6a4d05a7b2e96129a902b3573db17121c00023e55a5b05 SHA512 20a172b4b5a209649c82038f2f5601cf04e7829c2f3db4fd2a14dd9e4cb763e0d6f8ef7cc13ad4d8cca23e6c69031a1c50835ee56556f87ac934effe5b30bfd0 WHIRLPOOL b7274a003b28a8f85209d5082049b17ebed9efdeb3dca7d6252e65ea691ba0592b3e0522ebec30d3795ff8d535febc64dddfc55f9de718f52e7b05d61d5d7fa6
+MISC metadata.xml 548 SHA256 21ff0f58e2d0bf131cc26d70aa6f7d29818c5fc7b3f59158727b03afa0dd4c19 SHA512 e87020fb255c6461b1aa6fe25ad66621c8a680fac287818d13a3089ff3b858c9f5a768ebf08e620d97700f83119bf426655c2b910529ffdc8907104f522dee04 WHIRLPOOL 7162206a09d54487d3f54f0ba36e2c8b6f589311b6b4523c16aa1366b6e367be8cb9bdf00302efaa1105f4720e14b7cb4c0192561103a95e23ffe0c96c8d4b22
diff --git a/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild b/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild
new file mode 100644
index 000000000000..f8d827e01c64
--- /dev/null
+++ b/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=CoinMP
+
+DESCRIPTION="COIN-OR lightweight API for COIN-OR libraries CLP, CBC, and CGL"
+HOMEPAGE="https://projects.coin-or.org/CoinMP/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND="sci-libs/coinor-cbc:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ sed -i \
+ -e '/^addlibsdir/s/$(DESTDIR)//' \
+ -e 's/$(addlibsdir)/$(DESTDIR)\/$(addlibsdir)/g' \
+ -e 's/$(DESTDIR)$(DESTDIR)/$(DESTDIR)/g' \
+ Makefile.in || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ --datadir=/usr/share
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-mp/metadata.xml b/sci-libs/coinor-mp/metadata.xml
new file mode 100644
index 000000000000..5fbc1079f58b
--- /dev/null
+++ b/sci-libs/coinor-mp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The COmputational INfrastructure for Operations Research (COIN-OR)
+ MP is a C-API interface library that supports most of the
+ functionality of the CLP (Coin LP), CBC (Coin Branch-and-Cut), and
+ CGL (Cut Generation Library) projects.
+</longdescription>
+</pkgmetadata>