summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-dylp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sci-libs/coinor-dylp
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sci-libs/coinor-dylp')
-rw-r--r--sci-libs/coinor-dylp/Manifest6
-rw-r--r--sci-libs/coinor-dylp/coinor-dylp-1.10.4.ebuild77
-rw-r--r--sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild63
-rw-r--r--sci-libs/coinor-dylp/metadata.xml25
4 files changed, 94 insertions, 77 deletions
diff --git a/sci-libs/coinor-dylp/Manifest b/sci-libs/coinor-dylp/Manifest
index f9ae9d86017e..056e311a3127 100644
--- a/sci-libs/coinor-dylp/Manifest
+++ b/sci-libs/coinor-dylp/Manifest
@@ -1,3 +1,3 @@
-DIST DyLP-1.9.4.tgz 5049865 BLAKE2B 4e7ea46973845959bb4d0b0f24c380b10ec8245bd690a3fadf2fe14d136187a828e898e78afc5625543eec27a7af23d0a3def433259e61fb13d337ac4f4ccd93 SHA512 1dcad555f40b88aafaef0ca712731f3d4787900cefd2125eea9171d5dfdbea1888fd08b6767f50dcb915a0e2ad4e3430ed67d68026015b15af9032ed9231a069
-EBUILD coinor-dylp-1.9.4.ebuild 1402 BLAKE2B 1acdd084eb6c79347db0773ec15cad77e72363cc2ac08278b43a9d97e52cce27aa9a556a6e890d83fd1d10a6d497a05cd16c543971f75f9f75d3fcac428eba63 SHA512 dd9a925846010a5fb58df9497efedde8b6bb383d11783c103c8dcf4348a8a7fa8a2e7d1b17a8730516230a577dc0674f3db300c536fa7fe2d636127f293a1f6b
-MISC metadata.xml 621 BLAKE2B ab7383a1b4706a739b8095227d69c9d29bfadfa1451c5e996e482cb4928119d72b4b94097d918fad28d6a4c41905f7f9e9560110875fc7033a11d37339ce33c5 SHA512 6b577cfbd41c6107609ac4939409f4c0360948b3cd63ea29a87f51706673f2493bfd9e98dd23eebc3d90f314fff666c9ce3359fc43c59bffa82c18b791218e3c
+DIST coinor-dylp-1.10.4.tar.gz 2820973 BLAKE2B 29f74c314940e32b0e1c9c9bf6b9fc0515eeb98674d88e914445efaec2f97c92ff6e9de7d9b55f2427a1cf3d92fddb976915fbdc1ddd1df9fd0985e5b078ed2d SHA512 2fe3298007568cc9ed7626e72e7ed5c45611fb15120db06cdefd21e02b34a2c11a498b360489df1f00e8a897023419688e43dbb77edb690350b3ee2d4cd2781c
+EBUILD coinor-dylp-1.10.4.ebuild 1831 BLAKE2B 3e98611460bd593a5106fbc8b82046b6cb0b7a9a8a7b1a3d473958ec98a16f9791ed55b556ed805b4370c06b4023cd2419c2c6ba1057b4bfda9a12fe9fb9bcd7 SHA512 6221899f85c14622d11af1afb5d29fe583d39dde76edec96dcf9a717253a07ae70e176650f0e185835537744cb31ade525aa2805c4a6971848561537057770dc
+MISC metadata.xml 721 BLAKE2B b0973529c5d9e37c60104f7bf07e180989c2056519123f360f5d56f90151ec6422ed3817827b358f0dbd3c9ae33061781244c50251dd32799e47d1ccf4d69643 SHA512 3e78f356b87e72c5d92660ce283846dd83ef4fe28439d6076b2eebf9182efdaefeb04794578f7ececd14442dffa1e1250ea2da253feda07a1e7105990f980aa2
diff --git a/sci-libs/coinor-dylp/coinor-dylp-1.10.4.ebuild b/sci-libs/coinor-dylp/coinor-dylp-1.10.4.ebuild
new file mode 100644
index 000000000000..b36ea7976c84
--- /dev/null
+++ b/sci-libs/coinor-dylp/coinor-dylp-1.10.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=DyLP
+
+DESCRIPTION="COIN-OR dynamic simplex linear program solver"
+HOMEPAGE="https://github.com/coin-or/DyLP/"
+SRC_URI="https://github.com/coin-or/${MY_PN}/archive/releases/${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="EPL-1.0"
+
+# major soname component
+SLOT="0/1"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+RESTRICT="!test? ( test )"
+
+# Fortran is NOT needed, but the ./configure scripts for all of the CoinOR
+# packages contain a check for it. Gentoo bug 601648 and upstream issue,
+#
+# https://github.com/coin-or/CoinUtils/issues/132
+#
+BDEPEND="virtual/fortran
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+DEPEND="sci-libs/coinor-osi:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+
+src_prepare() {
+ # Needed to make the --with-coin-instdir in src_configure happy.
+ dodir /usr
+
+ # They don't need to guess at this, but they do, and get it wrong...
+ sed -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ -i configure \
+ || die "failed to fix the pkgconfig path in ${S}/configure"
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc "")
+}
+
+src_test() {
+ # NOT redundant! The build system has a "make check" target that does
+ # nothing, so if you don't specify "test" here, you'll get a no-op.
+ emake test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+
+ emake DESTDIR="${D}" install
+
+ # Duplicate junk, and in the wrong location.
+ rm -r "${ED}/usr/share/coin/doc/${MY_PN}" || die
+
+ use examples && dodoc -r examples
+}
diff --git a/sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild b/sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild
deleted file mode 100644
index 6432f3ab4b26..000000000000
--- a/sci-libs/coinor-dylp/coinor-dylp-1.9.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib
-
-MYPN=DyLP
-
-DESCRIPTION="COIN-OR using the dynamic simplex linear programming solver"
-HOMEPAGE="https://projects.coin-or.org/DyLP/"
-SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
-
-LICENSE="EPL-1.0"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="sci-libs/coinor-osi:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
- test? ( sci-libs/coinor-sample )"
-
-S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
-
-src_prepare() {
- # needed for the --with-coin-instdir
- dodir /usr
- sed -i \
- -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
- configure || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-dependency-linking
- --with-coin-instdir="${ED}"/usr
- $(use_with doc dot)
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile all $(usex doc doxydoc "")
-}
-
-src_test() {
- autotools-utils_src_test test
-}
-
-src_install() {
- use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
- autotools-utils_src_install
- # already installed
- rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sci-libs/coinor-dylp/metadata.xml b/sci-libs/coinor-dylp/metadata.xml
index 5faa1834a148..0766bb7d9751 100644
--- a/sci-libs/coinor-dylp/metadata.xml
+++ b/sci-libs/coinor-dylp/metadata.xml
@@ -1,15 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- DyLp is designed to find solutions of constrained linear mathematical
- optimization problems. To this end, it is using a full implementation
- of the so called dynamic simplex algorithm for linear programming.
- DyLP is part of the larger COIN-OR initiative (Computational
- Infrastructure for Operations Research).
- </longdescription>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ DyLP is designed to find solutions of constrained linear
+ mathematical optimization problems. To this end, it is using a
+ full implementation of the so called dynamic simplex algorithm for
+ linear programming. DyLP is part of the larger COIN-OR initiative
+ (Computational Infrastructure for Operations Research).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">coin-or/DyLP</remote-id>
+ </upstream>
</pkgmetadata>