summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-clp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-libs/coinor-clp
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-libs/coinor-clp')
-rw-r--r--sci-libs/coinor-clp/Manifest2
-rw-r--r--sci-libs/coinor-clp/coinor-clp-1.17.6-r1.ebuild146
-rw-r--r--sci-libs/coinor-clp/files/coinor-clp-1.17.6-remove-extern-C-for-MPI.patch18
3 files changed, 166 insertions, 0 deletions
diff --git a/sci-libs/coinor-clp/Manifest b/sci-libs/coinor-clp/Manifest
index 323a1b5030bc..3cdfd4a2fd15 100644
--- a/sci-libs/coinor-clp/Manifest
+++ b/sci-libs/coinor-clp/Manifest
@@ -1,3 +1,5 @@
+AUX coinor-clp-1.17.6-remove-extern-C-for-MPI.patch 441 BLAKE2B 7543b6447044a434f6f3feb295a480c45a4ed16237ad7f61e2b0116dc8816b7c8d70171a35fdeb4e24bbfd89d61fa685c3ae3b212e069a80f87ad6acbec9421d SHA512 267b76ac10ca934d866eb4e8886bc8afc6af2b8e9b678bb5a300787b51616e1eabb4f8814060344150bd09f585da67553122938f8a1294f1dfa3a1ecf63f5e5b
DIST coinor-clp-1.17.6.tar.gz 2158530 BLAKE2B b1bf6ecfdf3669ff4393e31c23d24f9160124dcd69df611c96feaa73acf796bc3a13a54542a5d0495e9a68789e762f5392bd7f23c0fee20c0699df2d0b084891 SHA512 8a799d87ba988a27e3ba526ded65425979b4364e374db4e943f41a523f3743efb88a9964eb575c058151e47f58be6ba0ac1b368177f0322850be3704be6f24d1
+EBUILD coinor-clp-1.17.6-r1.ebuild 3840 BLAKE2B d2e2c907cfc17fc84cae28b290bbc9774d6f54fed8dd0a10143f8383f019590d98d6aeaee2567ccdab404e8d8111f443776864b6fa07a77a8a8ce55d069a42cc SHA512 beb36900e1278fe763ac28b59dac6b3be5a73b475f14114a39b1177a08efc09431fde0079de936d08a7cefeb7541dd47447a7460e6468b82e89e6161fc7992bf
EBUILD coinor-clp-1.17.6.ebuild 3774 BLAKE2B 93ae581cc8b89606016253634ff6cbeb6b8c46f0bbb886c04bd4a015898bb288c65d5e927aed677cca29b74b323fe25ce48d29aa443f716e22f1777d7de63992 SHA512 9f6db4bda4db2491059cf27a6123bb811086eb10f4e2d2fe02b1ff1827c7390f7c2e578bd110a63570b992b5049b3e80906f3b0e7507017e7665d52a246aeeef
MISC metadata.xml 1119 BLAKE2B 7ae4adff772310ffe91c494ae83fbcf4b4d10f9c4e26b2a23d86f1a0a67f1f8e0fdc9f66960a095f33226c9b35b9f444c13b4bd3901528d21c9facc77f8190a0 SHA512 0306dbb1ef75a40edebe00cf6a0f8c11dfcc9857cf922f8a625b4c400d7bf6372ffbd208dbd72dbbb8d86cc028b6d85a3d250676e36f8f87d523ff4b43db5371
diff --git a/sci-libs/coinor-clp/coinor-clp-1.17.6-r1.ebuild b/sci-libs/coinor-clp/coinor-clp-1.17.6-r1.ebuild
new file mode 100644
index 000000000000..0017e5702100
--- /dev/null
+++ b/sci-libs/coinor-clp/coinor-clp-1.17.6-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="media-gfx/graphviz"
+DOCS_DIR="doxydoc"
+DOCS_CONFIG_NAME="doxygen.conf"
+inherit docs toolchain-funcs
+
+MY_PN=Clp
+
+DESCRIPTION="COIN-OR linear programming solver"
+HOMEPAGE="https://github.com/coin-or/Clp"
+SRC_URI="https://github.com/coin-or/Clp/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+
+LICENSE="EPL-1.0"
+SLOT="0/1" # major soname component
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples glpk metis mpi mumps sparse static-libs test"
+REQUIRED_USE="mpi? ( mumps )"
+RESTRICT="!test? ( test )"
+
+# Fortran is NOT needed, but the ./configure scripts for all of the CoinOR
+# packages contain a check for it. Gentoo bug 601648 and upstream issue,
+#
+# https://github.com/coin-or/CoinUtils/issues/132
+#
+BDEPEND="
+ virtual/fortran
+ virtual/pkgconfig
+ test? ( sci-libs/coinor-sample )
+"
+DEPEND="
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ glpk? ( sci-mathematics/glpk:= sci-libs/amd )
+ metis? ( sci-libs/metis )
+ mumps? ( sci-libs/mumps[mpi?] )
+ sparse? ( sci-libs/cholmod )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Needed to make the --with-coin-instdir in src_configure happy.
+ dodir /usr
+
+ mumpslibs="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps"
+
+ if use mumps; then
+ if use mpi; then
+ # https://github.com/coin-or/Clp/issues/199
+ eapply "${FILESDIR}/${P}-remove-extern-C-for-MPI.patch"
+ export CXX=mpicxx
+ else
+ # The file ClpCholeskyMumps.cpp does #include "mpi.h", and we
+ # need to point it to the right file. Our sci-libs/mumps ebuild
+ # is so ridiculous that I can't even tell if this is our fault
+ # or if it's something that should be reported upstream.
+ ln -s "${EPREFIX}/usr/include/mpiseq/mpi.h" src/mpi.h || die
+ mumpslibs="${mumpslibs} -lmpiseq"
+ fi
+ fi
+
+ # They don't need to guess at this, but they do, and get it wrong...
+ sed -e "s|lib/pkgconfig|$(get_libdir)/pkgconfig|g" \
+ -i configure \
+ || die "failed to fix the pkgconfig path in ${S}/configure"
+
+ default
+}
+
+src_configure() {
+ # The --enable-aboca flag is temporarily disabled, because the build
+ # is broken with it (see https://github.com/coin-or/Clp/issues/139).
+ # There's a fix, but I'm not going to bother with a patch for an
+ # an experimental feature.
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ if use glpk; then
+ myeconfargs+=(
+ --with-amd-incdir="${EPREFIX}"/usr/include
+ --with-amd-lib=-lamd
+ --with-glpk-incdir="${EPREFIX}"/usr/include
+ --with-glpk-lib=-lglpk
+ )
+ else
+ myeconfargs+=( --without-glpk )
+ fi
+ if use sparse; then
+ myeconfargs+=(
+ --with-amd-incdir="${EPREFIX}"/usr/include
+ --with-amd-lib=-lamd
+ --with-cholmod-incdir="${EPREFIX}"/usr/include
+ --with-cholmod-lib=-lcholmod
+ )
+ else
+ myeconfargs+=( --without-amd --without-cholmod )
+ fi
+ if use metis; then
+ myeconfargs+=(
+ --with-metis-incdir="$($(tc-getPKG_CONFIG) --cflags metis | sed s/-I//)"
+ --with-metis-lib="$($(tc-getPKG_CONFIG) --libs metis)"
+ )
+ else
+ myeconfargs+=( --without-metis )
+ fi
+ if use mumps; then
+ myeconfargs+=(
+ --with-mumps-incdir="${EPREFIX}"/usr/include
+ --with-mumps-lib="$mumpslibs"
+ )
+ else
+ myeconfargs+=( --without-mumps )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake all
+ docs_compile
+}
+
+src_test() {
+ # NOT redundant! The build system has a "make check" target that does
+ # nothing, so if you don't specify "test" here, you'll get a no-op.
+ emake test
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ # Duplicate junk, and in the wrong location.
+ rm -r "${ED}/usr/share/coin/doc/${MY_PN}" || die
+
+ use examples && dodoc -r examples
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/coinor-clp/files/coinor-clp-1.17.6-remove-extern-C-for-MPI.patch b/sci-libs/coinor-clp/files/coinor-clp-1.17.6-remove-extern-C-for-MPI.patch
new file mode 100644
index 000000000000..04e5c731a241
--- /dev/null
+++ b/sci-libs/coinor-clp/files/coinor-clp-1.17.6-remove-extern-C-for-MPI.patch
@@ -0,0 +1,18 @@
+--- a/src/ClpCholeskyMumps.cpp
++++ b/src/ClpCholeskyMumps.cpp
+@@ -11,7 +11,6 @@
+ #define JOB_INIT -1
+ #define JOB_END -2
+ #define USE_COMM_WORLD -987654
+-extern "C" {
+ #include "dmumps_c.h"
+ // In newer ThirdParty/Mumps, mpi.h is renamed to mumps_mpi.h.
+ // We get informed about this by having COIN_USE_MUMPS_MPI_H defined.
+@@ -20,7 +19,6 @@
+ #else
+ #include "mpi.h"
+ #endif
+-}
+
+ #include "ClpCholeskyMumps.hpp"
+ #include "ClpMessage.hpp"