summaryrefslogtreecommitdiff
path: root/sci-libs/coinhsl/coinhsl-2015.06.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sci-libs/coinhsl/coinhsl-2015.06.23.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sci-libs/coinhsl/coinhsl-2015.06.23.ebuild')
-rw-r--r--sci-libs/coinhsl/coinhsl-2015.06.23.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/coinhsl/coinhsl-2015.06.23.ebuild b/sci-libs/coinhsl/coinhsl-2015.06.23.ebuild
new file mode 100644
index 000000000000..9e1cac607992
--- /dev/null
+++ b/sci-libs/coinhsl/coinhsl-2015.06.23.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_STANDARD="77 90"
+
+inherit fortran-2 toolchain-funcs
+
+DESCRIPTION="HSL mathematical software library for IPOPT"
+HOMEPAGE="http://www.hsl.rl.ac.uk/ipopt"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="HSL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sci-libs/metis
+ virtual/blas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="mirror fetch"
+
+src_configure() {
+ export LIBS="$($(tc-getPKG_CONFIG) --libs metis blas lapack)"
+ default
+ MAKEOPTS+=" -j1"
+}