summaryrefslogtreecommitdiff
path: root/sci-libs/coinhsl/coinhsl-2014.01.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/coinhsl/coinhsl-2014.01.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/coinhsl/coinhsl-2014.01.10.ebuild')
-rw-r--r--sci-libs/coinhsl/coinhsl-2014.01.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/coinhsl/coinhsl-2014.01.10.ebuild b/sci-libs/coinhsl/coinhsl-2014.01.10.ebuild
new file mode 100644
index 000000000000..b750ae79f7ad
--- /dev/null
+++ b/sci-libs/coinhsl/coinhsl-2014.01.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+FORTRAN_STANDARD="77 90"
+
+inherit autotools-utils fortran-2 toolchain-funcs
+
+DESCRIPTION="HSL mathematical software library for IPOPT"
+HOMEPAGE="http://www.hsl.rl.ac.uk/ipopt"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="HSL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ sci-libs/metis
+ virtual/blas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="mirror fetch"
+
+src_configure() {
+ export LIBS="$($(tc-getPKG_CONFIG) --libs metis blas lapack)"
+ autotools-utils_src_configure
+ MAKEOPTS+=" -j1"
+}