summaryrefslogtreecommitdiff
path: root/sci-libs/cmpfit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/cmpfit
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/cmpfit')
-rw-r--r--sci-libs/cmpfit/Manifest5
-rw-r--r--sci-libs/cmpfit/cmpfit-1.2-r1.ebuild38
-rw-r--r--sci-libs/cmpfit/metadata.xml15
3 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/cmpfit/Manifest b/sci-libs/cmpfit/Manifest
new file mode 100644
index 000000000000..d043cdaf2ca9
--- /dev/null
+++ b/sci-libs/cmpfit/Manifest
@@ -0,0 +1,5 @@
+DIST cmpfit-1.2.tar.gz 30431 SHA256 4b90521d8fe7614e6ce1455aa77ee6eea397acfcdc870019e4351055a0ee0697 SHA512 232a39538396f166efd9c7a9fc687e0ac8fd3090f871f54fb0c131a1ed02cc05a60904894d853d8eb76d88e70a1fbab4bce3ad0b5990408c77d5a6028a3b466c WHIRLPOOL 0cf0eed9e1e1f60ce9a37afffba02155fef5a6bc4ca1b4833bdf1e776d2e01a6b9335f4bf260f311a96ae9e350e92e2e6451003c95ec9789f5fa4df2647b095b
+EBUILD cmpfit-1.2-r1.ebuild 1113 SHA256 6fee18d4dd7aedbb586606619db24511f263aebeb93232e149146e8b832d50a4 SHA512 7b5f03cdf045396ec88611dcc75e8776cb1313d707273a538cd05a10ff61c8f99c7cf5db425f1928d0950be627d0a2cee30156476c7df4ee111fd64a8dc3d54e WHIRLPOOL 7fefd38a8b112ceb945c75763e50624c45335f3160f7ef02191ad3132d421def4613fcbbf6a0a9f9ca46b428e8696d4160c83b012328f1b72b3410cfc6177e73
+MISC ChangeLog 2931 SHA256 12092f630926dbdca1eb0d87b06edf23f60dbe6db05a2e46d55205956791d602 SHA512 aaee7dfed18ac8e127fb056d61f8e2acebfda8c691c2522def44c2b96b9f807cae77908f8f9f6a59871173b4cd2193e68140a2eb12d7e239ca495f2e963ee3fa WHIRLPOOL 93826e818a3124ce8103b724a5ae87f67379540e764ee6ab6cd66f093a2e1aaffe54b69bcc7f114da0fffb53d0065bd7304617a685c57d6a7411f25a7f796568
+MISC ChangeLog-2015 470 SHA256 033eb1a3e40a9f98bda3cb46bc7cd1476d6ce3a1d2874fef15d03cb06388da3c SHA512 6069407d86dc80cc566a339f260a4f298a5233940ab9d055221c622bc779fb69af4e371882e9c5c4156d6ae1c240575be4c9c7ee7d69b82b552dd1ceeb339df5 WHIRLPOOL 13c1b3045e96f6468fab09ead0fc0b9095479951719cc472ba109d4a35d06be3f39b0890a7ab150d36feb616ddc3a291997ca9bed120a7ad0f905e5183b20792
+MISC metadata.xml 616 SHA256 7eaee90725ae0495a55cfaf436ffcc99167bfeb400806b3b9e81c0e7185df633 SHA512 4e38bce3a6be5e555dd573d5435b807e7bdda78e002aa896299be521b7cf50a2cd148a25a8ae2dc568a7b730cefa7bf8e2f19d76280654963a870d7d8e60c4d5 WHIRLPOOL 5349de0e4a1746a1797e7e65cd2fca2ed5f236b7ead56db2defe02c18bce6687e0aaf7c5ac3bc29cfcc7f10518af5b5d8380c5f661f734db170d5169501d45dc
diff --git a/sci-libs/cmpfit/cmpfit-1.2-r1.ebuild b/sci-libs/cmpfit/cmpfit-1.2-r1.ebuild
new file mode 100644
index 000000000000..4ddf2df64b53
--- /dev/null
+++ b/sci-libs/cmpfit/cmpfit-1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="MINPACK-1 Least Squares Fitting Library in C"
+HOMEPAGE="http://www.physics.wisc.edu/~craigm/idl/cmpfit.html"
+SRC_URI="http://www.physics.wisc.edu/~craigm/idl/down/${P}.tar.gz"
+
+LICENSE="public-domain minpack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DOCS=( README DISCLAIMER )
+
+src_compile() {
+ if use static-libs; then
+ $(tc-getCC) ${CFLAGS} -c mpfit.c || die "non-PIC compilation failed"
+ $(tc-getAR) cr libmpfit.a mpfit.o || die "creation of static archive failed"
+ fi
+ $(tc-getCC) ${CFLAGS} -fPIC -c mpfit.c -o mpfit.so || die "PIC compilation failed"
+ $(tc-getCC) ${LDFLAGS} -shared -Wl,-soname=libmpfit.so mpfit.so -lm -o libmpfit.so || die "linking failed"
+}
+
+src_test() {
+ $(tc-getCC) ${CFLAGS} testmpfit.c -L. -lmpfit -lm -o testmpfit || die
+ LD_LIBRARY_PATH=.:${LD_LIBRARY_PATH} ./testmpfit || die
+}
+
+src_install() {
+ dolib.so libmpfit.so
+ use static-libs && dolib.a libmpfit.a
+ doheader mpfit.h
+ einstalldocs
+}
diff --git a/sci-libs/cmpfit/metadata.xml b/sci-libs/cmpfit/metadata.xml
new file mode 100644
index 000000000000..bfd0c6bb45fa
--- /dev/null
+++ b/sci-libs/cmpfit/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ MPFIT uses the Levenberg-Marquardt technique to solve the
+ least-squares problem. In its typical use, MPFIT will be used to fit
+ a user-supplied function (the "model") to user-supplied data points
+ (the "data") by adjusting a set of parameters. MPFIT is based upon
+ MINPACK-1 (LMDIF.F) by More' and collaborators.
+</longdescription>
+</pkgmetadata>