summaryrefslogtreecommitdiff
path: root/sci-libs/clblas/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /sci-libs/clblas/files
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'sci-libs/clblas/files')
-rw-r--r--sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch20
-rw-r--r--sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch59
-rw-r--r--sci-libs/clblas/files/clblas-2.12-Detect-CBLAS-when-building-the-client.patch24
-rw-r--r--sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch26
-rw-r--r--sci-libs/clblas/files/clblas-2.12-fix-doxygen-output-dir.patch (renamed from sci-libs/clblas/files/clblas-2.10-fix-doxygen-output-dir.patch)0
-rw-r--r--sci-libs/clblas/files/clblas-2.12-fix-pthread-linkage.patch (renamed from sci-libs/clblas/files/clblas-2.10-fix-pthread-linkage.patch)4
-rw-r--r--sci-libs/clblas/files/clblas-2.12-reproducible-build.patch17
-rw-r--r--sci-libs/clblas/files/clblas-2.12-use-boost-dynamic-libs.patch (renamed from sci-libs/clblas/files/clblas-2.10-use-boost-dynamic-libs.patch)6
-rw-r--r--sci-libs/clblas/files/clblas-2.12-use-system-mathjax.patch (renamed from sci-libs/clblas/files/clblas-2.10-use-system-mathjax.patch)0
9 files changed, 72 insertions, 84 deletions
diff --git a/sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch b/sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch
deleted file mode 100644
index a7e59d913f06..000000000000
--- a/sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Description: disable multilib flags
-Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
-Forwarded: not-needed
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -296,9 +296,9 @@
- # Don't use -rpath.
- set(CMAKE_SKIP_RPATH ON CACHE BOOL "Skip RPATH" FORCE)
-
-- set(CMAKE_C_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_C_FLAGS}")
-- set(CMAKE_CXX_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_CXX_FLAGS}")
-- set(CMAKE_Fortran_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_Fortran_FLAGS}")
-+ #set(CMAKE_C_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_C_FLAGS}")
-+ #set(CMAKE_CXX_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_CXX_FLAGS}")
-+ #set(CMAKE_Fortran_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_Fortran_FLAGS}")
-
- if(TARGET_PLATFORM EQUAL 32)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-builtin")
diff --git a/sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch b/sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch
deleted file mode 100644
index cc2c6c3c1766..000000000000
--- a/sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff --git a/src/tests/correctness/blas-lapack.c b/src/tests/correctness/blas-lapack.c
-index 9687bdf..54666b1 100644
---- a/src/tests/correctness/blas-lapack.c
-+++ b/src/tests/correctness/blas-lapack.c
-@@ -655,7 +655,7 @@ complex cdotu( int n, complex *x, int incx, complex *y, int incy)
- #elif defined( __APPLE__)
- cblas_cdotu_sub(n, x, incx, y, incy, &ans);
- #else
-- cdotusub_(&n, x, &incx, y, &incy, &ans);
-+ ans = cdotu_(&n, x, &incx, y, &incy);
- #endif
-
- return ans;
-@@ -670,7 +670,7 @@ doublecomplex zdotu( int n, doublecomplex *x, int incx, doublecomplex *y, int i
- #elif defined(__APPLE__)
- cblas_zdotu_sub(n, x, incx, y, incy, &ans);
- #else
-- zdotusub_(&n, x, &incx, y, &incy, &ans);
-+ ans = zdotu_(&n, x, &incx, y, &incy);
- #endif
-
- return ans;
-@@ -685,7 +685,7 @@ complex cdotc( int n, complex *x, int incx, complex *y, int incy)
- #elif defined(__APPLE__)
- cblas_cdotc_sub(n, x, incx, y, incy, &ans);
- #else
-- cdotcsub_(&n, x, &incx, y, &incy, &ans);
-+ ans = cdotc_(&n, x, &incx, y, &incy);
- #endif
-
- return ans;
-@@ -700,7 +700,7 @@ doublecomplex zdotc( int n, doublecomplex *x, int incx, doublecomplex *y, int i
- #elif defined(__APPLE__)
- cblas_zdotc_sub(n, x, incx, y, incy, &ans);
- #else
-- zdotcsub_(&n, x, &incx, y, &incy, &ans);
-+ ans = zdotc_(&n, x, &incx, y, &incy);
- #endif
-
- return ans;
-diff --git a/src/tests/correctness/blas-lapack.h b/src/tests/correctness/blas-lapack.h
-index d2db1aa..8619e1e 100644
---- a/src/tests/correctness/blas-lapack.h
-+++ b/src/tests/correctness/blas-lapack.h
-@@ -1170,10 +1170,10 @@ double ddot_(int *n, double *x, int *incx, double* y, int *incy);
- complex cdotc_(int *n, complex *x, int *incx, complex* y, int *incy);
- doublecomplex zdotc_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy);
- #else
-- void cdotusub_(int *n, complex *x, int *incx, complex* y, int *incy, complex *ans);
-- void zdotusub_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy, doublecomplex *ans);
-- void cdotcsub_(int *n, complex *x, int *incx, complex* y, int *incy, complex *ans);
-- void zdotcsub_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy, doublecomplex *ans);
-+ complex cdotu_(int *n, complex *x, int *incx, complex* y, int *incy);
-+ doublecomplex zdotu_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy);
-+ complex cdotc_(int *n, complex *x, int *incx, complex* y, int *incy);
-+ doublecomplex zdotc_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy);
- #endif
-
- void sswap_(int *n, float *x, int *incx, float* y, int *incy);
diff --git a/sci-libs/clblas/files/clblas-2.12-Detect-CBLAS-when-building-the-client.patch b/sci-libs/clblas/files/clblas-2.12-Detect-CBLAS-when-building-the-client.patch
new file mode 100644
index 000000000000..bfe94dfd7074
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.12-Detect-CBLAS-when-building-the-client.patch
@@ -0,0 +1,24 @@
+From: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Date: Sat, 21 Jan 2017 16:49:27 +0000
+Subject: Detect CBLAS when building the client
+
+---
+ src/CMakeLists.txt | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index bf351c1..28d6a60 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -267,10 +267,7 @@ if( BUILD_TEST )
+ endif( )
+
+ if( BUILD_CLIENT )
+- if( NETLIB_FOUND )
+- else( )
+- message( WARNING "Not find Netlib; BUILD_CLIENT needs the Netlib CBLAS library" )
+- endif()
++ find_package( Netlib COMPONENTS BLAS REQUIRED )
+ endif()
+
+
diff --git a/sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch b/sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch
new file mode 100644
index 000000000000..8e8f14871ef1
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch
@@ -0,0 +1,26 @@
+Description: disable multilib flags
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: not-needed
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -305,18 +305,6 @@
+ # Don't use -rpath.
+ set(CMAKE_SKIP_RPATH ON CACHE BOOL "Skip RPATH" FORCE)
+
+- # Need to determine the target machine of the C compiler, because
+- # the '-m32' and '-m64' flags are supported on x86 but not on e.g. ARM.
+- exec_program( "${CMAKE_C_COMPILER} -dumpmachine"
+- OUTPUT_VARIABLE CMAKE_C_COMPILER_MACHINE )
+- message( STATUS "CMAKE_C_COMPILER_MACHINE: ${CMAKE_C_COMPILER_MACHINE}" )
+- # The "86" regular expression matches x86, x86_64, i686, etc.
+- if(${CMAKE_C_COMPILER_MACHINE} MATCHES "86")
+- set(CMAKE_C_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_C_FLAGS}")
+- set(CMAKE_CXX_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_CXX_FLAGS}")
+- set(CMAKE_Fortran_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_Fortran_FLAGS}")
+- endif()
+-
+ if(TARGET_PLATFORM EQUAL 32)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-builtin")
+ endif()
diff --git a/sci-libs/clblas/files/clblas-2.10-fix-doxygen-output-dir.patch b/sci-libs/clblas/files/clblas-2.12-fix-doxygen-output-dir.patch
index 31abb89b1c3a..31abb89b1c3a 100644
--- a/sci-libs/clblas/files/clblas-2.10-fix-doxygen-output-dir.patch
+++ b/sci-libs/clblas/files/clblas-2.12-fix-doxygen-output-dir.patch
diff --git a/sci-libs/clblas/files/clblas-2.10-fix-pthread-linkage.patch b/sci-libs/clblas/files/clblas-2.12-fix-pthread-linkage.patch
index aa99529df034..c920c8140d8d 100644
--- a/sci-libs/clblas/files/clblas-2.10-fix-pthread-linkage.patch
+++ b/sci-libs/clblas/files/clblas-2.12-fix-pthread-linkage.patch
@@ -5,9 +5,9 @@ Forwarded: no
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/src/library/CMakeLists.txt
+++ b/src/library/CMakeLists.txt
-@@ -888,6 +888,10 @@
+@@ -889,6 +889,10 @@
set_target_properties( clBLAS PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
- target_link_libraries(clBLAS ${OPENCL_LIBRARIES} ${MATH_LIBRARY})
+ target_link_libraries(clBLAS ${OPENCL_LIBRARIES} ${MATH_LIBRARY} ${THREAD_LIBRARY})
+set(THREADS_PREFER_PTHREAD_FLAG ON)
+find_package(Threads REQUIRED)
diff --git a/sci-libs/clblas/files/clblas-2.12-reproducible-build.patch b/sci-libs/clblas/files/clblas-2.12-reproducible-build.patch
new file mode 100644
index 000000000000..9d7c2b771e41
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.12-reproducible-build.patch
@@ -0,0 +1,17 @@
+Description: make package build reproducible
+ By disabling the HTML timestamp setting in Doxygen.
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: not-needed
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/doc/clBLAS.doxy
++++ b/doc/clBLAS.doxy
+@@ -974,7 +974,7 @@
+ # page will contain the date and time when the page was generated. Setting
+ # this to NO can help when comparing the output of multiple runs.
+
+-HTML_TIMESTAMP = YES
++HTML_TIMESTAMP = NO
+
+ # If the HTML_DYNAMIC_SECTIONS tag is set to YES then the generated HTML
+ # documentation will contain sections that can be hidden and shown after the
diff --git a/sci-libs/clblas/files/clblas-2.10-use-boost-dynamic-libs.patch b/sci-libs/clblas/files/clblas-2.12-use-boost-dynamic-libs.patch
index 57c585da11fc..64388c90dc48 100644
--- a/sci-libs/clblas/files/clblas-2.10-use-boost-dynamic-libs.patch
+++ b/sci-libs/clblas/files/clblas-2.12-use-boost-dynamic-libs.patch
@@ -5,12 +5,12 @@ Forwarded: no
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -270,7 +270,7 @@
+@@ -279,7 +279,7 @@
# Find Boost on the system, and configure the type of boost build we want
set( Boost_USE_MULTITHREADED ON )
-set( Boost_USE_STATIC_LIBS ON )
+set( Boost_USE_STATIC_LIBS OFF )
set( Boost_DETAILED_FAILURE_MSG ON )
- set( Boost_DEBUG ON )
- set( Boost_ADDITIONAL_VERSIONS "1.44.0" "1.44" "1.47.0" "1.47" )
+ # set( Boost_DEBUG ON )
+ set( Boost_ADDITIONAL_VERSIONS "1.44.0" "1.44" "1.47.0" "1.47" "1.60.0" "1.60" )
diff --git a/sci-libs/clblas/files/clblas-2.10-use-system-mathjax.patch b/sci-libs/clblas/files/clblas-2.12-use-system-mathjax.patch
index 775a669e96a8..775a669e96a8 100644
--- a/sci-libs/clblas/files/clblas-2.10-use-system-mathjax.patch
+++ b/sci-libs/clblas/files/clblas-2.12-use-system-mathjax.patch