summaryrefslogtreecommitdiff
path: root/sci-libs/cgcode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /sci-libs/cgcode
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'sci-libs/cgcode')
-rw-r--r--sci-libs/cgcode/Manifest4
-rw-r--r--sci-libs/cgcode/cgcode-1.0-r2.ebuild20
-rw-r--r--sci-libs/cgcode/files/1.0-gentoo.patch6
3 files changed, 13 insertions, 17 deletions
diff --git a/sci-libs/cgcode/Manifest b/sci-libs/cgcode/Manifest
index 9e2b33d58032..124671daf4a3 100644
--- a/sci-libs/cgcode/Manifest
+++ b/sci-libs/cgcode/Manifest
@@ -1,4 +1,4 @@
-AUX 1.0-gentoo.patch 2363 BLAKE2B 80c0ea8dce38494c2b21fc79ff9f7e8121e4d529015a496d9af7acb87f0a50e39e0338af6884d7e662005d064fa9ca8e0893ed45e746cc44b3b2730f47750917 SHA512 2daaf89d275a325404ec6804389a45fe02361e4e517a146dd329b9155a2200b4151bb559f4aad87055ed5d6da4227e0a30683ba82cfa1bb5f54c6cc40a76aea7
+AUX 1.0-gentoo.patch 2156 BLAKE2B f4ee517b96feb5ff5e69a97e4508751622edcc2a187283f53c5a0c0e25aed46799d6bcccbcad9d26a709aa76746bf9912224c2bb11550375bba238c565db0194 SHA512 70dbefb641750142c71d8c1d4b0b85740af8a1bcf2dd9c39db3aa7cbf99bc163352832c445e6bfc674c37919da8e91b952dd6fe257742b297c96ac59b52da6ab
DIST cgcode-1.0.tar.gz 77941 BLAKE2B bb062991d4bca842225b357a4bfd24edd2293ace224de141dc5782da82b3fb357d79cc8e06d90b948a8016fd726559469ab032b87cd8a678f10188079804295c SHA512 df76a2f8a0c00924af3d6933487a363fe23ded8281b392d40f240074c8643219f99dda9b6b6d515a281827d657a27ab06416ce152e65c5fead7549bb96be9621
-EBUILD cgcode-1.0-r2.ebuild 878 BLAKE2B 5663e71c2d081c75d57efeb7cb0c2e4692407bd44af77623f3e12ac905ac17c6ab4b7744059ffe16d2a77b7a9e668a8a11f9663e5a968787096908ce6f0e4f14 SHA512 02d27d15f596a1360086edff5dc8639da8390b8922b35f0bd47e3f9a5791d27afc895f3850c0934b3306a41a5a54279e65001cda15bd6f111b464bca6944b6db
+EBUILD cgcode-1.0-r2.ebuild 893 BLAKE2B 471caf9e01a5d0480f4cb6faaad522efb0ac0c492c2ceddbac3b96256ed39f69a5aa2cb5aa84a4a0f6797ccb4e8e1aa4321ec3f7213fdddcb6765f0eef577e3f SHA512 015ebaa8eefdfc325293edd94a2595f319e35ab9cea34e856b966a3700af3f7b07d4455521cdb0bb09d2aa03727f2128eab1c92cbe667b27e72bfc803c8d52b0
MISC metadata.xml 260 BLAKE2B 14d3d7872b9a3cb341301daf85c6b037c567163317516100d5af08e7ae02970252f210e90118d5df9e0cf6e0b3560add3a7894d379609b864e60dfdda3036423 SHA512 973385fccdcb0ccc36e00a09dc85204cf15081b8b61bc20e02d7d1311cb05af4927f01aac36ec93275158f5b990874ca03ab7d381cf6ee6f5e30bc4926d2f045
diff --git a/sci-libs/cgcode/cgcode-1.0-r2.ebuild b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
index dbb7d0622da8..6fe1ddee3b21 100644
--- a/sci-libs/cgcode/cgcode-1.0-r2.ebuild
+++ b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
@@ -1,33 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch fortran-2 flag-o-matic toolchain-funcs
+inherit fortran-2 flag-o-matic toolchain-funcs
DESCRIPTION="Conjugate gradient Codes for large sparse linear systems"
HOMEPAGE="http://fetk.org/codes/cgcode/index.html"
SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-2"
-IUSE=""
RDEPEND="virtual/blas"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}"/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+ default
# GCC 10 workaround
# bug #722000
append-fflags $(test-flags-FC -fallow-argument-mismatch)
- cat >> make.inc <<- EOF
+ cat >> make.inc <<- EOF || die
F77 = $(tc-getFC)
FFLAGS = ${FFLAGS}
BLASLIBS = $($(tc-getPKG_CONFIG) --libs blas)
diff --git a/sci-libs/cgcode/files/1.0-gentoo.patch b/sci-libs/cgcode/files/1.0-gentoo.patch
index 612ca9e06497..449f1f18dde5 100644
--- a/sci-libs/cgcode/files/1.0-gentoo.patch
+++ b/sci-libs/cgcode/files/1.0-gentoo.patch
@@ -1,5 +1,3 @@
-diff --git a/makefile b/makefile
-index 4813b55..f20af02 100644
--- a/makefile
+++ b/makefile
@@ -1,21 +1,23 @@
@@ -33,8 +31,6 @@ index 4813b55..f20af02 100644
clean :
rm -f *.o goos good
-diff --git a/src/makefile b/src/makefile
-index 10cf6c3..1dfd02d 100644
--- a/src/makefile
+++ b/src/makefile
@@ -1,16 +1,17 @@
@@ -60,8 +56,6 @@ index 10cf6c3..1dfd02d 100644
clean :
rm -f *.o $(THISLIB)
-diff --git a/util/makefile b/util/makefile
-index 6dad0d1..5c9d24f 100644
--- a/util/makefile
+++ b/util/makefile
@@ -6,11 +6,12 @@ SOBJLIB = saxpy.o scopy.o sdot.o snrm2.o sscal.o