summaryrefslogtreecommitdiff
path: root/sci-libs/cartopy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-libs/cartopy
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest3
-rw-r--r--sci-libs/cartopy/cartopy-0.18.0_beta1.ebuild65
-rw-r--r--sci-libs/cartopy/metadata.xml15
3 files changed, 83 insertions, 0 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
new file mode 100644
index 000000000000..f2633613ce59
--- /dev/null
+++ b/sci-libs/cartopy/Manifest
@@ -0,0 +1,3 @@
+DIST cartopy-0.18.0_beta1.tar.gz 14215372 BLAKE2B 5bb1e98f18fdf57c0459202bfe77d4e4a476a3008e2f21a77cf643711cc3c438626915c31ee48886e980466f952985503987e3ed571295e2beb6c12754b382c4 SHA512 95d3bd87e57bea89eb2c25d6a709285ba59fb0f994abc3b37faf29b272b73647d0bc8979a25b1480f48bb55c957f4183ac3c3ad49b830ce686e931227c797abe
+EBUILD cartopy-0.18.0_beta1.ebuild 1662 BLAKE2B 89c8c5c01c35b087b53f482bcdba0486b41d5de7d3a0a1abec623c287ca65b92d53c33a1766c532b1be34071c4bb38940cbcf2e80509fafbb2b01c5fc10e5ea7 SHA512 30e66e5d966dec99a83603f2447d3c9db054e45a54e55427df29f81b9348ff6772e9bd351f7f0a070b69c5d6b09c0eef0d1ec4109ecea23e9354e526f04f466a
+MISC metadata.xml 602 BLAKE2B 92e179b5503c84c6e567e7adb48917ca6140a7c04a0f5613b5aa3a9c19623d61abed95c325b41ca0d5a99b046c2891511796de49c3117c4ce9c969069bb2c5f0 SHA512 8677cb5685dee0b5868c1b14ffc13ac93e3b26ab741ceb684c7c48caf02f159a7a6613402e0396b9b0bc256c39b6446cbb7779521324447d96ed524fb8ca664d
diff --git a/sci-libs/cartopy/cartopy-0.18.0_beta1.ebuild b/sci-libs/cartopy/cartopy-0.18.0_beta1.ebuild
new file mode 100644
index 000000000000..01048dc6aca8
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.18.0_beta1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+inherit distutils-r1 virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ sci-libs/gdal[python,${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ sci-libs/geos
+ sci-libs/proj
+"
+
+distutils_enable_tests pytest
+
+DEPEND+="test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ # drop test file requiring network access, which got not covered by markers
+ rm "${S}"/lib/cartopy/tests/mpl/test_crs.py || die
+ # prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"
+ # drop all tests needing network access
+ virtx pytest -vv -m "not network and not natural_earth" || die "test failed"
+}
diff --git a/sci-libs/cartopy/metadata.xml b/sci-libs/cartopy/metadata.xml
new file mode 100644
index 000000000000..5bffb9050151
--- /dev/null
+++ b/sci-libs/cartopy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+ <longdescription>
+ Cartopy is a Python package designed for geospatial data processing
+ in order to produce maps and other geospatial data analyses.
+ Key features of cartopy are its object oriented projection definitions,
+ and its ability to transform points, lines, vectors, polygons and i
+ images between those projections.
+ </longdescription>
+</pkgmetadata>