summaryrefslogtreecommitdiff
path: root/sci-libs/cartopy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-libs/cartopy
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest3
-rw-r--r--sci-libs/cartopy/cartopy-0.20.1-r1.ebuild70
-rw-r--r--sci-libs/cartopy/cartopy-0.20.1.ebuild70
3 files changed, 143 insertions, 0 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
index f48732dade04..586d695b597c 100644
--- a/sci-libs/cartopy/Manifest
+++ b/sci-libs/cartopy/Manifest
@@ -1,3 +1,6 @@
DIST cartopy-0.19.0.tar.gz 11738107 BLAKE2B 129a32850947e3439505812655b0feb25f33e3b45a909be56a0093cba41acbf777be7e899b528cc910e044fc8844438283eff4d20a1433ab5ea3c58f240efa0f SHA512 5019c752fed18295048cdbe927e28040b61327414262c67c079572969e8ec3abd76f4cb0e6dd1f8ee4cfb88426cbd926ff9a2e934e8d47b8a3180bf748bd7364
+DIST cartopy-0.20.1.tar.gz 10704635 BLAKE2B 29ff571a4dccfe71585d6da4d11730fdb7d1b4bf28e9e16a7e928dc154a1fb74169fb122bf9dd2ebbc8b1a3d2ff4cd4591ec2afaa7eb9728ce1ae8a66facff1c SHA512 fe846fcaa8860f5bee4c478aa8a2125dad19d0d7988d10ee587590834728708f2a015104852d4320ba4d2367b78bad36cbdaa2b48cb6ed5b7b4d4e06a86e20d2
EBUILD cartopy-0.19.0.ebuild 1833 BLAKE2B 97c1bc9e16e40c882a9236294dc06120aa668edd7c467d258276dd2e4486c4acb5c9ad2082ba6c371db70a3760049ad49be1c3d0dcab4f87bb59deabf651ab0a SHA512 35f5d1dce3a2ec606d6b5322329b3a5b8345a7e5ad2d57fb17d485b00193c847e014e96cb94e119d679414408a45530d823e4dc4b6e1ece77bd0ec13847cd086
+EBUILD cartopy-0.20.1-r1.ebuild 1872 BLAKE2B 9794536c59aed5a8b2f28195e5425012b82b801d3b67ce7c8c6047e87ca7954f4919a27f2762be273c092e6f1eb69bbf6b55b3e761a8119e5936f17dc68b63e8 SHA512 169937284eee56144f265579af0f175710818dc7c08c2f8c95f7b397adbab4b6e1afaa5bdda72eeda7ad37528fb1c5f699e1690144486b1fdb4be81aeebfc05b
+EBUILD cartopy-0.20.1.ebuild 1872 BLAKE2B 7e6ca0fe2c7f841b2ae0c3eec8b90a07f6d2425592a19d64355b877a22deb192508855ce4005e8a77e2de91f2ba03414d5085ff97510537564348f26acd8ddc3 SHA512 ec4e0f11ff96c2450f7e493364183388bf0dea8f3462b373b1aa0135b58ccd5390610d9b94eb3200cf54bcfc02403fe99e7eab51ba0137409acb2d5f6c941352
MISC metadata.xml 603 BLAKE2B dc4da38fb25d4785362faa8475edb2d3b44aa99c0ce3f3f21ee3c1812a385a715a0d18ece3d58b63e298f997fdebd4762f8395335042bbac6e6fc2aadefee695 SHA512 3fb87e6057c17a7430519fc5e434847cfe13bdf06fa4aab6ed3b6aefe574a078c8750915c65a9d1ed12cecc8c25353e1218aae69dbe0a9e661b9d7499994dea3
diff --git a/sci-libs/cartopy/cartopy-0.20.1-r1.ebuild b/sci-libs/cartopy/cartopy-0.20.1-r1.ebuild
new file mode 100644
index 000000000000..d1c4f0d5d167
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.20.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1 virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sci-libs/geos
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ sci-libs/gdal[python,${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ >=sci-libs/proj-8
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DEPEND+="test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/flufl-lock[$PYTHON_USEDEP]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ # drop test file requiring network access, which got not covered by markers
+ rm "${S}"/lib/cartopy/tests/mpl/test_crs.py || die
+ rm "${S}"/lib/cartopy/tests/mpl/test_gridliner.py || die
+ # prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"
+ # drop all tests needing network access
+ virtx pytest -vv -m "not network and not natural_earth" || die "test failed"
+}
diff --git a/sci-libs/cartopy/cartopy-0.20.1.ebuild b/sci-libs/cartopy/cartopy-0.20.1.ebuild
new file mode 100644
index 000000000000..1fa38c496b97
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.20.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1 virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ sci-libs/gdal[python,${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ sci-libs/geos
+ >=sci-libs/proj-8
+ dev-python/pyproj[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DEPEND+="test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/flufl-lock[$PYTHON_USEDEP]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ # drop test file requiring network access, which got not covered by markers
+ rm "${S}"/lib/cartopy/tests/mpl/test_crs.py || die
+ rm "${S}"/lib/cartopy/tests/mpl/test_gridliner.py || die
+ # prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"
+ # drop all tests needing network access
+ virtx pytest -vv -m "not network and not natural_earth" || die "test failed"
+}