summaryrefslogtreecommitdiff
path: root/sci-libs/cartopy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 19:01:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 19:01:44 +0100
commit27ea108e1b7c2bb06bf1462685f119e435fd67cf (patch)
tree693bb5e76e5c14cb4d619dc900dac86d35e59ddc /sci-libs/cartopy
parente0722f6145f1e8db6281ff135d83442091b31620 (diff)
gentoo auto-resync : 18:07:2023 - 19:01:44
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest1
-rw-r--r--sci-libs/cartopy/cartopy-0.21.1-r1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
index 6366b36ac01d..6fd7e41bd0d6 100644
--- a/sci-libs/cartopy/Manifest
+++ b/sci-libs/cartopy/Manifest
@@ -1,4 +1,5 @@
AUX cartopy-0.21.1-fix-test.patch 1108 BLAKE2B c88a6a68bf0c0737d31049ac2c5a24791779ccc2b29f767056796c138928b04ffea47d8989dec02ed19725527d512920f07c991eb80f1534b83bf842df48b30e SHA512 010f1c844d21c60dca18dbc5530fcbebb5da99bd4a126e6c844bcb32c55533114c53694fbfc381e9a3aecabab8d11d9fb33a826597b9b66eae30c07f304f44e6
DIST cartopy-0.21.1.gh.tar.gz 10815884 BLAKE2B 4137f593b6ce35270f9df5016529250a07c57ec5a95843db8740eb494f55109b5129cf72153b0216e4f786771bf5cedde3caaecd40175fe9ad5c6fb65ad84788 SHA512 de1d09ee3bf6af13bcc7cc4bb1f7c13335ba67e05d2ad64efa0fb00bdb74c7e13c6fc44822d5ac1d70ee7d39b2322280c1395dc66119b9ecd94ca26014e413a1
+EBUILD cartopy-0.21.1-r1.ebuild 2097 BLAKE2B f129371845e40b9479ea9eb3d510bb29879fffafd5f474d8fa32cfe1cb8e376fdb47c0ba73ad2f5cf582ad1b05a50f3fd54078695fbe5606f2370e19c37d7aad SHA512 44606f3615b49c86fabba1752a48df65922d4d58f9184fb4b51ee7a7eba89fe07c0e11787597107f5c4ced70db7a5dc0c97ac4a8b43d7ba6ca4773448a27ad5d
EBUILD cartopy-0.21.1.ebuild 2103 BLAKE2B 40b5cbc22d3ecae968c8e7739264ff3b80c2953d2644e2df0c5d0e82a283a74e583129dea6c4c5b381738527607dc6cc378421c9ac233831b9e55b29e4244016 SHA512 276ac9f06c63821133e8a0d6e752d7a96a09bd1ebc60acbf74825b56ef7f2e2fdad5e874611612c3889aa285348f561776bdaa9d0ac9a00b50183fd2661b3de7
MISC metadata.xml 729 BLAKE2B 38605f8140ccae8c9edf2b5eb7bf394e9c99fd089fa998c98422967cc12d3b808d3b7901d3746da25558c9211e47deec01a3d5856176cda8a868c0151a03fed8 SHA512 f3fb714f50475c2e0f4150d20423195fffb39243aefd313e9a9d0fa834364a928a712006d6e1e1def77b902f8c349a4045d3081fe38697054e744441e622a591
diff --git a/sci-libs/cartopy/cartopy-0.21.1-r1.ebuild b/sci-libs/cartopy/cartopy-0.21.1-r1.ebuild
new file mode 100644
index 000000000000..29d90378d1ef
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.21.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 multibuild virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sci-libs/gdal[python,${PYTHON_SINGLE_USEDEP}]
+ sci-libs/geos
+ $(python_gen_cond_dep '
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flufl-lock[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-test.patch )
+
+EPYTEST_IGNORE=(
+ # Require network access, not covered by markers
+ lib/cartopy/tests/mpl/test_crs.py
+ lib/cartopy/tests/mpl/test_gridliner.py
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+ # Prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+
+ # Drop all tests needing network access
+ virtx epytest -m "not network and not natural_earth" || die "test failed"
+}