summaryrefslogtreecommitdiff
path: root/sci-libs/cartopy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 20:11:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 20:11:57 +0000
commitb30bf80580f09f15ee6686ff818cd36d923e1291 (patch)
tree273782d0605a08ce382dcf09078d11ed800cca58 /sci-libs/cartopy
parent51e7ea94956939599972c733f5b65fe71c7eb857 (diff)
gentoo auto-resync : 18:02:2023 - 20:11:56
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest3
-rw-r--r--sci-libs/cartopy/cartopy-0.21.1.ebuild4
-rw-r--r--sci-libs/cartopy/files/cartopy-0.21.1-fix-test.patch28
3 files changed, 33 insertions, 2 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
index 0c998ae1b938..b7f826dc220a 100644
--- a/sci-libs/cartopy/Manifest
+++ b/sci-libs/cartopy/Manifest
@@ -1,3 +1,4 @@
+AUX cartopy-0.21.1-fix-test.patch 1108 BLAKE2B c88a6a68bf0c0737d31049ac2c5a24791779ccc2b29f767056796c138928b04ffea47d8989dec02ed19725527d512920f07c991eb80f1534b83bf842df48b30e SHA512 010f1c844d21c60dca18dbc5530fcbebb5da99bd4a126e6c844bcb32c55533114c53694fbfc381e9a3aecabab8d11d9fb33a826597b9b66eae30c07f304f44e6
DIST cartopy-0.21.1.gh.tar.gz 10815884 BLAKE2B 4137f593b6ce35270f9df5016529250a07c57ec5a95843db8740eb494f55109b5129cf72153b0216e4f786771bf5cedde3caaecd40175fe9ad5c6fb65ad84788 SHA512 de1d09ee3bf6af13bcc7cc4bb1f7c13335ba67e05d2ad64efa0fb00bdb74c7e13c6fc44822d5ac1d70ee7d39b2322280c1395dc66119b9ecd94ca26014e413a1
-EBUILD cartopy-0.21.1.ebuild 2056 BLAKE2B 67d0beee114eff3fa353bce278949c2d3bd7e4e9defd44863746e70216f574763950936334c58475fb61cc8839a7f10e886f0ef2ae20d84ecd2adc2761c578d1 SHA512 fa1a5bd64cbc9b8111529e2daa6566e8e92f1c691f2d20d14721fcb82439ff101a2f48c1418ef4df9a367fb7cf137337a4323775038407f0bd1c1d65aea3a249
+EBUILD cartopy-0.21.1.ebuild 2103 BLAKE2B aafd9794240dd837326b2d54840f0e17427406d982b6bc589e2ab2c1def961acb28ccfae910172cd0798626f1eede7a6e7a79815dc76ae8e02228d060d663a9b SHA512 479aa493537c163a022f01906f8dc553977c94bbef948236190b682d75524026e4e0ffe64ac8b64f778cba63a1123b5f3c19ccd83404d90ea14441dfcd17d9e8
MISC metadata.xml 729 BLAKE2B 38605f8140ccae8c9edf2b5eb7bf394e9c99fd089fa998c98422967cc12d3b808d3b7901d3746da25558c9211e47deec01a3d5856176cda8a868c0151a03fed8 SHA512 f3fb714f50475c2e0f4150d20423195fffb39243aefd313e9a9d0fa834364a928a712006d6e1e1def77b902f8c349a4045d3081fe38697054e744441e622a591
diff --git a/sci-libs/cartopy/cartopy-0.21.1.ebuild b/sci-libs/cartopy/cartopy-0.21.1.ebuild
index 380a7c7ba024..40c419a3323b 100644
--- a/sci-libs/cartopy/cartopy-0.21.1.ebuild
+++ b/sci-libs/cartopy/cartopy-0.21.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 multibuild multiprocessing virtualx
@@ -55,6 +55,8 @@ BDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/${P}-fix-test.patch )
+
EPYTEST_IGNORE=(
# Require network access, not covered by markers
lib/cartopy/tests/mpl/test_crs.py
diff --git a/sci-libs/cartopy/files/cartopy-0.21.1-fix-test.patch b/sci-libs/cartopy/files/cartopy-0.21.1-fix-test.patch
new file mode 100644
index 000000000000..fd308b326c68
--- /dev/null
+++ b/sci-libs/cartopy/files/cartopy-0.21.1-fix-test.patch
@@ -0,0 +1,28 @@
+Matplotlib-3.7 has merged SubplotBase into AxesBase now, which makes the
+class string representation here GeoAxes now, even though we are
+still an _instance_ of GeoAxesSubplot
+
+Backported from https://github.com/SciTools/cartopy/commit/6b4572ba1a8a877f28e25dfe9559c14b7a565958?diff=unified
+diff --git a/lib/cartopy/tests/mpl/test_axes.py b/lib/cartopy/tests/mpl/test_axes.py
+index eaf5904..d4e37a1 100644
+--- a/lib/cartopy/tests/mpl/test_axes.py
++++ b/lib/cartopy/tests/mpl/test_axes.py
+@@ -13,7 +13,8 @@ import pytest
+
+ import cartopy.crs as ccrs
+ import cartopy.feature as cfeature
+-from cartopy.mpl.geoaxes import InterProjectionTransform, GeoAxes
++from cartopy.mpl.geoaxes import (
++ InterProjectionTransform, GeoAxes, GeoAxesSubplot)
+
+
+ class TestNoSpherical:
+@@ -119,7 +120,7 @@ class Test_Axes_add_geometries:
+
+ def test_geoaxes_subplot():
+ ax = plt.subplot(1, 1, 1, projection=ccrs.PlateCarree())
+- assert str(ax.__class__) == "<class 'cartopy.mpl.geoaxes.GeoAxesSubplot'>"
++ assert isinstance(ax, GeoAxesSubplot)
+
+
+ @pytest.mark.mpl_image_compare(filename='geoaxes_subslice.png')