summaryrefslogtreecommitdiff
path: root/sci-libs/camd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sci-libs/camd
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sci-libs/camd')
-rw-r--r--sci-libs/camd/Manifest2
-rw-r--r--sci-libs/camd/camd-2.4.6-r1.ebuild41
-rw-r--r--sci-libs/camd/files/camd-2.4.6-dash_doc.patch16
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/camd/Manifest b/sci-libs/camd/Manifest
index c1a8e0651cb7..0e764ad45885 100644
--- a/sci-libs/camd/Manifest
+++ b/sci-libs/camd/Manifest
@@ -1,3 +1,5 @@
+AUX camd-2.4.6-dash_doc.patch 498 BLAKE2B 93871bfdc9fbe1bc77f7cdc66d18d7517e318edcdbc09e1efa63a9400de5a3e91fa1febdc24394743b710090d7a78fc9e864732c4979db73f679cbd008fea670 SHA512 61a38299792ade16a067e7960d5922ffeb6be838eab73f8be493b999c9256875a07b28066e1965b59f9d9e5f63f616a1674f8987ff847e49ac4ff2a8fe05c73f
DIST camd-2.4.6.tar.bz2 317071 BLAKE2B 8f982050a20f00c9443063a0473caa4aa27efe005fe07b503cb68b29499152561fc9d30d00783607b1e8fb8af88707eabfe22d192b80e375b8a6d04d7a9a26d7 SHA512 c4020ed3e063d04f5d7d1a301719b1a5b5b912d505858f046654c9d283c41ff01d55f668fb7f7179a6ac636f5a5b80f71cac5eb5b1e5cae0ede97d946d62a1d0
+EBUILD camd-2.4.6-r1.ebuild 838 BLAKE2B 1688eac8d02dcc5475bc8ee099bad9c1b1bf0613c625d3887409d0cf28589e44e796062b31010402637382111a9010095faa1dec92e5d7081a321fff641182b7 SHA512 4f9f5fc06a801cf177d3c8b497da68c5205bdd9a9e5cabec6839f0fdec1ebd7c73de38a6c4efdaf53d79ccdad2d73135249c6e58f63f3df26467b0fe5ee12b28
EBUILD camd-2.4.6.ebuild 717 BLAKE2B aaea2b067e019608d3bd31ec989d25b926299da54b35fb9b60e0b9bfcd050e9c7ddddf987c9d1b36de838fd3360812d3ded619b576e4f042f9f3dc9e243b84df SHA512 3344d69aec563ab8d21a0aacdc6a14587b182bd460f4849a396ecd51fd2a2ee63bd483eddcafb12c489c23369356a3f4eeb14a7369da11d55f4d93616058c950
MISC metadata.xml 494 BLAKE2B 456f4ab539ab7303849cfabfda3e07987874a833e5691d6c3336ebb8a86cc6d5cc5fe8c20b65d8e5fdd8da1c947b9e7ff8eedfd2cc17da6040ff5d109b1b110d SHA512 6402783aec0922669bbf45477074644a9b10f44b0b06bf86ad9b4ecbab124076ee7f19c2c68c6eb3bf21a1569a3410f1ed0ac12f653dd5808559da133613d09f
diff --git a/sci-libs/camd/camd-2.4.6-r1.ebuild b/sci-libs/camd/camd-2.4.6-r1.ebuild
new file mode 100644
index 000000000000..fb5a430ed408
--- /dev/null
+++ b/sci-libs/camd/camd-2.4.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND=">=sci-libs/suitesparseconfig-5.4.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4.6-dash_doc.patch )
+
+src_prepare(){
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with doc)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/camd/files/camd-2.4.6-dash_doc.patch b/sci-libs/camd/files/camd-2.4.6-dash_doc.patch
new file mode 100644
index 000000000000..c70ed070f2a3
--- /dev/null
+++ b/sci-libs/camd/files/camd-2.4.6-dash_doc.patch
@@ -0,0 +1,16 @@
+diff --git a/Doc/Makefile.am b/Doc/Makefile.am
+index 80f5653..71c130a 100644
+--- a/Doc/Makefile.am
++++ b/Doc/Makefile.am
+@@ -1,9 +1,8 @@
+
+ CAMD_UserGuide.pdf:
+- echo '\begin{verbatim}' > camd_h.tex
++ printf '\\begin{verbatim}\n' > camd_h.tex
+ expand -8 $(top_srcdir)/Include/camd.h >> camd_h.tex
+- echo '\end{verbatim}' >> camd_h.tex
+- -ln -s $(srcdir)/*.{tex,bib} .
++ printf '\\end{verbatim}\n' >> camd_h.tex
+ $(PDFLATEX) CAMD_UserGuide
+ $(BIBTEX) CAMD_UserGuide
+ $(PDFLATEX) CAMD_UserGuide