summaryrefslogtreecommitdiff
path: root/sci-libs/caffe2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
commit1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (patch)
tree2cb5d912afaf290c355b58f8a7334b0e6c5277f0 /sci-libs/caffe2
parent7819ef4baadbb9171070ce385f7051989fe64e49 (diff)
gentoo auto-resync : 23:12:2022 - 13:59:28
Diffstat (limited to 'sci-libs/caffe2')
-rw-r--r--sci-libs/caffe2/Manifest2
-rw-r--r--sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch22
2 files changed, 22 insertions, 2 deletions
diff --git a/sci-libs/caffe2/Manifest b/sci-libs/caffe2/Manifest
index 619c28ac9c24..efd7900664e6 100644
--- a/sci-libs/caffe2/Manifest
+++ b/sci-libs/caffe2/Manifest
@@ -1,4 +1,4 @@
-AUX caffe2-1.11.0-gentoo.patch 4266 BLAKE2B 5e372a1b78d1215c27009d6aab13a5e0fbf1230adc44991e1410d25cdc92b7908ec9ca4c055159f3718412cdcb38688eaf0c409703a05c4eafb347c29c991160 SHA512 59643342c6e913e2650edd28409c8dcf0674bfe3e3aa00974ddbc1229bffa8f984f4494e0d2169755071cb32155fe9dad5bd8e5aa000b152fabde8ceb2b868b8
+AUX caffe2-1.11.0-gentoo.patch 5245 BLAKE2B 46f70234e3073a99297da4d56281a507a396f20592f05c45c1379b1b8f429bcfdd3ba00918f23da3ced4b30cb55cabe4af51a7d3bd3e21ddb2aaf53bf0e22b85 SHA512 ed331b74f126e675032adba5f7a5aa90dd55c8b94584896de99251d2abdf7c5738a9f5ad8a1907be808fe70750faf8e7d8d55d1807fa5b6708903f9c42e0ce88
AUX caffe2-1.12.0-glog-0.6.0.patch 959 BLAKE2B eb0c18a34a2c5a1b68a420b9001eac5c8ff65ef9ca9ea1e5ad93ecef3cbaa595808105bbf6c8d3dcb9047559d23bc0398cda5922fb41e29a7588644c90c90fd8 SHA512 5873f11930ae5947c7dfbb19d0377d5535e395fcc1ab213e3c65c77b2e3bd911efc11cde2ca3e7134e9e7798ca7a483910113f331c0a23b73a5546aaaded40c5
AUX caffe2-1.12.0-install-dirs.patch 6145 BLAKE2B 80ffd3cde9d25951156b1f8b476f19925ec408236c1a9f59205841d82a596fe3de75f896b8d554e091f7b23bf1090a4f7c19d39d5b60924127031da9958ad89c SHA512 37e3e1927a8ada047cee16d4d850433f028ffbe8feaccb91ad329c3ecc7b0a13fe43005e612023f5f90f094e5ed6080c9315d2b63418b118504c0904f4e81c03
DIST pytorch-1.12.0.tar.gz 106286765 BLAKE2B ff9bafedb35f859f7dccb9b606299cf9c345bdaa0deb87ecfe0c0c30c3c828414d989e1d9a243d9b7cd3f376d56a2f81c241ca2e3c9a8a2b30cddcdeddd3a5c7 SHA512 c9c748a2e0047daaaf199a1ba3198d2d1aee47f664170a9b34ccacd3deeb95f2070e4035eeb900012ef48dc62cf6fb6806f1a1dfe22de8c94892963076e593b7
diff --git a/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch b/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch
index addf1eb0bfba..059bcc2b9705 100644
--- a/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch
+++ b/sci-libs/caffe2/files/caffe2-1.11.0-gentoo.patch
@@ -49,7 +49,7 @@
set(TORCH_PYTHON_COMPILE_DEFINITIONS)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -750,7 +750,7 @@
+@@ -777,7 +777,7 @@
# ---[ Build flags
if(NOT MSVC)
@@ -58,6 +58,26 @@
string(APPEND CMAKE_CXX_FLAGS " -Wno-narrowing")
# Eigen fails to build with some versions, so convert this to a warning
# Details at http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1459
+@@ -783,7 +783,6 @@
+ # Details at http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1459
+ string(APPEND CMAKE_CXX_FLAGS " -Wall")
+ string(APPEND CMAKE_CXX_FLAGS " -Wextra")
+- string(APPEND CMAKE_CXX_FLAGS " -Werror=return-type")
+ string(APPEND CMAKE_CXX_FLAGS " -Wno-missing-field-initializers")
+ string(APPEND CMAKE_CXX_FLAGS " -Wno-type-limits")
+ string(APPEND CMAKE_CXX_FLAGS " -Wno-array-bounds")
+@@ -883,11 +882,9 @@
+ string(APPEND CMAKE_CXX_FLAGS " -fno-trapping-math")
+ check_cxx_compiler_flag("-Werror=format" HAS_WERROR_FORMAT)
+ if(HAS_WERROR_FORMAT)
+- string(APPEND CMAKE_CXX_FLAGS " -Werror=format")
+ endif()
+ check_cxx_compiler_flag("-Werror=cast-function-type" HAS_WERROR_CAST_FUNCTION_TYPE)
+ if(HAS_WERROR_CAST_FUNCTION_TYPE)
+- string(APPEND CMAKE_CXX_FLAGS " -Werror=cast-function-type")
+ endif()
+ check_cxx_compiler_flag("-Werror=sign-compare" HAS_WERROR_SIGN_COMPARE)
+ # This doesn't work globally so we use the test on specific
--- a/cmake/public/utils.cmake
+++ b/cmake/public/utils.cmake
@@ -512,8 +512,6 @@