summaryrefslogtreecommitdiff
path: root/sci-libs/buddy/buddy-2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/buddy/buddy-2.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/buddy/buddy-2.4-r1.ebuild')
-rw-r--r--sci-libs/buddy/buddy-2.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/buddy/buddy-2.4-r1.ebuild b/sci-libs/buddy/buddy-2.4-r1.ebuild
new file mode 100644
index 000000000000..c5dfddbbe1e1
--- /dev/null
+++ b/sci-libs/buddy/buddy-2.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit fortran-2
+
+DESCRIPTION="Binary Decision Diagram Package"
+HOMEPAGE="https://sourceforge.net/projects/buddy/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="buddy"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DOCS=( doc/tech.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gold.patch
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use doc && docinto ps && dodoc doc/*.ps
+
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r examples
+ fi
+}