summaryrefslogtreecommitdiff
path: root/sci-libs/brial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-libs/brial
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-libs/brial')
-rw-r--r--sci-libs/brial/Manifest3
-rw-r--r--sci-libs/brial/brial-1.2.8.ebuild39
-rw-r--r--sci-libs/brial/metadata.xml31
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
new file mode 100644
index 000000000000..31a2bfb2bbe3
--- /dev/null
+++ b/sci-libs/brial/Manifest
@@ -0,0 +1,3 @@
+DIST brial-1.2.8.tar.bz2 1228732 BLAKE2B f9bdfc9416381f3436c555861806a7ea4680e706729b6de9c2b06ea2908090b87b745fe5ce2d94ba9d5832a78067e4848f8ef113b7d8dc22557b6d95b7dad707 SHA512 a94acba140d976dd070b5214c537fb3dba89fc2309addc566b8f0a031328f2d4c2bb3c38c2cb5565c7ff2ca0c5f7f56ca120899d15c768887d3b61a18b3e05be
+EBUILD brial-1.2.8.ebuild 981 BLAKE2B 1afbbc177eac3082e2ed4ffaeb56e62d53067897e26be76f381be19384528cee71f8183ff0d50a146cc3f65d8f7b3b0c54cb99ddcec9c8bcc446fea5ece4fb34 SHA512 71614bcf0bf367288ae14e91b84a6ab4c9dc203ea208f837139590c84ace60e0e74928f16d83a4fa73206d28ba23ff7d1e2dd8d4ff0e8d691882b828831c4f9d
+MISC metadata.xml 1046 BLAKE2B 34c6f471ca6fbc4538cf3a2dc71bd19d4201656f326166b2589be3126f73f5ff34d190c2ff42154a067457a9da6f05067e782c9dc340357895ca016be6983183 SHA512 550a191f11f7812c363d419e8bed69fdd70e69b3a94e6fba838be9bc04050977edaab34ab0c0ef9c589e6478cdf2d40ba631983f6a2f411e51b9f3964bb48db5
diff --git a/sci-libs/brial/brial-1.2.8.ebuild b/sci-libs/brial/brial-1.2.8.ebuild
new file mode 100644
index 000000000000..8949ea5ef31b
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="png static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup(){
+ tc-export PKG_CONFIG
+}
+
+src_configure(){
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${EPREFIX}"/usr \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/brial/metadata.xml b/sci-libs/brial/metadata.xml
new file mode 100644
index 000000000000..7bb93bb41ee3
--- /dev/null
+++ b/sci-libs/brial/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <longdescription lang="en">
+ BRiAl is a C++ library (the successor to PolyBoRi) that provides
+ high-level data types for Boolean polynomials and monomials,
+ exponent vectors, as well as for the underlying polynomial rings
+ and subsets of the powerset of the Boolean variables.
+ </longdescription>
+
+ <upstream>
+ <remote-id type="github">BRiAl/BRiAl</remote-id>
+ </upstream>
+</pkgmetadata>