summaryrefslogtreecommitdiff
path: root/sci-libs/brial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 01:13:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 01:13:38 +0000
commit0e82736d0df44565875b055019ded1be0ac5c319 (patch)
treebd9daea4309088c78f6b358305ab15849d97d159 /sci-libs/brial
parent79be8f00e2aa293669b8e22e1ef02d2d5c5f9e25 (diff)
gentoo auto-resync : 17:01:2023 - 01:13:38
Diffstat (limited to 'sci-libs/brial')
-rw-r--r--sci-libs/brial/Manifest2
-rw-r--r--sci-libs/brial/brial-1.2.12.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
index 3c0f9ae66721..2044d39c7abb 100644
--- a/sci-libs/brial/Manifest
+++ b/sci-libs/brial/Manifest
@@ -1,3 +1,5 @@
DIST brial-1.2.11.tar.bz2 1260892 BLAKE2B 910f4ffd728235c8b18deb0d36c76778ce2c392644b7eaba06a9c00a832b4ccb0c2cd69f4d9ab9770e060b54491bd6b613e4e1324a32f57d7c32f200fb0a900d SHA512 00532b6361c709fce44940bfd22563046cfcbc06d41282a01a26f9bcb25fa86df1406685d7ba4b1ebbb08cd7fa8b9811c81eccf78e72ea96960ef7a059c2e926
+DIST brial-1.2.12.tar.bz2 1259569 BLAKE2B bf9415b2980d76d00239eceea113d6dbb916f5dcec3bdecb05db0ad1988761e4d25ab9a0419c68a3b2501f1f9dc6e2d31418aea7c727cfd01f4ae76eea8f81e2 SHA512 c44902f0f935d614b8c2d437d6c895f650ff4b77501ac3ba035e21671719f4080c88a173819f8db8e8b7dda121736146d8388b70ad7cda75207a1b22b93f5af6
EBUILD brial-1.2.11.ebuild 910 BLAKE2B 450ef8351b4ed6686d58ea3f336fc80a5aacceb0e26a96f211738e57c575be32b428d000f7b4a0b0f97d62d0655f9eacd777600af07cdca8ea618e218cb2e29a SHA512 a183e49c9564809b96535ebf82ecb5e725a75ef3149f4e8504860a06aa6fabc76c655a11fb765a65576cd4ce4988597d4562aabda37e76a3c265b6c353343140
+EBUILD brial-1.2.12.ebuild 912 BLAKE2B 006bf52542180b3fe8330647934350f04756eac488cdf450ea2465bbe66117d222d8be47510986edb0fbf41b90bb260ad5ae0ea1f30476d40da31b3d3236706e SHA512 ce280ef084f837f720123ba345fb030e155339535fe41df92c0354fbe73fcc6c00bee3ed585e366c94e9eafe417a3ed9b17b1bf279fef7aecf2974a6d203767d
MISC metadata.xml 1077 BLAKE2B 516f3390d40d27d4d1934be2eea344e888112ae8912985134bc288fe4d9414f49100874ddf94f7b0d517e60b7a37801464a6f64108df0465a015e6e9f3c3702e SHA512 284c49e862464bf2d825598a9ef6aa6dbf40c6f42f02f1dcb53f7d3baf8c728771dec129a63fcadb711c40ff623e5c4036cfdc54afc4dbaf07c73b75329aefe0
diff --git a/sci-libs/brial/brial-1.2.12.ebuild b/sci-libs/brial/brial-1.2.12.ebuild
new file mode 100644
index 000000000000..31821f7a6cde
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2+, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="png"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${ESYSROOT}"/usr \
+ --with-boost-libdir="${ESYSROOT}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}