summaryrefslogtreecommitdiff
path: root/sci-libs/brial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
commit00d9a8fc3e9e5bafeff6747e978c1685b384e587 (patch)
tree43c6db3767706ffe339a7040cb0a5dea8bd1ef26 /sci-libs/brial
parent799073eb168d35819904276f6c912be4ac76166a (diff)
gentoo auto-resync : 04:08:2022 - 02:04:17
Diffstat (limited to 'sci-libs/brial')
-rw-r--r--sci-libs/brial/Manifest2
-rw-r--r--sci-libs/brial/brial-1.2.11.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
index 86374caf3722..b4b4727b25a2 100644
--- a/sci-libs/brial/Manifest
+++ b/sci-libs/brial/Manifest
@@ -1,3 +1,5 @@
DIST brial-1.2.10.tar.bz2 1229830 BLAKE2B a1cfe4fcd19824d04388bbab1130a9d07e5920fb05ea1686424f1e0193c6f5d29300bba66bdf7ac59665cbceed3f6ff84fbb5a95311858196a0fbdecda5a2cc7 SHA512 163d9f3703271f412d20ec165d713280d9b46c50b66eed0b15385c6d94569e0ea5d7e84c3b6715d51197e97be4062325551402c844f70235a4aa1cebc5e9d3a1
+DIST brial-1.2.11.tar.bz2 1260892 BLAKE2B 910f4ffd728235c8b18deb0d36c76778ce2c392644b7eaba06a9c00a832b4ccb0c2cd69f4d9ab9770e060b54491bd6b613e4e1324a32f57d7c32f200fb0a900d SHA512 00532b6361c709fce44940bfd22563046cfcbc06d41282a01a26f9bcb25fa86df1406685d7ba4b1ebbb08cd7fa8b9811c81eccf78e72ea96960ef7a059c2e926
EBUILD brial-1.2.10.ebuild 957 BLAKE2B b37370aef6a8cadcdb0d5ed34b5640bc53eac4a90c1757f3de168c05622ca580b211fd935b0da9237456d4b78365498b85e0a1497a0feb7b124558d73504f09b SHA512 c536b54927457c463cddec863ea3e96753ed11d7fc40e5010b0416810185b3d0b2acf69f4e56e0bcb43cfcc10ade93a11e74dc932eecc28c8132a0c8e982a84c
+EBUILD brial-1.2.11.ebuild 912 BLAKE2B a7c9114dedecfff4fd90db92c896fbd718939d5c7c7c4bac8d58be11fb593b5b650affd0c857f3e99a7900daecae1d03f4af2090a4db0c16f9e050f637a813e5 SHA512 a9e832ee8ebeeef4ec33f0a46fc8978b4a5c15d6040662e93961ebc14fb9578743320fdaf4e56b30f8ad3ca42b8fa245c35e303f1808336f0fb20856878b48fb
MISC metadata.xml 1077 BLAKE2B 516f3390d40d27d4d1934be2eea344e888112ae8912985134bc288fe4d9414f49100874ddf94f7b0d517e60b7a37801464a6f64108df0465a015e6e9f3c3702e SHA512 284c49e862464bf2d825598a9ef6aa6dbf40c6f42f02f1dcb53f7d3baf8c728771dec129a63fcadb711c40ff623e5c4036cfdc54afc4dbaf07c73b75329aefe0
diff --git a/sci-libs/brial/brial-1.2.11.ebuild b/sci-libs/brial/brial-1.2.11.ebuild
new file mode 100644
index 000000000000..aa41242e9a0b
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2+, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="png"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${ESYSROOT}"/usr \
+ --with-boost-libdir="${ESYSROOT}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}