summaryrefslogtreecommitdiff
path: root/sci-libs/branca/branca-0.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
commit80c51284f0017d5765c7ae39207be9c58f4bfa17 (patch)
treef870412cb8771b0acdc3b28c70c09545bf034385 /sci-libs/branca/branca-0.6.0-r1.ebuild
parentfd089c26c06476b291a5255011ee378561c2615d (diff)
gentoo auto-resync : 19:02:2023 - 14:14:15
Diffstat (limited to 'sci-libs/branca/branca-0.6.0-r1.ebuild')
-rw-r--r--sci-libs/branca/branca-0.6.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/branca/branca-0.6.0-r1.ebuild b/sci-libs/branca/branca-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..91ea6850fcc5
--- /dev/null
+++ b/sci-libs/branca/branca-0.6.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features"
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/selenium[${PYTHON_USEDEP}] )"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not headless'
+}