summaryrefslogtreecommitdiff
path: root/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-libs/Shapely/Shapely-1.6.4_p2.ebuild')
-rw-r--r--sci-libs/Shapely/Shapely-1.6.4_p2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild b/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
deleted file mode 100644
index 7b76620b7303..000000000000
--- a/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-
-inherit distutils-r1 eapi7-ver
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="https://pypi.org/project/Shapely/"
-
-MY_PV="$(ver_cut 1-3).post$(ver_cut 5)"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sci-libs/geos-3.3
- dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}/${P}-test_operations.patch" ) # bug 701624
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-python_prepare_all() {
- # fix install path for Cython definition file
- sed -i \
- -e "s|\(data_files.*\)'shapely'|\1'share/shapely'|" \
- setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}/lib" || die
- cp -r "${S}/tests" . || die
- py.test tests || die
-}