summaryrefslogtreecommitdiff
path: root/sci-libs/Shapely/Shapely-1.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/Shapely/Shapely-1.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/Shapely/Shapely-1.3.2.ebuild')
-rw-r--r--sci-libs/Shapely/Shapely-1.3.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Shapely-1.3.2.ebuild b/sci-libs/Shapely/Shapely-1.3.2.ebuild
new file mode 100644
index 000000000000..290fdf25740f
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/setup_unicode.patch )
+
+python_test() {
+ esetup.py test
+}