summaryrefslogtreecommitdiff
path: root/sci-geosciences/routino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
commitb18dbdc69b2be6f0ac0db668b0bc57fb6f766afc (patch)
treee77939b82c93b9689bc1bb0bc8a55132c509cb44 /sci-geosciences/routino
parent97f40b36b1afa9726e32962d11f3ac2d0bc5792e (diff)
gentoo auto-resync : 16:02:2023 - 14:04:41
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/Manifest1
-rw-r--r--sci-geosciences/routino/routino-3.3.3-r3.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index 44ffaff8f80b..aea9de6de268 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -1,4 +1,5 @@
AUX routino-3.3.2.patch 1771 BLAKE2B a40ebca2cbc81f479eca69222e679a1abef4c42bd3db8417bd8bcc62c8d15a5ed2f43ae8b55e56870ca037b98de2c424f258d139dff11c0128ac60940f09ace6 SHA512 52cbd47e68b25a7c735d32a4bb51436ea45867cdb9f86bc3a55304674b80d33dcc41f845527659db345e118f2f56036a2265a98a177744b4cb1029c7a18e202e
DIST routino-3.3.3.tgz 2564198 BLAKE2B 0476e4afb2279c6a93b3d5192a1be580b0ee20fe07b5101c7d590bd3b74873e0205549c2fa621c6444eea0dd0cf0545c9fc054454e04f434d3e57ed750b1df3d SHA512 b037f6ef38b3abef4639d639c3564b42adc742d225108905d0cacb790e4a07593245c537b5550c43874cd6083f37b710b7aec02a0b0669c927804cf30ce34386
EBUILD routino-3.3.3-r2.ebuild 1639 BLAKE2B 202b9300edfbe011b8599d371c7151fd52deb4a3d79de549e5a112c222c7770bfd00bb258fc6cb1e69cbc24321d9f178acfa8348e04f3f9c7e1ac69e05b077ed SHA512 3d937f4e9574925198add33d52bb4efb1610c2e4aa47c6a9ffa47750ccfebfedd9302c4474c9401f91af69c83efb1568fc4ab29c73c78fd09a93f97e10cd7cec
+EBUILD routino-3.3.3-r3.ebuild 1641 BLAKE2B 8f0b26453d5e7caf7551779d84291bddbb4d7360feb52da996fe9414478b7407657309e913820d7623a7669e56b1435c994a39c01894b942f0838c55f90e2e8a SHA512 7e199159dc4efa0384e329a3a090b9e319c3e62cff718a4b6bbc3cebb48d8d9e10b2138851caff079a0c221945fc26ab99b482f6dfb8a2eedf04fc7e70ed53a8
MISC metadata.xml 894 BLAKE2B e9854b11005fdab70046e42a963c65a4e921f2d05572c4591e0ee581316a8ba3d3a5a0df39cf2aa500b1a89bde29fd1aaa459962abb68fdc71b49abd9681db54 SHA512 1397fb38a051f523925f04ab1d77044f2bbbcb2957a724696b54d6c057d49d67e758ae3d5b3c925fbce95f35e95c8b3a191724021bb82d4aa35ea61bc2c2153a
diff --git a/sci-geosciences/routino/routino-3.3.3-r3.ebuild b/sci-geosciences/routino/routino-3.3.3-r3.ebuild
new file mode 100644
index 000000000000..bc39cf589cc9
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.3.3-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{9..11} )
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="https://routino.org/"
+SRC_URI="https://routino.org/download/${P}.tgz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig[pcre]
+ )
+"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.2.patch )
+
+src_prepare() {
+ default
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+}
+
+src_compile() {
+ emake -j1
+
+ rm README.txt || die "rm README.txt failed"
+ mv doc/README.txt . || die "mv doc/README.txt . failed"
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+python_compile() {
+ rm -f build/.timestamp || die
+ emake PYTHON=${EPYTHON}
+}
+
+src_test() {
+ emake test
+
+ # Need to fix import issues with these
+ #if use python; then
+ # pushd python > /dev/null || die
+ # distutils-r1_src_test
+ # popd > /dev/null || die
+ #fi
+}
+
+python_test() {
+ emake PYTHON=${EPYTHON} test
+}
+
+src_install() {
+ default
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_install
+ newdoc README.txt README_python.txt
+ popd > /dev/null || die
+ fi
+}
+
+python_install() {
+ esetup.py install
+ python_optimize
+}