summaryrefslogtreecommitdiff
path: root/sci-geosciences/qgis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-10 12:25:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-10 12:25:06 +0100
commite810ac4a0e6af9f763f4433863042b34609075a7 (patch)
tree6fe0b3ff24f3b875be1564e273049c1e301d205b /sci-geosciences/qgis/files
parentc218398bbbe70a616790cf146c28c1066b9284bf (diff)
gentoo auto-resync : 10:07:2024 - 12:25:06
Diffstat (limited to 'sci-geosciences/qgis/files')
-rw-r--r--sci-geosciences/qgis/files/qgis-3.36.3-qt6-Fix-broken-test.patch29
-rw-r--r--sci-geosciences/qgis/files/qgis-3.36.3-qt6.patch42
-rw-r--r--sci-geosciences/qgis/files/qgis-3.36.3-testReportDir.patch13
3 files changed, 84 insertions, 0 deletions
diff --git a/sci-geosciences/qgis/files/qgis-3.36.3-qt6-Fix-broken-test.patch b/sci-geosciences/qgis/files/qgis-3.36.3-qt6-Fix-broken-test.patch
new file mode 100644
index 000000000000..0c4050271b10
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.36.3-qt6-Fix-broken-test.patch
@@ -0,0 +1,29 @@
+From 3f87b7af8baff33e2ed31c60a32da30a5291a346 Mon Sep 17 00:00:00 2001
+From: Nyall Dawson <nyall.dawson@gmail.com>
+Date: Mon, 29 Apr 2024 09:16:22 +1000
+Subject: [PATCH] Fix broken test
+
+This test was broken and not actually testing the QgsGeometry
+operator, and breaks compilation under qt 6.7
+---
+ tests/src/core/geometry/testqgsgeometry.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/src/core/geometry/testqgsgeometry.cpp b/tests/src/core/geometry/testqgsgeometry.cpp
+index 5cbb5b6b8c01..18e410c7a9af 100644
+--- a/tests/src/core/geometry/testqgsgeometry.cpp
++++ b/tests/src/core/geometry/testqgsgeometry.cpp
+@@ -1710,11 +1710,11 @@ void TestQgsGeometry::dataStream()
+ QCOMPARE( geom.constGet()->asWkt(), resultGeometry.constGet()->asWkt() );
+
+ //also test with geometry without data
+- std::unique_ptr<QgsGeometry> emptyGeom( new QgsGeometry() );
++ QgsGeometry emptyGeom;
+
+ QByteArray ba2;
+ QDataStream ds2( &ba2, QIODevice::ReadWrite );
+- ds2 << emptyGeom.get();
++ ds2 << emptyGeom;
+
+ ds2.device()->seek( 0 );
+ ds2 >> resultGeometry;
diff --git a/sci-geosciences/qgis/files/qgis-3.36.3-qt6.patch b/sci-geosciences/qgis/files/qgis-3.36.3-qt6.patch
new file mode 100644
index 000000000000..295c01b480fa
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.36.3-qt6.patch
@@ -0,0 +1,42 @@
+From: Paul Zander <negril.nx+gentoo@gmail.com>
+Subject: [PATCH] Build against Qt6
+
+diff --git a/external/qspatialite/CMakeLists.txt b/external/qspatialite/CMakeLists.txt
+index 33536da..61c7370 100644
+--- a/external/qspatialite/CMakeLists.txt
++++ b/external/qspatialite/CMakeLists.txt
+@@ -7,11 +7,19 @@ add_definitions(-DQT_SHARED)
+
+ include_directories(SYSTEM
+ ${SQLITE3_INCLUDE_DIR}
+- ${Qt5Sql_PRIVATE_INCLUDE_DIRS}
+ )
++if (BUILD_WITH_QT6)
++ include_directories(SYSTEM ${Qt6Sql_PRIVATE_INCLUDE_DIRS})
++else()
++ include_directories(SYSTEM ${Qt5Sql_PRIVATE_INCLUDE_DIRS})
++endif()
+
+ set(QSQLSPATIALITE_SRC qsql_spatialite.cpp smain.cpp)
+-QT5_WRAP_CPP(QSQLSPATIALITE_SRC qsql_spatialite.h smain.h)
++if (BUILD_WITH_QT6)
++ QT6_WRAP_CPP(QSQLSPATIALITE_SRC qsql_spatialite.h smain.h)
++else()
++ QT5_WRAP_CPP(QSQLSPATIALITE_SRC qsql_spatialite.h smain.h)
++endif()
+
+ add_library(qsqlspatialite SHARED ${QSQLSPATIALITE_SRC})
+ target_link_libraries(qsqlspatialite
+diff --git a/external/qspatialite/qsql_spatialite.cpp b/external/qspatialite/qsql_spatialite.cpp
+index 0e8f15a..9e30004 100644
+--- a/external/qspatialite/qsql_spatialite.cpp
++++ b/external/qspatialite/qsql_spatialite.cpp
+@@ -632,7 +632,7 @@ bool QSpatiaLiteDriver::open( const QString &db, const QString &, const QString
+ bool openReadOnlyOption = false;
+ bool openUriOption = false;
+
+- const auto opts = conOpts.splitRef( QLatin1Char( ';' ) );
++ const auto opts = conOpts.split( u';' );
+ for ( auto option : opts )
+ {
+ option = option.trimmed();
diff --git a/sci-geosciences/qgis/files/qgis-3.36.3-testReportDir.patch b/sci-geosciences/qgis/files/qgis-3.36.3-testReportDir.patch
new file mode 100644
index 000000000000..c8abe302104a
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.36.3-testReportDir.patch
@@ -0,0 +1,13 @@
+diff --git a/src/core/qgsrenderchecker.cpp b/src/core/qgsrenderchecker.cpp
+index c75985a..4696f18 100644
+--- a/src/core/qgsrenderchecker.cpp
++++ b/src/core/qgsrenderchecker.cpp
+@@ -54,7 +54,7 @@ QgsRenderChecker::QgsRenderChecker()
+ QDir QgsRenderChecker::testReportDir()
+ {
+ if ( qgetenv( "QGIS_CONTINUOUS_INTEGRATION_RUN" ) == QStringLiteral( "true" ) )
+- return QDir( QDir( "/root/QGIS" ).filePath( QStringLiteral( "qgis_test_report" ) ) );
++ return QDir( QDir( qgetenv( "CMAKE_SOURCE_DIR" ) ).filePath( QStringLiteral( "qgis_test_report" ) ) );
+ else
+ return QDir( QDir::temp().filePath( QStringLiteral( "qgis_test_report" ) ) );
+ }