summaryrefslogtreecommitdiff
path: root/sci-geosciences/osm-gps-map/osm-gps-map-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/osm-gps-map/osm-gps-map-1.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/osm-gps-map/osm-gps-map-1.1.0.ebuild')
-rw-r--r--sci-geosciences/osm-gps-map/osm-gps-map-1.1.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-geosciences/osm-gps-map/osm-gps-map-1.1.0.ebuild b/sci-geosciences/osm-gps-map/osm-gps-map-1.1.0.ebuild
new file mode 100644
index 000000000000..fda2bd508a4f
--- /dev/null
+++ b/sci-geosciences/osm-gps-map/osm-gps-map-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2
+
+DESCRIPTION="A GTK+ widget for displaying OpenStreetMap tiles"
+HOMEPAGE="http://nzjrs.github.io/osm-gps-map/"
+SRC_URI="https://github.com/nzjrs/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="
+ >=dev-libs/glib-2.16.0:2
+ >=net-libs/libsoup-2.4.0:2.4
+ >=x11-libs/cairo-1.8.0
+ >=x11-libs/gtk+-3.0:3[introspection]
+ dev-libs/gobject-introspection"
+
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ gnome-base/gnome-common:3
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gtk-doc-module.patch"
+ "${FILESDIR}/${P}-no-maintainer-mode.patch"
+)
+
+src_prepare() {
+ gnome2_src_prepare
+ AT_NOELIBTOOLIZE=yes eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}