summaryrefslogtreecommitdiff
path: root/sci-geosciences/opencpn-plugin-weather_routing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-geosciences/opencpn-plugin-weather_routing
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-geosciences/opencpn-plugin-weather_routing')
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/Manifest4
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild27
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild27
3 files changed, 28 insertions, 30 deletions
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/Manifest b/sci-geosciences/opencpn-plugin-weather_routing/Manifest
index e35a7d1ec7bb..1f669283d23c 100644
--- a/sci-geosciences/opencpn-plugin-weather_routing/Manifest
+++ b/sci-geosciences/opencpn-plugin-weather_routing/Manifest
@@ -1,4 +1,4 @@
DIST opencpn-plugin-weather_routing-1.10.1.tar.gz 845403 BLAKE2B e7cacef78f2f5567c008452c6c24eacf3acde8f8dcd78aa05f1e36248f31ab946f27c0bacdbb0882dcc1075a0fe15d6ddd62f5e24f7c38fffaf577683de6a345 SHA512 052377bc2b962b131640ecdb2e688b97325a7935f60c68652be6bdb07486278d03d09ec2c8b4b1547e5eeab1ea7613890604c800a91f185babe5bfb5221a7337
-EBUILD opencpn-plugin-weather_routing-1.10.1.ebuild 810 BLAKE2B 6eda58921aadfa85386ba845577cf968b796e31ded29b2782bd15ee9ba80f6302c7881dc838196c68bbb9bbac32554b3f40db0f1c735e4ee72f99020cda4165e SHA512 40f6f2511d47245a6e9b549b62ab6057e41cad5788a7690a73aea94e62b7c1cb0e3f935bfcac3c2199b9c7f40293c5958857cf4a5311cdffddb41e6da15ea3b4
-EBUILD opencpn-plugin-weather_routing-9999.ebuild 810 BLAKE2B 6eda58921aadfa85386ba845577cf968b796e31ded29b2782bd15ee9ba80f6302c7881dc838196c68bbb9bbac32554b3f40db0f1c735e4ee72f99020cda4165e SHA512 40f6f2511d47245a6e9b549b62ab6057e41cad5788a7690a73aea94e62b7c1cb0e3f935bfcac3c2199b9c7f40293c5958857cf4a5311cdffddb41e6da15ea3b4
+EBUILD opencpn-plugin-weather_routing-1.10.1.ebuild 777 BLAKE2B bd03ab8cf466ef4d4f8c506f7a70515b17f0eafe00cb7c5576b6993305888fc66db77a6326c2cd17dd08eb8b8719cc83b71b02739b1eceac1f215587dc01f427 SHA512 f83452bdc60882de93ae858cf160492d9b67ee4e874f3159acab0e5eb24a3bb5a90a9ca5f4b50d28d61921cc44882b3f879d6a32eefce054e4d4643d609dfc22
+EBUILD opencpn-plugin-weather_routing-9999.ebuild 777 BLAKE2B bd03ab8cf466ef4d4f8c506f7a70515b17f0eafe00cb7c5576b6993305888fc66db77a6326c2cd17dd08eb8b8719cc83b71b02739b1eceac1f215587dc01f427 SHA512 f83452bdc60882de93ae858cf160492d9b67ee4e874f3159acab0e5eb24a3bb5a90a9ca5f4b50d28d61921cc44882b3f879d6a32eefce054e4d4643d609dfc22
MISC metadata.xml 477 BLAKE2B be997d2c605fae9ffe4a2156ee1f157bd4583d8b28d3229f05d169b10512603ee04ce12568c116e3435efe459aad158a3d5462502344827a94bc104b62dabb22 SHA512 7a02f730a36af241a340d3d07c01051a5570078622651dd2886348fba796f8de91bb6faa45860afd312fd20305bd716c6b7603e5aa0153959e931f7bad88ea7e
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild
index bb68887e62a0..826df2e8f0ba 100644
--- a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild
+++ b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="weather_routing_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/seandepagnier/weather_routing_pi/"
LICENSE="GPL-3+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild
index bb68887e62a0..826df2e8f0ba 100644
--- a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="weather_routing_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/seandepagnier/weather_routing_pi/"
LICENSE="GPL-3+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}