summaryrefslogtreecommitdiff
path: root/sci-geosciences/opencpn-plugin-gxradar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/opencpn-plugin-gxradar
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/opencpn-plugin-gxradar')
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/Manifest4
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/metadata.xml15
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild37
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild37
4 files changed, 93 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-gxradar/Manifest b/sci-geosciences/opencpn-plugin-gxradar/Manifest
new file mode 100644
index 000000000000..5fd4ae3a1028
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/Manifest
@@ -0,0 +1,4 @@
+DIST opencpn-plugin-gxradar-1.1.tar.gz 297126 SHA256 7f4dca4feb4e705b880cd8779b9689725173ce5e5a08a8b3fb57cc1cf04fb9e5 SHA512 16b361e664323d125872628291bf97c6ac29caee4bae09ec256180aa66591bf9c66b7bdc38cd6d3c0988ed295148c0691bb8e511b5a9b9b6b34046dd419c9d7e WHIRLPOOL 59ce158b72298eae37a5c46f9d902689c3072646fe33af29331af2976dde712a9234fd7d5df7868fc8f1db0b6c310f4d27441a8a35dae34adde4547df7b5db62
+EBUILD opencpn-plugin-gxradar-1.1.ebuild 795 SHA256 1aeac20a297be111175b6a78a509a0079117d1a6afa028d2b8962e13490c89c3 SHA512 73ab0e7359fdc573eb4972709a03ef3f832034a3b3f86acd8431891790ad88cb75ff78c16a2a6cbbca465ca72a510a3494aa7e1d70ec0943c89c5eead3781745 WHIRLPOOL 5568ae8aac870f094c308df2b3c98ecc98782bb87b69cc676db1185902b194970f040271eff233f122ed47b3391e72bc3f6365a0ddd18e34ae9d93d9e4a8b8b0
+EBUILD opencpn-plugin-gxradar-9999.ebuild 793 SHA256 291c13df7ccf664498b2548a5b89812eedaa835e96797b90f3bd92ea88a1825c SHA512 b77fa71b09b481b8922daaf7be191ab36063b48cbdc798cb59f5c214e117a976cb331b80635f43678799963df3856c2fdf59674c917b50f4220e607eb808cdac WHIRLPOOL a719f1429022b385e4efa94c18f9a87c94180015ddb8cf973a425b540088d47342e560ebc791b90938cf8950cb0122e9e47f7334a6be7b9d4b3694c3e9160b82
+MISC metadata.xml 463 SHA256 d2423e0314edaac2961bbf9786e7a96264d89c190ed23ab8828a9f58493dd692 SHA512 7541ccf9ba469470bb1174029048053e8be82e7c9eab70d3fa47bff82ebee30f1b040e48e2f7e5bc41e2a4ce164756ead536bbc6f161df26c676bef2e9e1581d WHIRLPOOL a71abdba6af0e794da04de7611d521f52ee64a2f114fbeaa895d67bd0ed83809d3b72102b443fdee14a019c3847abbb2a9199c124b523b118ffa25309e180cf4
diff --git a/sci-geosciences/opencpn-plugin-gxradar/metadata.xml b/sci-geosciences/opencpn-plugin-gxradar/metadata.xml
new file mode 100644
index 000000000000..d8606ec694c7
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">trudK45/gxradar_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild
new file mode 100644
index 000000000000..9218dcc4cfca
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="gxradar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/trudK45/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/trudK45/${MY_PN}/archive/v.${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-v.${PV}"
+fi
+
+DESCRIPTION="Garmin xHD Radar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/trudK45/gxradar_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild
new file mode 100644
index 000000000000..f6fe3791f2cc
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="gxradar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/trudK45/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/trudK45/${MY_PN}/archive/v.${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Garmin xHD Radar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/trudK45/gxradar_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}