summaryrefslogtreecommitdiff
path: root/sci-geosciences/laszip/laszip-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/laszip/laszip-2.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/laszip/laszip-2.2.0.ebuild')
-rw-r--r--sci-geosciences/laszip/laszip-2.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-geosciences/laszip/laszip-2.2.0.ebuild b/sci-geosciences/laszip/laszip-2.2.0.ebuild
new file mode 100644
index 000000000000..bdabd9793af1
--- /dev/null
+++ b/sci-geosciences/laszip/laszip-2.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="Library for free and lossless compression of the LAS LiDAR format"
+HOMEPAGE="http://www.laszip.org/"
+SRC_URI="https://github.com/LASzip/LASzip/releases/download/v${PV}/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86"
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}_fix-build-system.patch
+)
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ autotools-utils_src_configure
+}