summaryrefslogtreecommitdiff
path: root/sci-geosciences/josm-bin/josm-bin-18940.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-23 16:46:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-23 16:46:30 +0000
commit1f1ada4b2afd8dd8de6ac1e0f94702abf05654bc (patch)
tree2d9c4727985711ca133f754404d7ef6c40d82be3 /sci-geosciences/josm-bin/josm-bin-18940.ebuild
parent02d5de423c2b7f8d7c873bcc7a1a222b1847149d (diff)
gentoo auto-resync : 23:01:2024 - 16:46:30
Diffstat (limited to 'sci-geosciences/josm-bin/josm-bin-18940.ebuild')
-rw-r--r--sci-geosciences/josm-bin/josm-bin-18940.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-geosciences/josm-bin/josm-bin-18940.ebuild b/sci-geosciences/josm-bin/josm-bin-18940.ebuild
new file mode 100644
index 000000000000..1aba0e7ffd7b
--- /dev/null
+++ b/sci-geosciences/josm-bin/josm-bin-18940.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop java-utils-2 xdg
+
+DESCRIPTION="Java-based editor for the OpenStreetMap project"
+HOMEPAGE="https://josm.openstreetmap.de/"
+# PV should be stable here https://josm.openstreetmap.de/wiki/StartupPage
+SRC_URI="https://josm.openstreetmap.de/download/josm-snapshot-${PV}.jar"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${A}" ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ local icon_size
+ for icon_size in 16 32 48; do
+ newicon -s ${icon_size} -t hicolor \
+ images/logo_${icon_size}x${icon_size}x32.png ${PN}.png
+ newicon -s ${icon_size} -t locolor \
+ images/logo_${icon_size}x${icon_size}x8.png ${PN}.png
+ done
+ make_desktop_entry ${PN} "Java OpenStreetMap Editor" ${PN} "Utility;Science;Geoscience"
+}