summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch')
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch17
1 files changed, 8 insertions, 9 deletions
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
index f48dba1882f2..82bd63545dfc 100644
--- a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
@@ -1,6 +1,5 @@
-diff -urN gpscorrelate-1.6.1.old/Makefile gpscorrelate-1.6.1/Makefile
---- gpscorrelate-1.6.1.old/Makefile 2011-06-08 13:51:06.000000000 +0200
-+++ gpscorrelate-1.6.1/Makefile 2011-06-08 14:13:18.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -4,11 +4,15 @@
COBJS = main-command.o unixtime.o gpx-read.o correlate.o exif-gps.o
@@ -10,13 +9,13 @@ diff -urN gpscorrelate-1.6.1.old/Makefile gpscorrelate-1.6.1/Makefile
-OFLAGS = -Wall
-override OFLAGS += $(shell pkg-config --libs libxml-2.0 gtk+-2.0) -lm -lexiv2
-prefix = /usr/local
-+CFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
-+CXXFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
-+CLIBS = $(shell pkg-config --libs libxml-2.0) -lm -lexiv2 -lstdc++
++CFLAGS += $(shell ${PKG_CONFIG} --cflags libxml-2.0) -I/usr/include/exiv2
++CXXFLAGS += $(shell ${PKG_CONFIG} --cflags libxml-2.0) -I/usr/include/exiv2
++CLIBS = $(shell ${PKG_CONFIG} --libs libxml-2.0) -lm -lexiv2 -lstdc++
+ifdef BUILD_GUI
-+CXXFLAGS += $(shell pkg-config --cflags gtk+-2.0)
-+CFLAGS += $(shell pkg-config --cflags gtk+-2.0)
-+CLIBS += $(shell pkg-config --libs gtk+-2.0)
++CXXFLAGS += $(shell ${PKG_CONFIG} --cflags gtk+-2.0)
++CFLAGS += $(shell ${PKG_CONFIG} --cflags gtk+-2.0)
++CLIBS += $(shell ${PKG_CONFIG} --libs gtk+-2.0)
+endif
+prefix ?= /usr/local
bindir = $(prefix)/bin