summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
commit404b23b9395fafe5c40a1fd4d859c6cd17b4a646 (patch)
tree789ba7b9b17a99ad3ccbf05a131086babface825 /sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
parent633a3741c9483bd63e8c29b276d2af636ec8b390 (diff)
gentoo auto-resync : 14:03:2024 - 06:47:03
Diffstat (limited to 'sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild')
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
index cfe639e603e8..7e4d5bf44ef1 100644
--- a/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake desktop xdg
+inherit cmake desktop flag-o-matic xdg
MY_PV="${PV//./_}"
MY_P="${PN}_${MY_PV}"
@@ -76,6 +76,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862576
+ # Fixed in newer versions: https://github.com/GPSBabel/gpsbabel/pull/824
+ filter-lto
+
local mycmakeargs=(
-DGPSBABEL_WITH_LIBUSB=pkgconfig
-DGPSBABEL_WITH_SHAPELIB=pkgconfig