summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsbabel/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/gpsbabel/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/gpsbabel/files')
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch12
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_statistic_uploading.patch11
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_update_check.patch108
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_version_check.patch45
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-1.patch105
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-2.patch70
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_shapelib.patch68
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_zlib.patch80
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-xmldoc.patch13
9 files changed, 512 insertions, 0 deletions
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch
new file mode 100644
index 000000000000..2ab8d5e10c69
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.4.3-fix_binary_name.patch
@@ -0,0 +1,12 @@
+Rename gpsbabelfe binary.
+--- gpsbabel-1.4.3/gui/app.pro
++++ gpsbabel-1.4.3/gui/app.pro
+@@ -30,7 +30,7 @@
+ TARGET=GPSBabelFE
+ QMAKE_LFLAGS_RELEASE += -static-libgcc
+ }
+-unix:TARGET=gpsbabelfe-bin
++unix:TARGET=gpsbabelfe
+ mac:TARGET=GPSBabelFE
+
+ FORMS += aboutui.ui
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_statistic_uploading.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_statistic_uploading.patch
new file mode 100644
index 000000000000..b65413c3d7c5
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_statistic_uploading.patch
@@ -0,0 +1,11 @@
+--- a/gui/babeldata.h 2017-01-02 06:05:19.000000000 +0100
++++ b/gui/babeldata.h 2017-01-21 00:33:30.858046004 +0100
+@@ -64,7 +64,7 @@
+ upgradeOffers_(0),
+ runCount_(0),
+ startupVersionCheck_(true),
+- reportStatistics_(true),
++ reportStatistics_(false),
+ allowBetaUpgrades_(false),
+ ignoreVersionMismatch_(false),
+ disableDonateDialog_(false),
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_update_check.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_update_check.patch
new file mode 100644
index 000000000000..b618106df3f0
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_update_check.patch
@@ -0,0 +1,108 @@
+Disable check for newer versions on start.
+
+--- a/gui/preferences.ui 2017-01-02 06:05:19.000000000 +0100
++++ b/gui/preferences.ui 2017-01-21 00:38:44.929972188 +0100
+@@ -40,13 +40,6 @@
+ </property>
+ <layout class="QVBoxLayout" name="verticalLayout_4">
+ <item>
+- <widget class="QCheckBox" name="startupCheck">
+- <property name="text">
+- <string>Check for newer version on start.</string>
+- </property>
+- </widget>
+- </item>
+- <item>
+ <widget class="QCheckBox" name="reportStatisticsCheck">
+ <property name="text">
+ <string>Anonymously report usage data.</string>
+--- a/gui/preferences.cc 2017-01-02 06:05:19.000000000 +0100
++++ b/gui/preferences.cc 2017-01-21 00:39:20.648418701 +0100
+@@ -39,7 +39,6 @@
+ {
+ ui_.setupUi(this);
+
+- ui_.startupCheck->setChecked(babelData_.startupVersionCheck_);
+ ui_.reportStatisticsCheck->setChecked(babelData_.reportStatistics_);
+ ui_.ignoreVersionMismatchCheck->setChecked(babelData_.ignoreVersionMismatch_);
+ // Because of an unfortunate bug in 1.4.0, we turn this off in 1.4.1.
+@@ -82,7 +81,6 @@
+ formatList_[i].setHidden(item->checkState() == Qt::Unchecked);
+ }
+
+- babelData_.startupVersionCheck_ = ui_.startupCheck->isChecked();
+ babelData_.reportStatistics_ = ui_.reportStatisticsCheck->isChecked();
+ babelData_.ignoreVersionMismatch_ = ui_.ignoreVersionMismatchCheck->isChecked();
+ accept();
+--- a/gui/babeldata.h 2017-01-21 00:33:30.858046004 +0100
++++ b/gui/babeldata.h 2017-01-21 00:40:03.888959247 +0100
+@@ -63,7 +63,7 @@
+ upgradeErrors_(0),
+ upgradeOffers_(0),
+ runCount_(0),
+- startupVersionCheck_(true),
++ startupVersionCheck_(false),
+ reportStatistics_(false),
+ allowBetaUpgrades_(false),
+ ignoreVersionMismatch_(false),
+--- a/gui/mainwinui.ui 2017-01-02 06:05:19.000000000 +0100
++++ b/gui/mainwinui.ui 2017-01-21 00:40:40.453416335 +0100
+@@ -637,7 +637,6 @@
+ <addaction name="actionHelp"/>
+ <addaction name="separator"/>
+ <addaction name="actionAbout"/>
+- <addaction name="actionUpgradeCheck"/>
+ <addaction name="separator"/>
+ <addaction name="actionVisit_Website"/>
+ <addaction name="actionMake_a_Donation"/>
+@@ -666,11 +665,6 @@
+ <string>Preferences...</string>
+ </property>
+ </action>
+- <action name="actionUpgradeCheck">
+- <property name="text">
+- <string>Check for Upgrade</string>
+- </property>
+- </action>
+ <action name="actionVisit_Website">
+ <property name="text">
+ <string>Visit Website...</string>
+--- a/gui/mainwindow.cc 2017-01-02 06:05:19.000000000 +0100
++++ b/gui/mainwindow.cc 2017-01-21 00:42:02.939447485 +0100
+@@ -147,7 +147,6 @@
+ connect(ui_.actionAbout, SIGNAL(triggered()), this, SLOT(aboutActionX()));
+ connect(ui_.actionVisit_Website, SIGNAL(triggered()), this, SLOT(visitWebsiteActionX()));
+ connect(ui_.actionMake_a_Donation, SIGNAL(triggered()), this, SLOT(donateActionX()));
+- connect(ui_.actionUpgradeCheck, SIGNAL(triggered()), this, SLOT(upgradeCheckActionX()));
+ connect(ui_.actionPreferences, SIGNAL(triggered()), this, SLOT(preferencesActionX()));
+
+ connect(ui_.inputFormatCombo, SIGNAL(currentIndexChanged(int)),
+@@ -208,17 +208,6 @@
+ restoreSettings();
+
+ upgrade = new UpgradeCheck(parent, formatList_, babelData_);
+- if (babelData_.startupVersionCheck_) {
+- upgrade->checkForUpgrade(babelVersion_, babelData_.upgradeCheckTime_,
+- allowBetaUpgrades());
+- }
+-
+- if (!babelData_.ignoreVersionMismatch_ && babelVersion_ != VERSION) {
+- VersionMismatch vm(0, babelVersion_, QString(VERSION));
+-
+- vm.exec();
+- babelData_.ignoreVersionMismatch_ = vm.neverAgain();
+- }
+ }
+
+ //------------------------------------------------------------------------
+@@ -1021,10 +1010,6 @@
+ //------------------------------------------------------------------------
+ void MainWindow::closeActionX()
+ {
+- QDateTime wt= upgrade->getUpgradeWarningTime();
+- if (wt.isValid()) {
+- babelData_.upgradeCheckTime_ = wt;
+- }
+ babelData_.runCount_++;
+
+ QDateTime now = QDateTime::currentDateTime();
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_version_check.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_version_check.patch
new file mode 100644
index 000000000000..e9d56d0a460b
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-disable_version_check.patch
@@ -0,0 +1,45 @@
+--- a/gui/preferences.ui 2017-01-21 00:38:44.929972188 +0100
++++ b/gui/preferences.ui 2017-01-21 00:50:05.314477610 +0100
+@@ -46,13 +46,6 @@
+ </property>
+ </widget>
+ </item>
+- <item>
+- <widget class="QCheckBox" name="ignoreVersionMismatchCheck">
+- <property name="text">
+- <string>Ignore mismatch between command line and GUI version.</string>
+- </property>
+- </widget>
+- </item>
+ </layout>
+ </widget>
+ </widget>
+--- a/gui/preferences.cc 2017-01-21 00:39:20.648418701 +0100
++++ b/gui/preferences.cc 2017-01-21 00:50:33.451829352 +0100
+@@ -40,7 +40,6 @@
+ ui_.setupUi(this);
+
+ ui_.reportStatisticsCheck->setChecked(babelData_.reportStatistics_);
+- ui_.ignoreVersionMismatchCheck->setChecked(babelData_.ignoreVersionMismatch_);
+ // Because of an unfortunate bug in 1.4.0, we turn this off in 1.4.1.
+ if (VERSION == QString("1.4.1"))
+ babelData_.ignoreVersionMismatch_ = false;
+@@ -82,7 +81,6 @@
+ }
+
+ babelData_.reportStatistics_ = ui_.reportStatisticsCheck->isChecked();
+- babelData_.ignoreVersionMismatch_ = ui_.ignoreVersionMismatchCheck->isChecked();
+ accept();
+ }
+
+--- a/gui/babeldata.h 2017-01-21 00:40:03.888959247 +0100
++++ b/gui/babeldata.h 2017-01-21 00:51:05.753233149 +0100
+@@ -66,7 +66,7 @@
+ startupVersionCheck_(false),
+ reportStatistics_(false),
+ allowBetaUpgrades_(false),
+- ignoreVersionMismatch_(false),
++ ignoreVersionMismatch_(true),
+ disableDonateDialog_(false),
+ donateSplashed_(QDateTime(QDate(2010, 1, 1), QTime(0, 0, 0)))
+ {
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-1.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-1.patch
new file mode 100644
index 000000000000..36db615f9dec
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-1.patch
@@ -0,0 +1,105 @@
+From 30a345577a644125502f6e4f8b58ea3077ec8dad Mon Sep 17 00:00:00 2001
+From: Robert Lipe <robertlipe@gpsbabel.org>
+Date: Mon, 4 Sep 2017 23:20:00 -0500
+Subject: [PATCH] Prefer QStringLiteral over implicit conversion from Latin1
+ for Q5 5.9. Based on work by Bernd Zeimetz.
+
+---
+ gpx.cc | 14 +++++++-------
+ magproto.cc | 6 +++---
+ unicsv.cc | 8 ++++----
+ 3 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/gpx.cc b/gpx.cc
+index 3b3b963c..36701e52 100644
+--- a/gpx.cc
++++ b/gpx.cc
+@@ -494,7 +494,7 @@ tag_cache_desc(const QXmlStreamAttributes& attr)
+ {
+ cache_descr_is_html = 0;
+ if (attr.hasAttribute("html")) {
+- if (attr.value("html").toString().compare("True") == 0) {
++ if (attr.value("html").toString() == QStringLiteral("True")) {
+ cache_descr_is_html = 1;
+ }
+ }
+@@ -509,16 +509,16 @@ tag_gs_cache(const QXmlStreamAttributes& attr)
+ gc_data->id = attr.value("id").toString().toInt();
+ }
+ if (attr.hasAttribute("available")) {
+- if (attr.value("available").toString().compare("True", Qt::CaseInsensitive) == 0) {
++ if (attr.value("available").toString().compare(QStringLiteral("True"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_available = status_true;
+- } else if (attr.value("available").toString().compare("False", Qt::CaseInsensitive) == 0) {
++ } else if (attr.value("available").toString().compare(QStringLiteral("False"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_available = status_false;
+ }
+ }
+ if (attr.hasAttribute("archived")) {
+- if (attr.value("archived").toString().compare("True", Qt::CaseInsensitive) == 0) {
++ if (attr.value("archived").toString().compare(QStringLiteral("True"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_archived = status_true;
+- } else if (attr.value("archived").toString().compare("False", Qt::CaseInsensitive) == 0) {
++ } else if (attr.value("archived").toString().compare(QStringLiteral("False"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_archived = status_false;
+ }
+ }
+@@ -972,7 +972,7 @@ gpx_end(const QString& el)
+ * last date we saw in this log.
+ */
+ case tt_cache_log_type:
+- if ((cdatastr.compare("Found it") == 0) &&
++ if ((cdatastr.compare(QStringLiteral("Found it")) == 0) &&
+ (0 == wpt_tmp->gc_data->last_found.toTime_t())) {
+ wpt_tmp->AllocGCData()->last_found = gc_log_date;
+ }
+@@ -1423,7 +1423,7 @@ fprint_xml_chain(xml_tag* tag, const Waypoint* wpt)
+ fprint_xml_chain(tag->child, wpt);
+ }
+ if (wpt && wpt->gc_data->exported.isValid() &&
+- tag->tagname.compare("groundspeak:cache") == 0) {
++ tag->tagname.compare(QStringLiteral("groundspeak:cache")) == 0) {
+ writer->writeTextElement("time",
+ wpt->gc_data->exported.toPrettyString());
+ }
+diff --git a/magproto.cc b/magproto.cc
+index 7c82e9fb..0deb7f33 100644
+--- a/magproto.cc
++++ b/magproto.cc
+@@ -819,11 +819,11 @@ mag_rd_init_common(const QString& portname)
+ */
+ QString exten = QFileInfo(curfname).suffix();
+ if (exten.length() > 0) {
+- if (0 == exten.compare("upt", Qt::CaseInsensitive)) {
++ if (0 == exten.compare(QStringLiteral("upt"), Qt::CaseInsensitive)) {
+ extension_hint = WPTDATAMASK;
+- } else if (0 == exten.compare("log", Qt::CaseInsensitive)) {
++ } else if (0 == exten.compare(QStringLiteral("log"), Qt::CaseInsensitive)) {
+ extension_hint = TRKDATAMASK;
+- } else if (0 == exten.compare("rte", Qt::CaseInsensitive)) {
++ } else if (0 == exten.compare(QStringLiteral("rte"), Qt::CaseInsensitive)) {
+ extension_hint = RTEDATAMASK;
+ }
+ }
+diff --git a/unicsv.cc b/unicsv.cc
+index 4a7d78ed..6312e9d2 100644
+--- a/unicsv.cc
++++ b/unicsv.cc
+@@ -430,13 +430,13 @@ unicsv_parse_time(const QString& str, int* msec, time_t* date)
+ static status_type
+ unicsv_parse_status(const QString& str)
+ {
+- if (str.compare("true", Qt::CaseInsensitive) == 0 ||
+- str.compare("yes", Qt::CaseInsensitive) == 0 ||
++ if (str.compare(QStringLiteral("true"), Qt::CaseInsensitive) == 0 ||
++ str.compare(QStringLiteral("yes"), Qt::CaseInsensitive) == 0 ||
+ str == "1") {
+ return status_true;
+ }
+- if (str.compare("false", Qt::CaseInsensitive) == 0 ||
+- str.compare("no", Qt::CaseInsensitive) == 0 ||
++ if (str.compare(QStringLiteral("false"), Qt::CaseInsensitive) == 0 ||
++ str.compare(QStringLiteral("no"), Qt::CaseInsensitive) == 0 ||
+ str == "0") {
+ return status_false;
+ }
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-2.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-2.patch
new file mode 100644
index 000000000000..ce1b0489146f
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9-2.patch
@@ -0,0 +1,70 @@
+From 604178aa8ad4d3c3ad218df24c1e9a6a1f683bb3 Mon Sep 17 00:00:00 2001
+From: Harel Mazor <harel.mazor@gmail.com>
+Date: Tue, 24 Jan 2017 00:35:04 +0200
+Subject: [PATCH] Added geojson read capablity, moved magic strings to
+ constants, fixed windows compilation issues.
+
+---
+ tef_xml.cc | 24 +++----
+
+* Removed any unrelated changes except for s/windows/Qt-5.9/ compilation issues.
+
+diff --git a/tef_xml.cc b/tef_xml.cc
+index b32d69b3..37dd85ba 100644
+--- a/tef_xml.cc
++++ b/tef_xml.cc
+@@ -72,11 +72,11 @@ tef_start(xg_string args, const QXmlStreamAttributes* attrv)
+ bool valid = false;
+
+ foreach(QXmlStreamAttribute attr, *attrv) {
+- if (attr.name().compare("Comment", Qt::CaseInsensitive) == 0) {
+- if (attr.value().compare("TourExchangeFormat", Qt::CaseInsensitive) == 0) {
++ if (attr.name().compare(QString("Comment"), Qt::CaseInsensitive) == 0) {
++ if (attr.value().compare(QString("TourExchangeFormat"), Qt::CaseInsensitive) == 0) {
+ valid = true;
+ }
+- } else if (attr.name().compare("Version", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QString("Version"), Qt::CaseInsensitive) == 0) {
+ version = attr.value().toString().toDouble();
+ }
+ }
+@@ -95,9 +95,9 @@ tef_header(xg_string args, const QXmlStreamAttributes* attrv)
+ {
+ route = route_head_alloc();
+ foreach(QXmlStreamAttribute attr, *attrv) {
+- if (attr.name().compare("Name", Qt::CaseInsensitive) == 0) {
++ if (attr.name().compare(QString("Name"), Qt::CaseInsensitive) == 0) {
+ route->rte_name = attr.value().toString().trimmed();
+- } else if (attr.name().compare("Software", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QString("Software"), Qt::CaseInsensitive) == 0) {
+ route->rte_desc = attr.value().toString().trimmed();
+ }
+ }
+@@ -248,20 +248,20 @@ tef_item_start(xg_string args, const QXmlStreamAttributes* attrv)
+ QString attrstr = attr.value().toString();
+ QByteArray attrtext = attrstr.toUtf8();
+
+- if (attr.name().compare("SegDescription", Qt::CaseInsensitive) == 0) {
++ if (attr.name().compare(QString("SegDescription"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->shortname = attrstr.trimmed();
+- } else if (attr.name().compare("PointDescription", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QString("PointDescription"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->description = attrstr.trimmed();
+- } else if (attr.name().compare("ViaStation", Qt::CaseInsensitive) == 0 &&
+- attr.value().compare("true", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QString("ViaStation"), Qt::CaseInsensitive) == 0 &&
++ attr.value().compare(QString("true"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->wpt_flags.fmt_use = 1; /* only a flag */
+
+ /* new in TEF V2 */
+- } else if (attr.name().compare("Instruction", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QString("Instruction"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->description = attrstr.trimmed();
+- } else if (attr.name().compare("Altitude", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QString("Altitude"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->altitude = attrstr.toDouble();
+- } else if (attr.name().compare("TimeStamp", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QString("TimeStamp"), Qt::CaseInsensitive) == 0) {
+ /* nothing for the moment */
+ }
+ }
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_shapelib.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_shapelib.patch
new file mode 100644
index 000000000000..d3a4fa0c16a3
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_shapelib.patch
@@ -0,0 +1,68 @@
+--- a/configure.in 2017-01-02 06:05:19.000000000 +0100
++++ b/configure.in 2017-01-21 00:26:02.239786037 +0100
+@@ -402,7 +402,7 @@
+ AC_SUBST(QT_SYSINC_OPT)
+ AC_SUBST(QT_LIBS)
+
+-AC_CONFIG_FILES([Makefile gbversion.h gui/setup.iss xmldoc/makedoc tools/mkcapabilities win32/gpsbabel.rc jeeps/Makefile shapelib/Makefile zlib/empty])
++AC_CONFIG_FILES([Makefile gbversion.h gui/setup.iss xmldoc/makedoc tools/mkcapabilities win32/gpsbabel.rc jeeps/Makefile zlib/empty])
+ AC_CONFIG_FILES([gui/makelinuxdist.sh], [chmod +x gui/makelinuxdist.sh])
+ AC_OUTPUT
+
+--- a/Makefile.in 2017-01-02 06:05:19.000000000 +0100
++++ b/Makefile.in 2017-01-21 00:29:05.715731486 +0100
+@@ -100,7 +100,7 @@
+ # Extra modules in Jeeps that we don't use
+ # jeeps/gpsfmt.o jeeps/gpsinput.o jeeps/gpsproj.o
+
+-SHAPE=shapelib/shpopen.o shapelib/dbfopen.o shapelib/safileio.o
++SHAPE=-lshp
+
+ MINIZIP=zlib/contrib/minizip/zip.o \
+ zlib/contrib/minizip/ioapi.o
+@@ -119,7 +119,7 @@
+ src/core/xmlstreamwriter.o \
+ src/core/usasciicodec.o\
+ src/core/ziparchive.o \
+- $(GARMIN) $(JEEPS) $(SHAPE) @ZLIB@ $(FMTS) $(FILTERS)
++ $(GARMIN) $(JEEPS) @ZLIB@ $(FMTS) $(FILTERS)
+ OBJS = main.o globals.o $(LIBOBJS) @FILEINFO@
+
+ DEPFILES = $(OBJS:.o=.d)
+@@ -148,10 +148,10 @@
+ all: gpsbabel$(EXEEXT)
+
+ gpsbabel$(EXEEXT): configure Makefile $(OBJS) @GPSBABEL_DEBUG@
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
+
+ gpsbabel-debug: $(OBJS)
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) @LIBS@ @EFENCE_LIB@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) @LIBS@ @EFENCE_LIB@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
+
+ Makefile gbversion.h: Makefile.in config.status xmldoc/makedoc.in \
+ gbversion.h.in gui/setup.iss.in
+@@ -894,11 +894,7 @@
+ session.o: session.cc defs.h config.h queue.h zlib/zlib.h zlib/zconf.h \
+ gbfile.h cet.h inifile.h session.h src/core/datetime.h
+ shape.o: shape.cc defs.h config.h queue.h zlib/zlib.h zlib/zconf.h \
+- gbfile.h cet.h inifile.h session.h src/core/datetime.h \
+- shapelib/shapefil.h
+-shapelib/dbfopen.o: shapelib/dbfopen.c shapelib/shapefil.h
+-shapelib/safileio.o: shapelib/safileio.c shapelib/shapefil.h
+-shapelib/shpopen.o: shapelib/shpopen.c shapelib/shapefil.h
++ gbfile.h cet.h inifile.h session.h src/core/datetime.h
+ skyforce.o: skyforce.cc defs.h config.h queue.h zlib/zlib.h zlib/zconf.h \
+ gbfile.h cet.h inifile.h session.h src/core/datetime.h
+ skytraq.o: skytraq.cc defs.h config.h queue.h zlib/zlib.h zlib/zconf.h \
+--- a/shape.cc 2017-01-02 06:05:19.000000000 +0100
++++ b/shape.cc 2017-01-21 00:29:58.514391517 +0100
+@@ -20,7 +20,7 @@
+
+ */
+ #include "defs.h"
+-#include "shapelib/shapefil.h"
++#include <libshp/shapefil.h>
+ #include <stdlib.h>
+
+ #if SHAPELIB_ENABLED
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_zlib.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_zlib.patch
new file mode 100644
index 000000000000..ce3591715492
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-use_system_zlib.patch
@@ -0,0 +1,80 @@
+--- a/configure.in 2017-01-21 03:17:05.480317203 +0100
++++ b/configure.in 2017-01-21 03:26:53.743671224 +0100
+@@ -402,7 +402,7 @@
+ AC_SUBST(QT_SYSINC_OPT)
+ AC_SUBST(QT_LIBS)
+
+-AC_CONFIG_FILES([Makefile gbversion.h gui/setup.iss xmldoc/makedoc tools/mkcapabilities win32/gpsbabel.rc jeeps/Makefile zlib/empty])
++AC_CONFIG_FILES([Makefile gbversion.h gui/setup.iss xmldoc/makedoc tools/mkcapabilities win32/gpsbabel.rc jeeps/Makefile])
+ AC_CONFIG_FILES([gui/makelinuxdist.sh], [chmod +x gui/makelinuxdist.sh])
+ AC_OUTPUT
+
+--- a/Makefile.in 2017-01-21 03:17:05.530317828 +0100
++++ b/Makefile.in 2017-01-21 03:32:19.447032690 +0100
+@@ -102,14 +102,7 @@
+
+ SHAPE=-lshp
+
+-MINIZIP=zlib/contrib/minizip/zip.o \
+- zlib/contrib/minizip/ioapi.o
+-
+-ZLIB=zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o zlib/inffast.o \
+- zlib/inflate.o zlib/infback.o zlib/inftrees.o zlib/trees.o \
+- zlib/uncompr.o zlib/gzlib.o zlib/gzclose.o zlib/gzread.o \
+- zlib/gzwrite.o zlib/zutil.o $(MINIZIP)
+-
++ZLIB=-lz -lminizip
+
+ LIBOBJS = queue.o route.o waypt.o filter_vecs.o util.o vecs.o mkshort.o \
+ csv_util.o strptime.o grtcirc.o util_crc.o xmlgeneric.o \
+@@ -119,7 +112,7 @@
+ src/core/xmlstreamwriter.o \
+ src/core/usasciicodec.o\
+ src/core/ziparchive.o \
+- $(GARMIN) $(JEEPS) @ZLIB@ $(FMTS) $(FILTERS)
++ $(GARMIN) $(JEEPS) $(FMTS) $(FILTERS)
+ OBJS = main.o globals.o $(LIBOBJS) @FILEINFO@
+
+ DEPFILES = $(OBJS:.o=.d)
+@@ -148,10 +141,10 @@
+ all: gpsbabel$(EXEEXT)
+
+ gpsbabel$(EXEEXT): configure Makefile $(OBJS) @GPSBABEL_DEBUG@
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) $(ZLIB) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
+
+ gpsbabel-debug: $(OBJS)
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) @LIBS@ @EFENCE_LIB@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) $(ZLIB) @LIBS@ @EFENCE_LIB@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
+
+ Makefile gbversion.h: Makefile.in config.status xmldoc/makedoc.in \
+ gbversion.h.in gui/setup.iss.in
+--- a/src/core/ziparchive.cc 2017-01-02 06:05:19.000000000 +0100
++++ b/src/core/ziparchive.cc 2017-01-21 03:51:30.402421165 +0100
+@@ -23,7 +23,7 @@
+
+ #include "defs.h"
+ #include "src/core/logging.h"
+-#include "zlib/contrib/minizip/zip.h"
++#include <minizip/zip.h>
+
+ #include <QtCore/QFile>
+ #include <QtCore/QDebug>
+@@ -89,4 +89,4 @@
+ return true;
+ }
+ return false;
+-}
+\ No newline at end of file
++}
+--- a/src/core/ziparchive.h 2017-01-02 06:05:19.000000000 +0100
++++ b/src/core/ziparchive.h 2017-01-21 03:51:05.931115241 +0100
+@@ -21,7 +21,7 @@
+
+ #include <QtCore/QString>
+ #include <QtCore/QStringList>
+-#include "zlib/contrib/minizip/zip.h"
++#include <minizip/zip.h>
+
+ class ZipArchive
+ {
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-xmldoc.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-xmldoc.patch
new file mode 100644
index 000000000000..3fdd274927eb
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-xmldoc.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.in 2017-01-21 00:32:50.921546762 +0100
++++ b/Makefile.in 2017-01-21 00:55:45.362728521 +0100
+@@ -278,8 +278,8 @@
+ --stringparam html.cleanup "1" \
+ --stringparam make.clean.html "1" \
+ --stringparam html.valid.html "1" \
+- --stringparam html.stylesheet \
+- "http://www.gpsbabel.org/style3.css" \
++ --nonet \
++ --stringparam html.stylesheet "gpsbabel.org-style3.css" \
+ http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
+ xmldoc/readme.xml
+